SRU : Please release choqok 0.9.85 for lucid

Bug #654236 reported by Rohan Garg on 2010-10-03
20
This bug affects 5 people
Affects Status Importance Assigned to Milestone
choqok (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: choqok

Twitter changed its authentication mechanism due to which clients which do not support authentication via OAuth become useless.
Lucid currently has choqok version 0.9.55a-0ubuntu1 which does not support authentication via OAuth thereby breaking twitter integration.
This bug has been addressed in Maverick by uploading qoauth and choqok 0.9.85 which support authentication via OAuth.
In order to fix this, we need to release choqok 0.9.85 and qoauth 1.0 for lucid, packages can be found at : https://edge.launchpad.net/~rohangarg/+archive/experimental/+packages
In order to reproduce bug : Install Choqok -> Try to add a twitter account, choqok wont be able to read and post tweets
TEST CASE
1) Install choqok 0.9.85
2) Add twitter account
More info at : http://dev.twitter.com/announcements

Rohan Garg (rohangarg) wrote :

The choqok debdiff between package in my PPA and the current lucid package, its huge because these are 2 septate upstream releases

description: updated
Rohan Garg (rohangarg) wrote :

Also see bug 628200

Rohan Garg (rohangarg) wrote :

Install log for choqok

Rohan Garg (rohangarg) wrote :

Debdiff with correct changelog

Rohan Garg (rohangarg) on 2010-10-03
Changed in choqok (Ubuntu):
status: New → Confirmed
Changed in choqok (Ubuntu Lucid):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Closing maverick task, fixed there.

Changed in choqok (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

This has tons of unrelated changes, including UI changes, new features, new backends, new modules, etc. Thus this has a lot of regression potential. Is it possible in any way to just backport the move to oauth? We'd still need a backport of qoauth of course (bug 654241), but since that's a new package the regression potential is low.

If backporting doesn't work, then from my perspective we can also do the full jump, but in that case I'd like to get a second ack from another SRU team member.

In any case, please upload the two packages, so that they are ready for review. Thanks!

Jonathan Riddell (jr) wrote :

Uploaded choqok_0.9.85-0ubuntu2~lucid1 to lucid-proposed, waiting approval

Unfortunately it's not possible to backport the oauth mechanism to the version in lucid

Accepted choqok into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in choqok (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Daniel Albers (al) wrote :

Working fine for me, not seeing any regressions.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package choqok - 0.9.85-0ubuntu2~lucid1

---------------
choqok (0.9.85-0ubuntu2~lucid1) lucid-proposed; urgency=low

  * Release for lucid-proposed (LP: #654236)
 -- Rohan Garg <email address hidden> Mon, 04 Oct 2010 01:25:56 +0530

Changed in choqok (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers