Choqok will not with twitter - updated API

Bug #1220049 reported by Phil Wyett on 2013-09-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
choqok (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

Choqok cannot communicate with twitter.

No tweets are downloaded.

Attempting to post a message, I get:

choqok(2388): Creating post: XML parsing error: "<?xml version="1.0" encoding="UTF-8"?><errors> <error code="68">The Twitter REST API v1 is no longer active. Please migrate to API v1.1. https://dev.twitter.com/docs/api/1.1/overview.</error></errors>"

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: choqok 1.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-52.78-generic 3.2.48
Uname: Linux 3.2.0-52-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
Date: Tue Sep 3 06:21:33 2013
InstallationMedia: Kubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: choqok
UpgradeStatus: No upgrade log present (probably fresh install)

Phil Wyett (u-k-i-t) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in choqok (Ubuntu):
status: New → Confirmed
Changed in choqok (Ubuntu):
status: Confirmed → Triaged
Changed in choqok (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → High
Changed in choqok (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package choqok - 1.4-1ubuntu1

---------------
choqok (1.4-1ubuntu1) trusty; urgency=low

  * Merge from Debian unstable. (LP: #1254058) Remaining changes:
    - debian/patches/kubuntu_01_consumerkey.diff:
      + Switch to custom Kubuntu OAuth id.
  * Drop B-D libattica-dev (>= 0.4.1) as trusty got already 0.4.2.
  * Upload fixes:
    - New upstream release. (LP: #1225133)
    - Support Twitter API 1.1. (LP: #1220049)
 -- Artur Rona <email address hidden> Fri, 22 Nov 2013 15:11:10 +0100

Changed in choqok (Ubuntu):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in choqok (Ubuntu Saucy):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers