chntpw fails on x86_64

Bug #293809 reported by Jason Mansfield on 2008-11-04
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gentoo Linux
Won't Fix
chntpw (Debian)
Fix Released
chntpw (Mandriva)
chntpw (Ubuntu)
Philippe Coval
Nominated for Jaunty by Alan

Bug Description

Binary package hint: chntpw

I attempt to load valid registry files on my Core2Duo system:

jason@grendel:/media/sda1/WINDOWS/system32/config$ sudo chntpw -e software
chntpw version 0.99.3 040818, (c) Petter N Hagen
openHive(software): File does not seem to be a registry hive!
Simple registry editor. ? for help.
get_abs_path: Not a 'nk' node!

[0] >

I attempt the same file on a P4 system:

jason@stitches:/tmp$ chntpw software
chntpw version 0.99.3 040818, (c) Petter N Hagen
openHive(software) failed: Permission denied, trying read-only
Hive's name (from header): <emRoot\System32\Config\SOFTWARE>
ROOT KEY at offset: 0x001020 * Subkey indexing type is: 686c <lh>
Page at 0x143e000 is not 'hbin', assuming file contains garbage at end
File size 21233664 [1440000] bytes, containing 4909 pages (+ 1 headerpage)
Used for data: 393286/20853496 blocks/bytes, unused: 3323/210792 blocks/bytes.
Simple registry editor. ? for help.

[1020] >

The first system:
jason@grendel:/usr/share/doc/chntpw$ uname -a
Linux grendel 2.6.24-21-generic #1 SMP Mon Aug 25 16:57:51 UTC 2008 x86_64 GNU/Linux

The second system:
jason@stitches:/tmp$ uname -a
Linux stitches 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux

Both systems have:
ii chntpw 0.99.3-1 NT SAM password recovery utility

Both are:
Description: Ubuntu 8.04.1
Release: 8.04

Xepra (xepra) wrote :

Bug confirmed on x86_64 8.10

/media/disk/WINDOWS/system32/config$ chntpw -u hasan SAM
chntpw version 0.99.5 070923 (decade), (c) Petter N Hagen
openHive(SAM): File does not seem to be a registry hive!
Simple registry editor. ? for help.
get_abs_path: Not a 'nk' node!

Alan (mrintegrity) wrote :

I can confirm this bug on jaunty.

chntpw version 0.99.5 070923 (decade), (c) Petter N Hagen

>>:/media/windowsXP/WINDOWS/system32/config# lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty
>>:/media/windowsXP/WINDOWS/system32/config# uname -a
Linux alkjhdfkh 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

Christian (cb-256bit) wrote :

I have been bitten by the same bug. Until this problem is fixed, could you please include chntpw.static from Upstreams source package? I have been using it to successfully reset my password


I'm experiencing the same Problem in (x)ubuntu jaunty (9.04), hope someone who could feel responsible notices that soon, because a command-line Registry-Editor is important to me.

Druciferre (drewchapin) wrote :

I too can confirm this bug. I have not been able to find a solution on Google either. Any prospects on when/if this will be fixed ?

$ uname -a
Linux anubis 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 01:19:55 UTC 2009 x86_64 GNU/Linux

AraKs (aracnew) wrote :

Confirmed on core2 duo, with Ubuntu 9.04 and 9.10 x86_64.
With Ubuntu 9.10 x86 works.

Linus C Unneback (linusu) wrote :

It seems like this issue was fixed upstream in version 0.99.6 (2008-mar) but the version used by Ubuntu (all versions, including current Lucid) is only 0.99.5 (2007-sep). The easiest way to resolve this issue would therefor be to bring Ubuntu up to date with the newer version.

//Linus Unnebäck

Tomas Pospisek (tpo-deb) wrote :

It seems there is a new upstream release here:

which also fixes a 64bit bug:

So it would "only" be a question of rebuilding from the new release?

Debian tracks the same bug here:


falstaff (falstaff) wrote :

I can confirm this bug on karmic. As far as I see the things its also in lucid (same version according to, so it would be nice if it gets fixed in lucid at least (which will be a LTS release)

Philippe Coval (rzr) wrote :

Ok I did most of the job, I waiting to upload it to debian first then I'll request a sync

Changed in chntpw (Ubuntu):
assignee: nobody → Philippe Coval (rzr)
Changed in gentoo:
status: Unknown → Won't Fix
Philippe Coval (rzr) wrote :


I just requested a sync from debian's unstable :

it includes my patches


Changed in chntpw (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chntpw - 0.99.6-2

chntpw (0.99.6-2) unstable; urgency=low

  * Add patches provided by Fedora to fix regex -x crahses, see
    The patches included are:

chntpw (0.99.6-1) unstable; urgency=low

  * New upstream release (Closes: #503908)
     - Fixes bug in 64-bit architectures (Closes: #539227) (LP: #293809)
  * Create debian/README.source to describe the usage of quilt
  * Update FAQ contents with latest upstream version (updated 080526)
  * Move the "improve documentation" patch to quilt, it is currently
    disabled until we get an answer from upstream
  * Definition of optimisation for the compiler is now done in debian/rules
    and not in the Makefile
  * Update homepage location and upstream's email in debian/copyright
  * Update homepage location in the manpage
  [ Changes by Philippe Coval <email address hidden> ]
  * Merged Tanguy Ortolo's manpage patch that updates
    the debian/chntpwd.8 manpage with additional information such as the
    SAM database location (Closes: #569943)
  * Refresh debian/patches (Closes: #538574)
  * Add debian/watch
 -- Ubuntu Archive Auto-Sync <email address hidden> Sun, 09 May 2010 13:45:42 +0100

Changed in chntpw (Ubuntu):
status: New → Fix Released
Changed in gentoo:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.