childsplay does not start on Trusty (14.04)

Bug #1316557 reported by Yannis Tsop on 2014-05-06
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
childsplay (Debian)
Fix Released
Unknown
childsplay (Ubuntu)
Critical
Unassigned
Trusty
Critical
Simon Quigley

Bug Description

[Impact]
Without this fix, childsplay is completely unusable.

[Test Case]
1. Try to open childsplay.
It should open correctly. Instead, it segfaults immediately.

[Regression Potential]
Extremely unlikely, but things could regress in the off chance that sqlalchemy is changed in a breaking way as part of an update.

[Original Description]
$ /usr/games/childsplay

Traceback (most recent call last):
  File "/usr/games/childsplay", line 118, in <module>
    import childsplay_sp.SPMainCore as SPMainCore
  File "/usr/lib/python2.7/dist-packages/childsplay_sp/SPMainCore.py", line 64, in <module>
    from sqlalchemy import exceptions as sqla_exceptions
ImportError: cannot import name exceptions

running childsplay on 14.04 you get an error. This is due to some changes in libraries.

Yannis Tsop (ogiannhs) wrote :

The attachment "Fix for installed files" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Pierre (pierrewinnipeg) wrote :

Affect me too. Could not start in 13.10 either and WAS REPORTED THEN.

That is an important package. Please fix package with patch in repository so we do not have to wait till 14.10 is out.

Even major packages in Ubuntu take over a year to patch... bad for Ubuntu reputation.

Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in childsplay (Ubuntu):
status: New → Confirmed

Affects me as well. Just did a new install of 14.04. My daughters favorite software. Looking forward to a fix.

Thanks,

Onno Zweers (onnozweers) wrote :

I had the same issue. To satisfy my kids I applied the fix of Yannis Tsop (comment #1) by hand. It worked perfectly, thanks Yannis!

For who has impatient children too:

  sudo nano /usr/lib/python2.7/dist-packages/childsplay_sp/SPMainCore.py

Search for the line:

  from sqlalchemy import exceptions as sqla_exceptions

Replace it with:

  from sqlalchemy import exc as sqla_exceptions

omvsj (omvsj) wrote :

Comment #6 solved it.

Kevin Williams (bthylafh) wrote :

Onno Zweers's suggestion fixed it for me as well.

xoristzatziki (simsonbike-bugs) wrote :

Onno Zweers's suggestion fixed it for me as well.

oposit (julio-poisot) wrote :

Thank you for the solution in comment #6, but I have to edit /usr/share/pyshared/childsplay_sp/SPMainCore.py

I have just installed Childsplay and is having the same error.

Tomasz Pudlo (tpudlo) wrote :

Thank you Yannis (#1) and Onno (#6) :-) Works perfectly.

Rolf Leggewie (r0lf) wrote :

This problem still affects Trusty but later releases should have seen a fix (new upsteam release)

Changed in childsplay (Ubuntu):
importance: Undecided → Critical
Changed in childsplay (Debian):
status: Unknown → Fix Released
Simon Quigley (tsimonq2) on 2017-12-03
Changed in childsplay (Ubuntu):
status: Confirmed → Fix Released
Changed in childsplay (Ubuntu Trusty):
status: New → Fix Released
status: Fix Released → Confirmed
importance: Undecided → Critical
assignee: nobody → Simon Quigley (tsimonq2)
tags: removed: patch
Simon Quigley (tsimonq2) on 2017-12-06
description: updated

Hello Yannis, or anyone else affected,

Accepted childsplay into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/childsplay/1.6-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in childsplay (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.