Remove unsupported release from Precise

Bug #948437 reported by Bryan McLellan on 2012-03-06
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chef (Ubuntu)
High
Unassigned
Precise
High
Unassigned
mcollective-plugins (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

The 0.8.16 release of Chef currently in Precise is very old and unsupported. It should be removed from the repository and not included in the Precise (12.04) release. Praveen Arimbrathodiyil has been working on getting a more recent release into Debian but it will not be ready in time for Precise.

Instructions for installing the latest version of Ohai from the external Opscode apt repository are available on the Opscode wiki: http://wiki.opscode.com/display/chef/Installing+Chef+Client+on+Ubuntu+or+Debian

Changed in chef (Ubuntu Precise):
importance: Undecided → Critical
status: New → Confirmed
importance: Critical → High
Antonio Rosales (arosales) wrote :

Subscribing ubuntu-archive to help with the requested removal of Chef for Precise.

Colin Watson (cjwatson) wrote :

-- precise/universe amd64 deps on chef:
mcollective-plugins-facts-ohai
-- precise/universe i386 deps on chef:
mcollective-plugins-facts-ohai
-- precise/universe armel deps on chef:
mcollective-plugins-facts-ohai
-- precise/universe armhf deps on chef:
mcollective-plugins-facts-ohai
-- precise/universe powerpc deps on chef:
mcollective-plugins-facts-ohai

Please resolve this first; since that's just one binary package from a source package that builds many others, the source package needs to be changed.

Marc Cluet (lynxman) wrote :

Here's the debdiff for mcollective-plugins_0.0.0~git20120105.9b90c2b-0ubuntu2 which removes ohai

The attachment "mcollective-plugins_0.0.0~git20120105.9b90c2b-0ubuntu2.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Colin Watson (cjwatson) wrote :

Looks good to me, thanks. Uploaded.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mcollective-plugins - 0.0.0~git20120105.9b90c2b-0ubuntu2

---------------
mcollective-plugins (0.0.0~git20120105.9b90c2b-0ubuntu2) precise; urgency=low

  * Removed facts ohai package (LP: #948437)
 -- Marc Cluet <email address hidden> Fri, 09 Mar 2012 16:59:09 +0000

Changed in mcollective-plugins (Ubuntu Precise):
status: New → Fix Released
Fabrice Coutadeur (fabricesp) wrote :

Unsubscribing sponsors from the bug report as the only piece that required sponsoring has been already uploaded.

Thanks for your work!

Fabrice

Jonathan Riddell (jr) wrote :

removed

Changed in chef (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers