[Oneiric] Cheese won't start (Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context)

Bug #890503 reported by Jacopo Lorenzetti on 2011-11-15
96
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Clutter
New
Undecided
Unassigned
cheese (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to run Cheese I receive this error message in the terminal:

Clutter-CRITICAL **: Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context: Unable to find fbconfig with rgba visual

Everything worked fine with Cheese 2.32 in Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: cheese 3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Nov 15 02:13:59 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: ASUSTeK Computer INC. A7N8X-X
RelatedPackageVersions:
 cheese 3.2.0-0ubuntu2
 cheese-common 3.2.0-0ubuntu2
SourcePackage: cheese
UpgradeStatus: Upgraded to oneiric on 2011-11-04 (10 days ago)
dmi.bios.date: 08/04/2004
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS A7N8X-X ACPI BIOS Rev 1011
dmi.board.name: A7N8X-X
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: REV 2.xx
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufactture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSA7N8X-XACPIBIOSRev1011:bd08/04/2004:svnASUSTeKComputerINC.:pnA7N8X-X:pvrREV2.xx:rvnASUSTeKComputerINC.:rnA7N8X-X:rvrREV2.xx:cvnChassisManufactture:ct3:cvrChassisVersion:
dmi.product.name: A7N8X-X
dmi.product.version: REV 2.xx
dmi.sys.vendor: ASUSTeK Computer INC.

Jacopo Lorenzetti (jacopol) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cheese (Ubuntu):
status: New → Confirmed
João Santana (joaosantana) wrote :

Adding dgb-cheese.txt, if useful.

David Ayers (ayers) wrote :

I'm also having this issue on Dell mini 12 that originally came with Ubuntu pre-installed.

Wim Jansen (wim-jansen) wrote :

The same problem for me:

(cheese:1956): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context: Unable to find fbconfig with rgba visual

Lets hope for a quick solution,

Wim Jansen

Jacopo Lorenzetti (jacopol) wrote :

Fixed in libclutter-1.0 version 1.8.2-2

Committed in master on 2011-11-01: http://git.gnome.org/browse/clutter/commit/?id=db53ca382c5db10fa19f93761b8f898b20a4534f
Committed in 1.8 on 2011-11-01: http://git.gnome.org/browse/clutter/commit/?id=db53ca382c5db10fa19f93761b8f898b20a4534f
Imported in Debian on 2011-11-14: http://comments.gmane.org/gmane.linux.debian.devel.gnome.scm/18290
Imported in Ubuntu (Precise) on 2011-11-16: https://launchpad.net/ubuntu/+source/clutter-1.0/1.8.2-2

Will it take long to see it in oneiric-proposed? Can I help testing something?

Have somebody any idea how start cheese?

Jacopo Lorenzetti (jacopol) wrote :

I tried backporting clutter-1.0 from Precise with Prevu but I didn't have any luck.

David Ayers (ayers) wrote :

This is a regression for my Dell Mini 12
Bus 001 Device 003: ID 064e:a118 Suyin Corp.
it worked on at least: Lucid, Maverick and Natty
(see duplicate bug #918439 for technical details)

Aaron Sun (hisycg) wrote :

The same problem here

Aaron Sun (hisycg) wrote :

Is there any temporary solution?

giardia (fabriziosm) wrote :

The same error message appears when i try to play the gnome-game "Quadrapassel" , is it linked in some way or should i open another bug for that?

David Ayers (ayers) wrote :

I can confirm that this issue is fixed for me in Precise.

giardia (fabriziosm) wrote :

also for me, no more "Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context" message.

cheese start in precise (and also quadrapassel game (see#14) )

but the problem now is that the camera is not working...

:~$ cheese

(cheese:3444): Gtk-WARNING **: Attempting to add a widget with type GtkImage to a GtkToggleButton, but as a GtkBin subclass a GtkToggleButton can only contain one widget at a time; it already contains a widget of type GtkLabel

[...]

** (cheese:3444): WARNING **: Could not negotiate format

cheese show black screen even if the webcam is connected...

my webcam: Bus 002 Device 002: ID 046d:092e Logitech, Inc. QuickCam Chat

it works in skype and empathy but not in cheese...same problem for you? other related bugs?

Changed in cheese (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions