picture from webcam has no color and some artifacts

Bug #888633 reported by c. mehlis on 2011-11-10
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Cheese
New
Undecided
Unassigned
cheese (Ubuntu)
Undecided
Unassigned

Bug Description

webcam should be a 720p cam in a thinkpad L420

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: cheese 3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Nov 10 17:59:47 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 78544VG
RelatedPackageVersions:
 cheese 3.2.0-0ubuntu2
 cheese-common 3.2.0-0ubuntu2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/16/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8GET36WW (1.13 )
dmi.board.name: 78544VG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8GET36WW(1.13):bd08/16/2011:svnLENOVO:pn78544VG:pvrThinkPadL420:rvnLENOVO:rn78544VG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 78544VG
dmi.product.version: ThinkPad L420
dmi.sys.vendor: LENOVO

a sample picture from cheese

this shows my ceiling with a lamp

updated bios to newest versoin (1.14) and used newest upstream kernel v3.1-oneiric

bug not fixed

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cheese (Ubuntu):
status: New → Confirmed
Prunus dulcis (prunus-dulcis) wrote :

When I change the resolution to a lower one, e.g. 640+480, the artifacts go away and colors are there again correctly.

Robb (robb-dawson-gmail) wrote :

Tried the lower resolution, but had not success. Colors and artifacts are still present. Mplayer, VLC , and v4lucp, which uses Mplayer to preview, have no difficulties.

changing resolution to 800x448 (or lower) fixes all problems
with more pixels problem not fixed

Luis Armando Medina (lamedina) wrote :

I confirm with 640x480 color look right, higher resolutions show wrong color or image composite

^rooker (rooker) wrote :

I can also confirm that the image is correct with <= 640x480, but all resolutions above have distorted chroma.
It used to work in Natty.

btw:
I've tried a workaround suggested by "Juan Francisco Contreras García" (juanfcocontreras) in bug-thread #838739 (https://bugs.launchpad.net/cheese/+bug/838739/comments/16), and installed "libv4l" from PPA.
Now all resolutions work fine again.

My webcam is (lsusb output):
ID 17ef:4815 Lenovo Integrated Webcam [R5U877]

can confirm that this bug is fixed in libv4l from ppa
its fixed-upstream

Robb (robb-dawson-gmail) wrote :

The PPA libv4l fixes this problem.

sordna (sordna) wrote :

Latest libv4l-0 package in oneiric (just received the update today) with version 0.8.5-3ubuntu2 fixes the issue. Changelog says it fixes bug 838739 so this bug (888633) is a duplicate of 838739 which is now fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers