first picture taken with cheese after install is not displayed in bottom pannel

Bug #876834 reported by Carla Sella on 2011-10-17
This bug report is a duplicate of:  Bug #1078612: Update cheese to 3.6.2. Edit Remove
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Cheese
Fix Released
Medium
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
James M. Leddy
Quantal
Medium
James M. Leddy
Raring
Undecided
James M. Leddy
cheese (Ubuntu)
Medium
Unassigned
Nominated for Raring by James M. Leddy
Quantal
Medium
Unassigned

Bug Description

Carrying out tests with my laptop, as I install Ubuntu from scratch every time I carry out laptop tests and I do not have cheese installed, I found out that, the very first picture you take with cheese as soon as it is installed, is saved in the pictures/webcam folder but it is not displayed in the lower pannel of cheese, if you take a second picture that is dispalyed as if onay one picture was taken.
If you close cheese and re-open they both appear in the bottom pannel.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: cheese 3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Mon Oct 17 22:16:24 2011
ExecutablePath: /usr/bin/cheese
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Hewlett-Packard HP G62 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions:
 cheese 3.2.0-0ubuntu2
 cheese-common 3.2.0-0ubuntu2
SourcePackage: cheese
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/25/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1425
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 54.12
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.06:bd01/25/2010:svnHewlett-Packard:pnHPG62NotebookPC:pvr049D100000202710000020000:rvnHewlett-Packard:rn1425:rvr54.12:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP G62 Notebook PC
dmi.product.version: 049D100000202710000020000
dmi.sys.vendor: Hewlett-Packard

Carla Sella (carla-sella) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cheese (Ubuntu):
status: New → Confirmed
Joe Areeda (areeda) wrote :

I see the same behavior.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/876834

tags: added: laptop-testing
Carla Sella (carla-sella) wrote :

I'm having the same problem testing Precise Pangolin.

Carla Sella (carla-sella) wrote :

I'm testing Quantal alpha 2 and the problem is still there.

Changed in cheese:
importance: Unknown → Medium
status: Unknown → New
Shih-Yuan Lee (fourdollars) wrote :

Hi,

I made this patch to fix this bug.
Please help to review it.
Any feedback is welcome.

Regards,
$4

The attachment "0001-Create-the-video-and-photo-directories.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in oem-priority:
importance: Undecided → Medium
James M. Leddy (jm-leddy) wrote :

Alternate patch from upstream. $4, what do you think?

Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
tags: added: rls-q-incoming
Shih-Yuan Lee (fourdollars) wrote :

@jm-leddy,

The alternate patch seems to be a possible solution for me.
However we need the upstream developer's feedback.

Shih-Yuan Lee (fourdollars) wrote :

I have tried to bring up the discussion about this bug at https://mail.gnome.org/archives/cheese-list/2012-September/msg00001.html .

Carla Sella (carla-sella) wrote :

It happens also on Ubuntu 12.10 Beta 1.

Didier Roche (didrocks) wrote :

I don't think the desktop team has the resource to fix it this cycle, please continue discussing with it with upstream, if they ack the patch, we can easily sneak it as a distro-patch for us. Thanks :)

tags: removed: rls-q-incoming
tags: added: rls-q-notfixing
James M. Leddy (jm-leddy) wrote :

 Great, I'll leave this open for the possibility of an SRU.

James M. Leddy (jm-leddy) wrote :

Didn't mean to nominate for Q, meant that for oem-priority

Kate Stewart (kate.stewart) wrote :

Hmm.. missed commetn #15, before I clicked on accept. Since it already has the tag rls-q-nofixing, all should be ok though.

Changed in cheese (Ubuntu Quantal):
importance: Undecided → Medium
Changed in cheese (Ubuntu Quantal):
status: Confirmed → Won't Fix
Phil Huang (phil.huang) wrote :

I branch a bzr for quantal and fix this issue by use upstream patch.

code:
https://code.launchpad.net/~phil.huang/cheese/bug876834

ppa:
https://launchpad.net/~phil.huang/+archive/ppa

tags: added: rls-r-incoming
Changed in cheese:
status: New → Confirmed
Changed in cheese:
status: Confirmed → Fix Released
James M. Leddy (jm-leddy) wrote :

Thank you for your work, but it looks like this already came through in the 3.6.2 update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.