[Thinkpad Edge 13] Video recorded using Cheese or gstreamer is out of sync and bad quality

Bug #876777 reported by Jeff Lane on 2011-10-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cheese (Ubuntu)
Undecided
Unassigned

Bug Description

Testing 11.10 on the Thinkpad Edge 13 (7450). There's a video test that uses gstreamer to record video from the onboard video camera to a temp file, then play that file back via totem. This test fails with errors in totem about a dead stream. So I installed Cheese and tried again.

With Cheese, I can recored "video" but the video is horribly out of sync with the audio AND the video quality is absolutely horrible.

I've attached a brief sample video shot with cheese demonstrating this...

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic-pae 3.0.0-12.20
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1581 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0700000 irq 44'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15066,17aa21c5,00100302 HDA:80862804,80860101,00100000'
   Controls : 12
   Simple ctrls : 6
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 84HT22WW-1.168000'
   Mixer name : 'ThinkPad EC 84HT22WW-1.168000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Oct 17 15:15:09 2011
HibernationDevice: RESUME=UUID=a6f46918-b8ac-4678-8c2d-8bcdf3fe4737
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MachineType: LENOVO 021730U
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=55b443fc-9c23-4027-944f-6af2f3269086 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic-pae N/A
 linux-backports-modules-3.0.0-12-generic-pae N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/14/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 84ET24WW (1.08 )
dmi.board.name: 021730U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr84ET24WW(1.08):bd02/14/2011:svnLENOVO:pn021730U:pvrThinkPadEdge:rvnLENOVO:rn021730U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 021730U
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :

Here's a very brief video showing the video and audio issues described above

Brad Figg (brad-figg) on 2011-10-17
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Jeff Lane (bladernr) wrote :

Also seen on an additional Edge 13 and a Thinkpad W510. Joseph, at this time, testing an upstream kernel is not an option :( sorry... perhaps later, but I just don't have the time and will not have access to these machines after today. Please work with Marc Legris for further diagnostic issues...

Additionally, I'm marking this as a cert blocker because I've tried two different utilities and can not get usable video out of the webcam. That's a pretty significant issue...

tags: added: blocks-hwcert
Ara Pulido (ara) on 2011-10-21
tags: added: blocks-hwcert-enablement
Jeff Lane (bladernr) wrote :

So part of this seems to be an issue of resolution. Reducing the resolution from 640x480 to 320x240 cleans it up a lot, but the video recorded is played back at a faster rate than it should be. Probably a test issue there.

The playback audio is still out of sync, and that still occurs with cheese too, so that is not necessarily a test tool issue.

Any thoughts on a better tool (other than skype) to test this with?

Ara Pulido (ara) wrote :

I removed the blocks-hwcert tags, as this seems to be a software issue: bug 876777

Can you retest with skype or camorama?

Thanks!

tags: removed: blocks-hwcert blocks-hwcert-enablement
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jeff Lane (bladernr) wrote :

it gets better/worse depending on the tool used, resolution, etc. I did try this with Camorama, Cheese and our test that uses gstreamer... I can tweak resolutions and Kinda get a good video, but the audio sync is still off either way.

Skype probably works, as I understand it, and ffmpeg does too, according to Daniel.

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-01-06
Changed in linux (Ubuntu):
status: New → Confirmed
Jeff Lane (bladernr) wrote :
Download full text (12.1 KiB)

I think this is a pretty serious problem, software or not, though I can concede that this is not a cert concern thinking on it further. But given that essentially video recording doesn't work out of the box on Ubuntu on every laptop I've tried, that's a pretty significant problem and effects a very common use case on portable systems... not everyone uses skype :(

That being said:

bladernr@klaatu:~/offline$ sudo apt-get install skype
[sudo] password for bladernr:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package skype is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'skype' has no installation candidate

Then I found this:

https://help.ubuntu.com/community/Skype

But the average user may not think to do this, it's not exactly obvious to the new user. And at that, it still didn't work :(

bladernr@klaatu:~/offline$ sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
bladernr@klaatu:~/offline$ sudo apt-get update && sudo apt-get install skype
Ign http://dl.google.com stable InRelease
Ign http://dl.google.com stable InRelease
Ign http://dl.google.com stable InRelease
Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://dl.google.com stable Release.gpg [198 B]
Get:3 http://dl.google.com stable Release.gpg [198 B]
Ign http://archive.canonical.com oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease
Ign http://archive.ubuntu.com oneiric InRelease
Get:4 http://dl.google.com stable Release.gpg [198 B]
Ign http://security.ubuntu.com oneiric-security InRelease
Get:5 http://dl.google.com stable Release [1,347 B]
Get:6 http://dl.google.com stable Release [1,338 B]
Hit http://archive.ubuntu.com oneiric Release.gpg
Hit http://archive.canonical.com oneiric Release.gpg
Ign http://us.archive.ubuntu.com oneiric InRelease
Ign http://us.archive.ubuntu.com oneiric-updates InRelease
Get:7 http://dl.google.com stable Release [1,349 B]
Ign http://ppa.launchpad.net oneiric InRelease
Get:8 http://dl.google.com stable Release [1,347 B]
Get:9 http://security.ubuntu.com oneiric-security Release.gpg [198 B]
Hit http://archive.ubuntu.com oneiric Release
Hit http://us.archive.ubuntu.com oneiric Release.gpg
Get:10 http://archive.canonical.com oneiric Release.gpg [198 B]
Hit http://ppa.launchpad.net oneiric Release.gpg ...

Robert Hooker (sarvatt) on 2012-01-06
affects: linux (Ubuntu) → cheese (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers