cheese does not detect webcam properly (it works in gstreamer-properties)

Bug #482377 reported by Matt Wheeler on 2009-11-13
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Cheese
Expired
Medium
cheese (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: cheese

Acer Aspire One webcam works in gstreamer-properties but not in cheese. Worked fine in 9.04, is not working in 9.10

ProblemType: Bug
Architecture: i386
Date: Fri Nov 13 21:45:34 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: cheese 2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: cheese
Tags: ubuntu-unr
Uname: Linux 2.6.31-14-generic i686

Matt Wheeler (funkyhat) wrote :
jtykal (jim-tykal) wrote :

Same on my AAO. I was able to get video configured to work in gstreamer-properties test as follows:
gstreamer-properties
 Video Output - Plugin: X Window System (No Xv)
 Video Input - Plugin: Video for Linux 2 (v4l2), Device: USB 2.0 Camera
However, in cheese all I see is a very faint static image from the webcam -- no streaming video at all on the display.
I can record photos and videos successfully, so the webcam itself is working fine -- it's just the video display that's bad.

Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in cheese (Ubuntu):
status: New → Incomplete

Definitely still an issue with 9.10 and all current updates. I have not installed 10.04 yet.
Just to clarify, I can take pictures with the webcam, but the display in cheese does not show what the camera sees.

Thanks for following up!

Jim Tykal
<email address hidden>

________________________________
From: Vish <email address hidden>
To: <email address hidden>
Sent: Fri, May 14, 2010 11:17:35 PM
Subject: [Bug 482377] Re: cheese does not detect webcam properly (it works in gstreamer-properties)

Thank you for taking the time to report this bug and helping to make
Ubuntu better. You reported this bug a while ago and there hasn't been
any activity in it recently. We were wondering if this is still an issue
for you. Can you try with the latest Ubuntu release? Thanks in advance.

** Changed in: cheese (Ubuntu)
       Status: New => Incomplete

--
cheese does not detect webcam properly (it works in gstreamer-properties)
https://bugs.launchpad.net/bugs/482377
You received this bug notification because you are a direct subscriber
of the bug.

Status in “cheese” package in Ubuntu: Incomplete

Bug description:
Binary package hint: cheese

Acer Aspire One webcam works in gstreamer-properties but not in cheese. Worked fine in 9.04, is not working in 9.10

ProblemType: Bug
Architecture: i386
Date: Fri Nov 13 21:45:34 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: cheese 2.28.1-0ubuntu1
ProcEnviron:
LANG=en_GB.UTF-8
SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: cheese
Tags: ubuntu-unr
Uname: Linux 2.6.31-14-generic i686

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/482377/+subscribe

Andreas Scherf (scherfa) wrote :

The bug is still present in UNR 10.04! Hope that someone could fix it.

Vish (vish) wrote :

Hi Andreas Scherf,
This bug is regarding acer aspire one laptops where the webcam works in gstreamer-properties.

Are you also facing the problem on Acer Aspire one? and the gstreamer-properties displays the video image?

Could you attach the output of commands:
lsusb
lspci

There is debugging information missing from the bug report.
Could you run the following command in a terminal which will launch cheese in debugging mode:

 GST_DEBUG=*cheese*:3 cheese -v 2>&1 | tee cheese-debug.log

After you reproduce the problem , close cheese and upload the file cheese-debug.log (as an attachment) to the bug report. [which will be created in your Home folder].

 This will greatly help us in tracking down your problem.

Hi here are the files you requested.

Cheers
Andreas

2010/5/30 Vish <email address hidden>:
> Hi Andreas Scherf,
> This bug is regarding acer aspire one laptops where the webcam works in gstreamer-properties.
>
> Are you also facing the problem on Acer Aspire one? and the gstreamer-
> properties displays the video image?
>
> Could you attach the output of commands:
> lsusb
> lspci
>
> There is debugging information missing from the bug report.
> Could you run the following command in a terminal which will launch cheese in debugging mode:
>
>  GST_DEBUG=*cheese*:3 cheese -v 2>&1 | tee cheese-debug.log
>
> After you reproduce the problem , close cheese and upload the file
> cheese-debug.log (as an attachment) to the bug report. [which will be
> created in your Home folder].
>
>  This will greatly help us in tracking down your problem.
>
> --
> cheese does not detect webcam properly (it works in gstreamer-properties)
> https://bugs.launchpad.net/bugs/482377
> You received this bug notification because you are a direct subscriber
> of the bug.
>

jtykal (jim-tykal) wrote :

Adding cheese-debug and lspci/lsusb output (jtykal suffix) for my system as an additional data point.

jtykal (jim-tykal) wrote :
jtykal (jim-tykal) wrote :
Vish (vish) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at : https://bugzilla.gnome.org/show_bug.cgi?id=620636

Changed in cheese (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in cheese:
status: Unknown → New
Changed in cheese:
importance: Unknown → Medium

This bug is stille present in maverick beta (on 2010-09-26):
Using directly cheese: no device found
Using this:
sudo gst-launch v4l2src name=video_source device=/dev/video0 ! capsfilter name=capsfilter 'caps=video/x-raw-rgb,width=640,height=480,framerate=30/1;video/x-raw-yuv,width=640,height=480,framerate=30/1' ! gconfvideosink

It works.

mihamina@packard:~$ uname -ra
Linux packard 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

mihamina@packard:~$ dmesg | grep uvc
[ 11.687295] uvcvideo: Found UVC 1.00 device PROLiNK PCC5020 Cam (0ac8:3420)
[ 11.691066] usbcore: registered new interface driver uvcvideo

Humm... chmod 777 /dev/video0 made it works... crazy

grahame pratt (softappstudio) wrote :

I too am having major problems with Cheese, using an EasyCap C60 USB. I would like to try the above, but what is "gst-launch" and where do I get it? I cannot find it on my UBUNTU Lucid distribution (which is only 12 hours after update). Thanks. I'm ignorant about much of Linux, so any tips greatly appreciated.
--G

Tanja Heller (28tanjaheller28) wrote :

cheese web cam does ot work with skype--what can i do?

Changed in cheese (Ubuntu):
assignee: nobody → Tanja Heller (28tanjaheller28)
assignee: Tanja Heller (28tanjaheller28) → nobody
Changed in cheese:
status: New → Incomplete
Changed in cheese:
status: Incomplete → Expired
Vadim Rutkovsky (roignac) wrote :

Is this reproducible in Cheese 3.x.x version?

Changed in cheese (Ubuntu):
status: Triaged → Incomplete

Upgrade ubuntu 12.10 to 13.04 unstable and cheese stop to detect my cam... with gstreamer-properties i can view the cam...

Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
Codename: raring

cheese:
  Installato: 3.6.2-0ubuntu2
  Candidato: 3.6.2-0ubuntu2
  Tabella versione:
 *** 3.6.2-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
        100 /var/lib/dpkg/status

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.