cheese crashed with signal 5 in _XError()

Bug #399082 reported by William Grant on 2009-07-14
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
cheese (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: cheese

Seems like it might have happened while it was trying to display the actual video.

ProblemType: Crash
Architecture: amd64
Date: Tue Jul 14 11:07:34 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/cheese
Package: cheese 2.27.3-0ubuntu2
ProcCmdline: cheese
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-2.17-generic
Signal: 5
SourcePackage: cheese
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 _XError () from /usr/lib/libX11.so.6
 ?? () from /usr/lib/libX11.so.6
 _XEventsQueued () from /usr/lib/libX11.so.6
 XPending () from /usr/lib/libX11.so.6
Title: cheese crashed with signal 5 in _XError()
Uname: Linux 2.6.31-2-generic x86_64
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare sbuild

William Grant (wgrant) wrote :

StacktraceTop:?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

visibility: private → public
Changed in cheese (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Robert Ancell (robert-ancell) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in cheese (Ubuntu):
status: Incomplete → Invalid
Durand D'souza (durand1) wrote :

I get the same error when trying to record a video. I'm not sure what kind of debugging you would like but I'll try to provide it.

CJay554 (cjay554-yahoo) wrote :

after i run the backtrace it shows the following log and the cheese window grayscales and just hangs.

Heres a backtrace log:

Starting program: /usr/bin/cheese
[Thread debugging using libthread_db enabled]
[New Thread 0xb6fd6b70 (LWP 3238)]
[New Thread 0xb67d5b70 (LWP 3239)]

Gdk-ERROR **: The program 'cheese' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 77 error_code 8 request_code 132 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
[New Thread 0xb65ffb70 (LWP 3241)]
[New Thread 0xb5dfeb70 (LWP 3242)]
[New Thread 0xb55fdb70 (LWP 3243)]
[New Thread 0xb2cd0b70 (LWP 3245)]
[Thread 0xb6fd6b70 (LWP 3238) exited]

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 0xb5dfeb70 (LWP 3242)]
0x00c5ca3f in g_logv () from /lib/libglib-2.0.so.0
(gdb)

Changed in cheese (Ubuntu):
status: Invalid → New
Vish (vish) wrote :

CJay554 & Durand D'souza Kindly follow the information given here: http://wiki.ubuntu.com/DebuggingProgramCrash

CJay554 , the gdb is not complete , you need to follow all the steps given in the wiki to get a full backtrace and it also seems your crash might be different

Changed in cheese (Ubuntu):
status: New → Incomplete
Durand D'souza (durand1) wrote :

Uhm, I forgot to say that this bug seems to have been fixed for me. Thanks.

Vish (vish) wrote :

This bug report is being closed due to the last comment regarding this being fixed . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find

@CJay554. If you are still having the problem , kindly open a separate bug report, as others on this bug mention it is fixed

Changed in cheese (Ubuntu):
status: Incomplete → Invalid
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers