cheese records at a painfully slow fps

Bug #332381 reported by Michael Janos on 2009-02-21
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
cheese (Fedora)
Confirmed
Unknown
cheese (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cheese

running on an eee pc 900ha

OS: 8.10 and 9.04 both with the latest updates
Kernel:
8.10- 2.6.27-8-eeepc
9.04- 2.6.28-8-generic
using the latest cheese packages available in each installation

When taking video the fps of the video drop to a frame every 4 seconds or so creating an extremely laggy slideshow

tidris (tidris769) wrote :

I have a similar problem but on much faster hardware, a 2.4GHz Intel dual core2 laptop with a 1.3MP built-in camera. I run ubuntu 8.10 with all the latest updates. Many seconds by between video frames.

Today I discovered a way to work around this problem. What I do is run this script on a terminal window.

 while true; do echo > /dev/null; done

That script keeps the CPU busy. When that script is running cheese displays video at a reasonable frame rate. Stop the script and frame rates goes back to super slow.

I think this is related to the automatic CPU frequency adjustment in the laptop. When the script above is running the CPU applet shows the CPU frequency as 2.4GHz. When the script is stopped the CPU frequency stays at 800MHz even if cheese is running and trying to capture video.

So maybe this isn't really a cheese bug, but perhaps cheese should try to force the CPU to run at maximum frequency when it is trying to capture video?

tidris (tidris769) wrote :

I tried the following command on a terminal window:

gst-launch v4l2src ! xvimagesink

gst-launch produces the same extremely slow frame rate as cheese unless I run the script I mentioned above.
That suggest to me there is something at the gstreamer/v4l2 level that is causing this problem whenever the CPU frequency is too low.

christobzr (christobzr) wrote :

I have the exact same problem on an eeepc 1000H with ubuntu netbook remix, default install, latest software as of today.

christobzr (christobzr) wrote :

UCView works much better, though not excellent. The "while true" trick above does not help at all.

I'm using integrated cam.

Changed in cheese (Ubuntu):
status: New → Confirmed
Paul Larson (pwlars) wrote :

Another thing you might try, is going to preferences in cheese and setting the resolution to something lower. At least on my system, any application I've tried that uses the camera struggles at higher resolutions.

Changed in cheese (Fedora):
status: Unknown → Confirmed
Christophe (tsela-cg) wrote :

Same problem here on a top of the line desktop (quadcore AMD phenom 3.4Ghz with 4GB memory) running Ubuntu 10.04 with all the latest updates. Webcam is a Logitech c500 (1.3 MP). Skype runs fine, simply watching the video stream via Cheese runs also fine (even at highest resolution, I get a very good framerate and the image is sharp even for fast movements), but recording via Cheese just does not work (highest framerate about 0.5fps!).

Would really like this bug to be solved as a quick check through Ubuntuforums shows that quite a few people are suffering from this issue.

Hi, I have the same problem. Everything works smoothly on Windows but after rebooting to Ubuntu camera becomes very slowed down in Cheese. It eats almost 100% of my CPU and outputs 0.5 fps.

What information I need to provide in order to help reproducing/investigating this.

marrduk (marduk2007) wrote :

Absolutely the same problem, but framerate is about 2-3 fps. Skype and watching the video stream via Cheese run fine too. Ubuntu 10.04. Webcam - A4tech PK-336, Triplecore AMD Phenom with 3 GB of RAM

Chris Lasher (chris.lasher) wrote :

This bug was marked as a duplicate of Bug #252664, but these two bugs are not directly related, so I removed this duplicate status. Bug #252664 is about choppy framerate in the observation window of Cheese; this bug is about choppy framerate when using Cheese to actually record video. Framerate when not recording video is otherwise acceptable.

Vish (vish) wrote :

Chris Lasher: Kindly do not re-open old bugs. This bug has no information for a developer to start work on.

If you are having a problem with cheese in the latest version from *Maverick* , do open a new bug using the command
 ubuntu-bug cheese

Marking bug as dup again.

Vish: With all due respect, these are NOT the same bug. As Chris Lasher indicated, Bug #252664 is about choppy frame rate at all times, not just during recording, perhaps suggesting a problem with actual video capture. What he and I seem to be experiencing is perfectly acceptable video in the observation window, which becomes unacceptably choppy ONLY WHEN RECORDING. These are almost certainly two distinct problems with two distinct causes.

In my case, while recording, the video seems to work just fine for a few seconds, then gets progressively more choppy until finally it's only capturing about a frame per second.

As for information for a developer to start work on: Please, tell me what information you need, and I will gladly provide it.

hawthornso23 (hawthorn) wrote :

I've just fixed this bug on my system (or at least I have a very usable workaround). It is a sound problem. That is why the video in the preview window is just fine (no sound involved) but as soon as you start recording it totally craps out.

In my case the preview window was beautiful at 30fps+ with high resolution, but when recording I was getting more like 1 frame every 2 seconds. That was extremely frustrating because you just had to look at the preview window to see that the hardware and system was capable of much better.

I'm using a USB webcam with built in microphone. My hypothesis is that because cheese isn't getting sound directly from the device but is getting it piped through pulseaudio/alsa - as soon as it starts to record and asks for sound, it finds itself having to fight for access to the device with the sound applications, which just clogs everything up.

The fix is simple. Plug a microphone into your sound card. Go to System>Preferences>Multimedia Systems Selector, and look at Audio default input. The Plugin should be ALSA. The device will probably be `default'. That is NOT what you want. Change the device from `default' to whatever the analogue input from your sound card is (there is a drop down list) - mine is "ALC 883 Analogue". Avoid the setting "USB audio" which is probably your webcam. On the video tab change the default input explicitly to your webcam device rather than default (this last step possibly isn't necessary - but it is what worked for me).

Now try again. The result in my case was that cheese functioned flawlessly, albeit with sound provided by an external mike and not the one built into the webcam.

hawthornso23 (hawthorn) wrote :

Actually I've just noticed that others are experiencing this problem on laptops with built-in webcams. Maybe I've found a workaround for a different bug. However it may still be worth checking this out on the possibility that the microphone and camera in those laptops are connected in some way.

This has nothing to do with video resolution.

@Vish :
Please think twice before adding a duplicate tag, it can be very frustrating to take time writting a bug report, to have people tag it as "duplicate" of another bug, without more discussion.

Vish (vish) wrote :

@guillaume le louet and all: If you are not sure how to check bug activity, here is the link:
 https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/332381/+activity
2009-05-14 03:29:12 Paul Larson : marked as duplicate 252664
2010-08-31 04:57:48 Chris Lasher : removed duplicate marker 252664
More than 1yr later this bug was unmarked. Paul is a triager while Chris is not, and I tend to trust someone who has more experience in actually triaging a bug.

And I would suggest you read my comment carefully!

Do NOT pile on other bugs unless you are sure your issue is the exact same .
So, if you are having a similar problem FILE A NEW SEPARATE BUG of your own.

Vish (vish) wrote :

Btw, this bug has zilch useful info about hardware of anything for someone to actually work on fixing a bug!
Ranting over trivia is not going to help solve your problem.

I suggest that people, test this in latest Ubuntu 11.04 and file bugs of their own using the command :
 ubuntu-bug cheese

That will collect data that is actually useful to solving your problem and is much less time consuming than ranting or flaming someone else who is trying to help you!

Vish, please. Read what the other bug is about. Then, read what this one bug is about.

And, even god made mistakes. In that case, Paul did one. those two bugs are not the same one.

PLUS, you are now insulting me. You don't even want to discuss, and are looking down to me. Just to tell you how you make me feel.

So please, next time someone telle you you did wrong, DONT say "no" before really considering his point of view. If you don't have time to think of it, let someone else answer. The error of Paul has been corrected after one year, so it's not a problem if my error takes another one year before being corrected - at least you will not offense me.

Removing the duplicate bug. If you add it again without discussion, I need to find a CM.

Collected data with ubuntu-bug, as you suggested. It created a new bug, that I tagged as duplicate of this one.

Vish (vish) wrote :

guillaume, Are you sure if your hardware is the exact same as the original reporter of this bug? Are you the original reporter?
Do you want your bug fixed or do you want to argue over the bug status? Kindly stop changing the status of bugs and spamming people, and stop harassing others who are trying to help *you*!

For Cheese, Several bugs might have the exact same symptoms but the cause is not always the same! This is because the issue might be drivers of might be hardware related.
Just file your bug and let triagers do their work. Let's just deal with your bug

If you want someone to take the time explaining why individual bugs , do feel free to contact me offline.

Vish,
I have the exact same symptoms described in the first post, so untill specific information is given about the importance of hardware in this bug, THEY ARE THE SAME ONE.

As a java dev, I know well that the same apparent bugs may be produced by underlying different bugs. But, when there is no more information about the origin of the bug, two bugs with same symptoms have to be considered as the same one bug.

I understand well that there are roles. But whatever you think, the original bug symptoms are not the same as the bug it is marked duplicate of.

Now, when I arg with you, it is very unpolite to skip my opinion.

So, in short : You don't read my posts, or you don't consider them. You think that Paul cannot have made a mistake.
you have the exact behaviour of a troll.
TROLL.

Vish (vish) wrote :

@guillaume le louet: Dont think that everyone in the world other than yourself is always wrong!
Have *you* actually read this bug report description? This bug has been reported from an EEPC!!
Is yours an EEPC? No, yours is a 64bit!

For netbooks it is a known issue : Bug #385344

Yours is not a netbook! Again, what are you trolling here about? Do you want to resolve your issue or do you want to keep arguing about bug status and spamming everyone!

I repeat for the final time, just stick to your bug, your configuration and your issue. Stop spamming others on this bug report! If you dont care I could just dup your bug to Bug #385344 and not care at all!

oyvindln (oyvindln) wrote :

Wow, calm down guys. Let's stop fighting and try to solve the problem instead please.
I have a similar issue as described in the first post, running 32-bit 10.10 (though not a netbook).
As I see it, #385344 seems to be the same issue as this one.
Shouldn't it be a dupe of that one, and not #252664 (which seems to be something else)?

Vish (vish) wrote :

OK, if that is going to stop people from trolling, sure..! ;-)

Bug #385344 however, was when people noticed this issue only in netbooks, if people are getting this in newer versions there seems to be some recent change/regerssion.

Rems (leveillerems) wrote :

the resolution thing work for me lower it

psypher (psypher246) wrote :

I have the exact same problem but I have logged a new bug for my issues and my laptop:
https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/800219

thanks

Attila Fulop (fulop-attila) wrote :

@Vish: I'm confused. I have a laptop. The symptoms are the same that Chris and Guillaume described: Previewing is perfect, but at real recording it gets choppy, useless actually. Which bug should I vote for, or what is the correct way to "express my interest"?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.