on photo capture cheese blanks the screen until logout

Bug #297890 reported by tak on 2008-11-14
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cheese
Fix Released
High
Mago
Undecided
Unassigned
gconf
Invalid
Undecided
Unassigned
cheese (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by pitwalker
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: cheese

When you take a photo after the 3-2-1 countdown the flash (white screen) remains without vanishing as expected.

If you use the space bar instead of the mouse this behaviour doesn't happen.

Steps to reproduce it:

(from upstream bug report)
Ok thanks pitwalker, I can confirm that the bug occurs and is 100% reproducible
only when a11y is enabled. You can try yourself running:

/usr/lib/at-spi/at-spi-registryd&
GTK_MODULES=gail:atk-bridge cheese

Andres Mujica (andres.mujica) wrote :

Hi tak, is it possible for you to describe a little more your bug, so we can understand what's the problem and how it presents?

do you have video output from the webcam?

which webcam do you have?

works in ekiga,camorama,kopete or amsn?

thanks

Changed in cheese:
status: New → Incomplete

I have a Chicony Electronics Co., Ltd Gateway Webcam

when I attempt to capture video, nothing crashes and it creates a video
file, but it contains no data.

when I capture a picture, the picture is taken, but i hate to log out
than back in to reset my screen.

the webcam works with skype perfect, and kopete from what I've used of
it.

On Wed, 2008-12-17 at 02:29 +0000, Andres Mujica wrote:
> Hi tak, is it possible for you to describe a little more your bug, so we
> can understand what's the problem and how it presents?
>
> do you have video output from the webcam?
>
> which webcam do you have?
>
> works in ekiga,camorama,kopete or amsn?
>
> thanks
>
> ** Changed in: cheese (Ubuntu)
> Status: New => Incomplete
>

Benjamin Bach (benjaoming) wrote :

I have the same problem. The white flash stays, so the screen goes all white. Cheese doesn't freeze.. it just paints the screen all white. Doesn't react on alt+f4, though, because the white area takes focus. Alt+tab shows the window switcher but is unable to switch away from the white area.

There are two workarounds:

1) Switch to a different workspace and open a terminal to do killall cheese. The picture will be saved.
2) Press [space] instead of using the mouse. The flash works fine when you don't use the mouse to click Take Photo.

Others having the same problem:

http://ubuntuforums.org/showthread.php?t=943314
http://ubuntuforums.org/showthread.php?p=6321379

My webcam uses the gspca_ov519 module. My desktop effects are on default settings. Please tell me what else you need.

Andres Mujica (andres.mujica) wrote :

Ok, this seems right.

Let's get some data to debug this bug.

Would i be possible for you both, to add as attachment to this bug report the output from the following commands?

cheese -v
lsusb
lsmod

Thanks and Merry Christmas

Benjamin Bach (benjaoming) wrote :

Cheese -v doesn't yield any output. Should I recompile with debugging enabled?

tak (tak) wrote :

cheese -v:
Detected v4l2 device: USB 2.0 Camera
Driver: uvcvideo, version: 256
Bus info: 0000:00:1a.7
Capabilities: 0x04000001

lsusb:
Bus 003 Device 002: ID 04f2:b027 Chicony Electronics Co., Ltd Gateway
Webcam

lsmod:
usbcore 149360 6
uvcvideo,usb_storage,libusual,ehci_hcd,uhci_hcdcompat_ioctl32
9344 1 uvcvideo
videodev 41344 1 uvcvideo
v4l1_compat 22404 2 uvcvideo,videodev
compat_ioctl32 9344 1 uvcvideo

On Wed, 2008-12-24 at 15:20 +0000, Andres Mujica wrote:
> Ok, this seems right.
>
> Let's get some data to debug this bug.
>
> Would i be possible for you both, to add as attachment to this bug
> report the output from the following commands?
>
>
> cheese -v
> lsusb
> lsmod
>
>
> Thanks and Merry Christmas
>

Andres Mujica (andres.mujica) wrote :

Ok, just for clarification. the problem that you both are facing is: When you take a photo after the 3-2-1 countdown the flash (white screen) remains without vanishing as expected. Is that the case?

Also can you add the uname -a output?

thanks!

tak (tak) wrote :

yes that is the problem

uname -a:
Linux Lockpick 2.6.27-11-generic #1 SMP Fri Dec 19 16:29:52 UTC 2008
i686 GNU/Linux

On Sat, 2008-12-27 at 15:21 +0000, Andres Mujica wrote:
> Ok, just for clarification. the problem that you both are facing is:
> When you take a photo after the 3-2-1 countdown the flash (white screen)
> remains without vanishing as expected. Is that the case?
>
>
> Also can you add the uname -a output?
>
> thanks!
>

description: updated
Changed in cheese:
status: Incomplete → Confirmed
Changed in cheese:
status: Unknown → New
Changed in cheese:
status: New → Invalid
Andres Mujica (andres.mujica) wrote :

previously reported at this bug

Changed in cheese:
status: Invalid → Unknown
Andres Mujica (andres.mujica) wrote :

Hi, this bug was already reported at upstream and it would be great if some of the reporters can report back at the upstream bugzilla the following information needed to properly solve this issue.

1.- There's a patch at http://bugzilla.gnome.org/show_bug.cgi?id=566098 that adds some debugging logs needed to solve this issue by upstream. So if any if the reporters can take a look at that report and provide the logs from cheese -v after applying the patch, would be really important.

2.- The bug is reproducible with and without compiz enabled??

Thanks.

Changed in cheese:
status: Unknown → Incomplete
tak (tak) wrote :

Can you link directly to the patch? all i found was an extreamly commented source file, and i woulden't know where to compile it if that was it.

yes the bug applied with compiz enabled, and disabled.

Andres Mujica (andres.mujica) wrote :

the patch is here http://bugzilla.gnome.org/attachment.cgi?id=125572&action=view

but i don't have the skills to make a deb, if you've got the skills or time please go ahead.

Thanks!

Paolo Sammicheli (xdatap1) wrote :
Download full text (5.4 KiB)

This bug affect me on Dell Inspiron 1520, with Intrepid and Cheese 2..24.1-0ubuntu1 and libv4l-0 0.5.6-1~intrepid1.

x@bwing:~$ lsusb
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 003: ID 05a9:2640 OmniVision Technologies, Inc.
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 004: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

x@bwing:~$ lsmod
Module Size Used by
af_packet 25728 4
rfkill_input 12672 0
binfmt_misc 16904 1
ppdev 15620 0
vmnet 48580 13
vmblock 21156 3
vmci 58964 0
vmmon 78064 0
ipv6 263972 12
acpi_cpufreq 15500 1
cpufreq_ondemand 14988 1
cpufreq_userspace 11396 0
cpufreq_conservative 14600 0
cpufreq_powersave 9856 0
cpufreq_stats 13188 0
freq_table 12672 3 acpi_cpufreq,cpufreq_ondemand,cpufreq_stats
pci_slot 12680 0
container 11520 0
sbs 19464 0
sbshc 13440 1 sbs
iptable_filter 10752 0
ip_tables 19600 1 iptable_filter
x_tables 22916 1 ip_tables
dm_crypt 21124 0
dm_mod 63432 1 dm_crypt
sbp2 29324 0
parport_pc 39204 0
lp 17156 0
parport 42604 3 ppdev,parport_pc,lp
arc4 9984 2
ecb 10880 2
crypto_blkcipher 25476 2 dm_crypt,ecb
snd_hda_intel 384176 3
snd_pcm_oss 46848 0
snd_mixer_oss 22784 1 snd_pcm_oss
b43 131356 0
rfkill 17176 3 rfkill_input,b43
snd_pcm 83204 2 snd_hda_intel,snd_pcm_oss
mac80211 216820 1 b43
snd_seq_dummy 10884 0
snd_seq_oss 38528 0
cfg80211 32392 1 mac80211
led_class 12164 1 b43
snd_seq_midi 14336 0
input_polldev 11912 1 b43
snd_rawmidi 29824 1 snd_seq_midi
uvcvideo 63624 0
snd_seq_midi_event 15232 2 snd_seq_oss,snd_seq_midi
joydev 18368 0
sdhci_pci 15360 0
snd_seq 57776 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
compat_ioctl32 9344 1 uvcvideo
wl 1079700 0
videodev 41344 1 uvcvideo
nvidia 7103300 26
snd_timer 29960 2 snd_pcm,snd_seq
serio_raw 13444 0
snd_seq_device 15116 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
pcspkr 10624 0
dcdbas 15008 0
v4l1_compat 22404 2 uvcvideo,videodev
ieee80211_crypt 13...

Read more...

Andres Mujica (andres.mujica) wrote :

This bug is being addressed at upstream, but it would be great if the reporters can let us know if is still an issue with Jaunty, or Intrepid fully updated!

thanks!

pitwalker (pitwalker) wrote :

cheese 2.25.90 affected (Jaunty) with Logitech QuickCam E 3500

after the shot program stops responding, but the video stream not ends

$ lsusb
Bus 007 Device 002: ID 046d:09a4 Logitech, Inc.

Craig73 (funrun73) wrote :

Yes, I have a fully up to date Intrepid and it still happens (although intermittently, I took a short or two before it gave me the white screen.).

But are you wanting me to apply the patch? (Is that what you mean by "fully updated")

Paolo Sammicheli (xdatap1) wrote :

Intrepid Ibex fully updated the 22 february still have the problem. Notice that if you use SPACE BAR instead the mouse CLICK it's working good. That's a crazy bug. :)

pitwalker (pitwalker) wrote :

Maybe this is caused by a "wrong" gconf setting.

https://bugs.launchpad.net/gconf/+bug/174570

After I corrected the xml, cheese 2.25.90 can take a shot without problem

pitwalker (pitwalker) wrote :

I can reproduce this error (with whole screen is white and a mouse pointer) by create a new user, and adding this line

<entry name="accessibility" mtime="1225138994" type="bool" value="true"/>

to

/home/username/.gconf/desktop/gnome/interface/%gconf.xml

ALT+TAB works, when you kill cheese you can continue work
(maybe this entry created in Hardy and not modified during upgrade to Intrepid)

Changed in cheese:
assignee: nobody → pitwalker
status: Confirmed → Invalid
Paolo Sammicheli (xdatap1) wrote :

@pirawalker: YAY!

I deleted in .gconf/desktop/gnome/interface/%gconf.xml the entry <entry name="accessibility" mtime="1225138994" type="bool" value="true"/> and now it works good.

GREAT, THANKS!

Solved for me

What is the impact of deleting this?

On Sun, Feb 22, 2009 at 3:53 PM, Paolo Sammicheli <email address hidden>wrote:

> @pirawalker: YAY!
>
> I deleted in .gconf/desktop/gnome/interface/%gconf.xml the entry <entry
> name="accessibility" mtime="1225138994" type="bool" value="true"/> and
> now it works good.
>
> GREAT, THANKS!
>
> Solved for me
>
> --
> on photo capture cheese blanks the screen until logout
> https://bugs.launchpad.net/bugs/297890
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Cheese Camera Application: Incomplete
> Status in The GConf Registry System: New
> Status in "cheese" source package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: cheese
>
> When you take a photo after the 3-2-1 countdown the flash (white screen)
> remains without vanishing as expected.
>
> If you use the space bar instead of the mouse this behaviour doesn't
> happen.
>

Andres Mujica (andres.mujica) wrote :

Craig73: maybe some accessibility functions would be disabled, but nothing critical.

@ pitwalker: nice catch!!

description: updated
Andres Mujica (andres.mujica) wrote :

i'm marking as confirmed until filippo discards completely the cheese_flash_start_fade issue.

Changed in cheese:
status: Invalid → Confirmed
pitwalker (pitwalker) on 2009-03-02
Changed in cheese:
assignee: pitwalker → nobody
Filippo Argiolas (fargiolas) wrote :

I'm currently discussing with gnome accessibility experts to try to nail down this issue. It is definetely confirmed that it only happens if a11y is enabled. There is probably some locking issue with gdk threads.
Anyway, why the upstream tracker is set to Incomplete? the bug is marked as NEW in gnome bugzilla (afaik it's the same as Confirmed in Launchpad), a LP bug?

Andres Mujica (andres.mujica) wrote :

maybe it's a LP bug.. i'll look around.

Thanks for the feedback Filippo!!

Steve Langasek (vorlon) on 2009-03-06
Changed in cheese:
importance: Undecided → Medium
Filippo Argiolas (fargiolas) wrote :

Ok, I think it's fixed with my last commit in SVN trunk. Could any of you who experienced the issue test it and confirm it? Anyway now bugzilla status is RESOLVED FIXED, and here it's still marked as Incomplete, you really need to fix your upstream bug tracker.

Changed in gconf:
status: New → Invalid
Changed in cheese:
importance: Unknown → Undecided
status: Incomplete → New
importance: Undecided → Unknown
status: New → Unknown
Andres Mujica (andres.mujica) wrote :
Tobin Davis (gruemaster) wrote :

Added ubuntu-desktop-testing to the projects affected. Currently holding up test script development.

Filippo Argiolas (fargiolas) wrote :

Ok, new cheese package with the fix is out, could you guys confirm that this bug is fixed?

Tobin Davis (gruemaster) wrote :

Tested with image on 3/19. Works ok.

Changed in ubuntu-desktop-testing:
status: New → Fix Released
Changed in cheese:
status: Unknown → Fix Released
Changed in cheese (Ubuntu Jaunty):
status: Confirmed → Fix Released
Changed in cheese:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.