Cheese does not show preferences/options/menus to non-GNOME Users

Bug #1879183 reported by Daniel Letzeisen
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cheese (Debian)
New
Unknown
cheese (Ubuntu)
Low
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]
Cheese no longer displays its menu button on non-GNOME desktop environments.
https://gitlab.gnome.org/GNOME/cheese/-/issues/62

Xubuntu uses cheese as its default camera program. Advanced users can still change these settings through dconf-editor, but this is neither convenient nor intuitive.

[Test Case]

Use the cheese program in Xubuntu/xfce, Kubuntu/KDE or other non-GNOME desktop environments. Notice missing menu in titlebar.

[Regression Potential]

The most likely regression would be if the patch disabled the menu in GNOME. Testing has not shown this to be an issue.

[ORIGINAL REPORT]
Cheese has removed the GUI method of accessing preferences for non-GNOME users.
https://github.com/GNOME/cheese/commit/48882da6a6dc4fc1c19e15f5210c9e10feb67ff5#diff-b2b45275b16940829b5f6f068943108d

I'm not sure if upstream cheese devs care enough to fix it:
https://gitlab.gnome.org/GNOME/cheese/-/issues/62
https://gitlab.gnome.org/GNOME/cheese/-/issues/52

Should Xubuntu default to a different camera program, such as guvcview?

(Partial?) WORKAROUND is to use dconf-editor:
dconf-editor /org/gnome/cheese

Revision history for this message
Daniel Letzeisen (dtl131) wrote :
affects: linux (Ubuntu) → cheese (Ubuntu)
tags: removed: gstreamer-error
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. If someone comes with a patch fixing the issue we could apply it to the package even if upstream isn't responsive to the problem

Changed in cheese (Ubuntu):
importance: Undecided → Low
status: New → Triaged
description: updated
Revision history for this message
Daniel Letzeisen (dtl131) wrote :
Revision history for this message
Archisman Panigrahi (apandada1) wrote :

I can confirm that the PPA package by Daniel Letzeisen with this fix works. Please apply it to the repository package (possibly as an important update, as all Ubuntu official flavours are affected).

Revision history for this message
Archisman Panigrahi (apandada1) wrote :

Daniel, can you make a dedicated PPA for Cheese (this PPA has other packages, some of which are possibly unrelated). Also, can you provide a PPA package for Bionic?

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

Archisman, the commit that caused this issue was first included in cheese 3.32.x version. Ubuntu Bionic/18.04 has cheese 3.28.x and should not be affected. (Or have you tested and confirmed that it does?)

As for a separate PPA, I don't see the need. This patch should be included upstream and/or Ubuntu should SRU it. The other packages in my PPA should not affect most users, and those that use projectm probably want the version available in my PPA, (because projectm standalone binaries did not make it into 20.04 due to python2 removal timing).

Revision history for this message
Archisman Panigrahi (apandada1) wrote :

Daniel, the reason I asked you to make a separate PPA is that, your PPA says "Random experiments. Use at own risk.", which might discourage people to try out the patched version of Cheese.

It should instead say something like "This PPA provides a version of Cheese with this patch(link), which enables user to use preferences in non-GNOME DEs, and it is a workaround for all these bugs(links). For more details see https://askubuntu.com/q/1133058/124466 ", so that affected users would want to try it out, without fearing to severely break the system.

This bug is absent in Ubuntu 18.04 (it looks like the person who asked this question in Ask Ubuntu manually installed 3.32 in Bionic and got this error. I can access preferences in Cheese 3.28 in Bionic).

However, this bug is also present in Debian Buster (Cheese 3.31) (see https://gitlab.gnome.org/GNOME/cheese/-/issues/52 ). I made this PPA (https://launchpad.net/~apandada1/+archive/ubuntu/cheese-headerbar-buster) for Debian Buster by applying the same patch, and someone confirmed that it works (https://gitlab.gnome.org/GNOME/cheese/-/issues/52#note_913663). I checked that PPA package also works in Bionic with KDE.

I can't say whether/when GNOME devs will accept this patch upstream, as this bug report ( https://gitlab.gnome.org/GNOME/cheese/-/issues/52 ) was closed because the devs could not reproduce it in GNOME (the fact is, it does not affect GNOME, but affects every other DE. The patch has been proposed in GitLab a month ago, but so far no developer of Cheese made a comment on it in GitLab. I fear they might ignore the patch because the bug does not affect GNOME.).

If someone knows how to do so, please backport this patch to Ubuntu 20.04, without waiting for upstream to include it (multiple people have already confirmed that the bug exists, and the patch fixes it). If possible, also submit the patch to Debian. (I don't know how to submit patches to official packages in Ubuntu/Debian, otherwise I would be happy to take the initiative).

Related Debian Bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949297

Changed in cheese (Debian):
status: Unknown → New
Revision history for this message
Archisman Panigrahi (apandada1) wrote :

I can confirm that the patch fixes the issue in KDE, Cinnamon and XFCE.

I also checked that the patch does not break functionality in GNOME.

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

"I can't say whether/when GNOME devs will accept this patch upstream, as this bug report (issues/52) was closed"
Yes, they did not seem to understand the issue in that report, which is now closed. But https://gitlab.gnome.org/GNOME/cheese/-/issues/62 is still open, so there's at least some hope that they'll fix it.

"Daniel, the reason I asked you to make a separate PPA is that, your PPA says "Random experiments. Use at own risk."
Yes, that's more of a "disclaimer" than anything. I only put the cheese package in my PPA for testing (and thank you for testing in several environments). I did not envision a lot of people using it. I probably should separate unrelated packages in different PPA's. Maybe when I have some more caffeine.. :)

"I don't know how to submit patches to official packages in Ubuntu/Debian"
See: https://wiki.ubuntu.com/StableReleaseUpdates
I think this qualifies as: Bugs which do not fit under above categories, but (1) have an obviously safe patch and (2) affect an application rather than critical infrastructure packages (like X.org or the kernel).

Revision history for this message
Daniel Letzeisen (dtl131) wrote :
description: updated
tags: added: groovy
tags: added: verification-needed-focal
Revision history for this message
Archisman Panigrahi (apandada1) wrote :

"The upload must have the correct release in the changelog header" according to https://wiki.ubuntu.com/StableReleaseUpdates. Groovy hosts Cheese 3.38.0

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

Archisman: Groovy is not released, so requesting an SRU for it does not make sense. Technically, requesting an SRU for Focal doesn't make sense at the moment since the problem is not fixed in development release (Groovy). It is up to Ubuntu devs to do that. I've done as much as I can here.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in cheese (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cheese - 3.38.0-2

---------------
cheese (3.38.0-2) unstable; urgency=medium

  * debian/patches/gitlab_always_headerbar.patch:
    - display the headerbar on any desktop since the compatibility menubar
      was removed, thanks esoleyman (lp: #1879183)

 -- Sebastien Bacher <email address hidden> Thu, 24 Sep 2020 21:29:37 +0200

Changed in cheese (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Daniel, or anyone else affected,

Accepted cheese into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cheese/3.34.0-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cheese (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Archisman Panigrahi (apandada1) wrote :

I can verify that the package in focal-proposed fixes this issue in Cinnamon, and I could not notice any regression.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Archisman Panigrahi (apandada1) wrote :

I have also verified that cheese 3.34.0-1ubuntu1 from focal-proposed fixes this bug in XFCE in Xubuntu 20.04, and I could not notice any regression.

Revision history for this message
Brian Murray (brian-murray) wrote :

I'd like to see this tested in an Ubuntu Gnome session to confirm that it does not regress there.

Revision history for this message
curtis martz (good-ubu) wrote : Re: [Bug 1879183] Re: Cheese does not show preferences/options/menus to non-GNOME Users

Ha, I know right? That would fit the pattern of decreased functionality if the fix was just to disable the menu in Gnome too! saboteur style : ) Maybe they'll allow burning of blue ray data disks someday too? umm er... sorry.

> On Oct 6, 2020, at 19:35, Brian Murray <email address hidden> wrote:
>
> I'd like to see this tested in an Ubuntu Gnome session to confirm that
> it does not regress there.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1884461).
> https://bugs.launchpad.net/bugs/1879183
>
> Title:
> Cheese does not show preferences/options/menus to non-GNOME Users
>
> Status in cheese package in Ubuntu:
> Fix Released
> Status in cheese source package in Focal:
> Fix Committed
> Status in cheese package in Debian:
> New
>
> Bug description:
> [Impact]
> Cheese no longer displays its menu button on non-GNOME desktop environments.
> https://gitlab.gnome.org/GNOME/cheese/-/issues/62
>
> Xubuntu uses cheese as its default camera program. Advanced users can
> still change these settings through dconf-editor, but this is neither
> convenient nor intuitive.
>
> [Test Case]
>
> Use the cheese program in Xubuntu/xfce, Kubuntu/KDE or other non-GNOME
> desktop environments. Notice missing menu in titlebar.
>
> [Regression Potential]
>
> The most likely regression would be if the patch disabled the menu in
> GNOME. Testing has not shown this to be an issue.
>
>
> [ORIGINAL REPORT]
> Cheese has removed the GUI method of accessing preferences for non-GNOME users.
> https://github.com/GNOME/cheese/commit/48882da6a6dc4fc1c19e15f5210c9e10feb67ff5#diff-b2b45275b16940829b5f6f068943108d
>
> I'm not sure if upstream cheese devs care enough to fix it:
> https://gitlab.gnome.org/GNOME/cheese/-/issues/62
> https://gitlab.gnome.org/GNOME/cheese/-/issues/52
>
> Should Xubuntu default to a different camera program, such as
> guvcview?
>
> (Partial?) WORKAROUND is to use dconf-editor:
> dconf-editor /org/gnome/cheese
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/1879183/+subscriptions

Revision history for this message
Paul White (paulw2u) wrote :

Further to comment #18 I updated cheese to version 3.34.0-1ubuntu1 and logged into both a GNOME session and an Ubuntu session. In both sessions the menu in the title bar is visible and usable.

tags: added: verification-done
removed: verification-needed
Revision history for this message
curtis martz (good-ubu) wrote :

Bullshit it does

> On Oct 7, 2020, at 04:20, Paul White <email address hidden> wrote:
>
> Further to comment #18 I updated cheese to version 3.34.0-1ubuntu1 and
> logged into both a GNOME session and an Ubuntu session. In both sessions
> the menu in the title bar is visible and usable.
>
> ** Tags removed: verification-needed
> ** Tags added: verification-done
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1884461).
> https://bugs.launchpad.net/bugs/1879183
>
> Title:
> Cheese does not show preferences/options/menus to non-GNOME Users
>
> Status in cheese package in Ubuntu:
> Fix Released
> Status in cheese source package in Focal:
> Fix Committed
> Status in cheese package in Debian:
> New
>
> Bug description:
> [Impact]
> Cheese no longer displays its menu button on non-GNOME desktop environments.
> https://gitlab.gnome.org/GNOME/cheese/-/issues/62
>
> Xubuntu uses cheese as its default camera program. Advanced users can
> still change these settings through dconf-editor, but this is neither
> convenient nor intuitive.
>
> [Test Case]
>
> Use the cheese program in Xubuntu/xfce, Kubuntu/KDE or other non-GNOME
> desktop environments. Notice missing menu in titlebar.
>
> [Regression Potential]
>
> The most likely regression would be if the patch disabled the menu in
> GNOME. Testing has not shown this to be an issue.
>
>
> [ORIGINAL REPORT]
> Cheese has removed the GUI method of accessing preferences for non-GNOME users.
> https://github.com/GNOME/cheese/commit/48882da6a6dc4fc1c19e15f5210c9e10feb67ff5#diff-b2b45275b16940829b5f6f068943108d
>
> I'm not sure if upstream cheese devs care enough to fix it:
> https://gitlab.gnome.org/GNOME/cheese/-/issues/62
> https://gitlab.gnome.org/GNOME/cheese/-/issues/52
>
> Should Xubuntu default to a different camera program, such as
> guvcview?
>
> (Partial?) WORKAROUND is to use dconf-editor:
> dconf-editor /org/gnome/cheese
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/1879183/+subscriptions

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

@curtis:
1. Please read and respect the Code of Conduct: https://launchpad.net/codeofconduct/2.0
2. This is not the place for a rant about "decreased functionality" or Blu-Ray burning.
3. If you really are trying to make a constructive comment, be more specific. Have you tried the patched version? Does it not work correctly? On what Ubuntu version and desktop environment?

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

I have no reason to not believe the verification provided in comment #20, as comment #21 does not provide any context and is rather disrespectful. If this update does indeed cause a regression, please fill a regression-update bug.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cheese - 3.34.0-1ubuntu1

---------------
cheese (3.34.0-1ubuntu1) focal; urgency=medium

  * debian/patches/gitlab_always_headerbar.patch:
    - display the headerbar on any desktop since the compatibility menubar
      was removed, thanks esoleyman (lp: #1879183)

 -- Sebastien Bacher <email address hidden> Thu, 24 Sep 2020 21:37:10 +0200

Changed in cheese (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for cheese has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Archisman Panigrahi (apandada1) wrote :

After 9 months, the patch has finally been accepted in the upstream repo.
https://gitlab.gnome.org/GNOME/cheese/-/commit/e42a3e55d4d82984779ce8a86aaa805897c9e438

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.