Cheese crashes on launch in Ubuntu 17.10 if no camera device is present

Bug #1710370 reported by AsciiWolf on 2017-08-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cheese
Confirmed
Medium
cheese (Ubuntu)
Undecided
Unassigned

Bug Description

Cheese crashes on launch in Ubuntu 17.10 if the computer does not have any camera device connected.

(cheese:3620): cheese-CRITICAL **: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed

(cheese:3620): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(cheese:3620): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed

(cheese:3620): GLib-GIO-CRITICAL **: g_settings_schema_key_type_check: assertion 'value != NULL' failed

(cheese:3620): GLib-CRITICAL **: g_variant_get_type_string: assertion 'value != NULL' failed

(cheese:3620): GLib-GIO-CRITICAL **: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given

(cheese:3620): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

** (cheese:3620): CRITICAL **: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed

AsciiWolf (asciiwolf) on 2017-09-15
Changed in cheese (Ubuntu):
status: New → Fix Released
AsciiWolf (asciiwolf) wrote :

Still the same issue.

Changed in cheese (Ubuntu):
status: Fix Released → New
AsciiWolf (asciiwolf) on 2017-11-09
tags: added: bionic
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

AsciiWolf (asciiwolf) wrote :

Done.

Changed in cheese:
importance: Unknown → Medium
status: Unknown → Confirmed
AsciiWolf (asciiwolf) wrote :

Still happening on the latest Bionic build.

AsciiWolf (asciiwolf) wrote :

I have just tested this on Fedora 27 under Wayland and Cheese works correctly when no camera is connected. So I am not sure if this is really an upstream issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.