Ubuntu

Please sync latest checkinstall from Debian unstable

Reported by Andreas Noteng on 2012-04-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
checkinstall (Ubuntu)
Medium
Fabrice Coutadeur

Bug Description

Please sync latest checkinstall revision from Debian unstable, and apply the attached debdiff.
The newest update in Debian fixes some minor bugs not reported in the Ubuntu BTS, the debdiff is a wokaround for bug #78455 which has been present in Ubuntu for years.
I've tested with an updated Precise installation, and the problem still exists.
With this workaround, file system translation will be disabled by default.

checkinstall (1.6.2-3ubuntu1) precise; urgency=low

  * Disable file system translation by default

 -- Andreas Noteng <email address hidden> Fri, 06 Apr 2012 15:16:05 +0200

checkinstall (1.6.2-3) unstable; urgency=low

  * Don't include empty control fields (closes: #666262)
  * Update Standards-Version
    - Update debian/copyright to version 1.0
  * Don't include directories in conffiles (closes: #655453)

 -- Andreas Noteng <email address hidden> Sun, 01 Apr 2012 18:22:33 +0200

Doug McMahon (mc3man) wrote :

Just to note - attempts to work with the maintainer (or former maintainer?) about this got nowhere -
Bug 599163

Changed in checkinstall (Ubuntu):
status: New → Confirmed
Andreas Noteng (andreas-noteng) wrote :

Well, I'm the new maintainer for checkinstall in Debian.

Changed in checkinstall (Ubuntu):
assignee: nobody → Fabrice Coutadeur (fabricesp)
status: Confirmed → In Progress
Fabrice Coutadeur (fabricesp) wrote :

Uploaded: thanks for your work! I deleted some unnecessary changes to keep the diff as minimal as possible and run update-maintainer.

thanks,

Fabrice

Changed in checkinstall (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkinstall - 1.6.2-3ubuntu1

---------------
checkinstall (1.6.2-3ubuntu1) precise; urgency=low

  * Sync from Debian (LP: #975140)
  * 0002-Change-default-configuration.patch: Disable file system translation by
    default (LP: #78455)
  * debian/copyright: fixed GPL-2+ licence name
 -- Andreas Noteng <email address hidden> Fri, 06 Apr 2012 15:16:05 +0200

Changed in checkinstall (Ubuntu):
status: Fix Committed → Fix Released

On 07. april 2012 20:16, Fabrice Coutadeur wrote:
> Uploaded: thanks for your work! I deleted some unnecessary changes to
> keep the diff as minimal as possible and run update-maintainer.
Hello, and thanks for uploading. However, I do not think this upload
fixes bug #78455, it's merely a workaround. The bug is that file system
translation does not work, the workaround is to make checkinstall not
default to file system translation, the bug still exists. I'll continue
to work with upstream to find a real fix for this.
Unless you disagree, I'll sett bug #78455 back to triaged.

Regards
Andreas Noteng

Fabrice Coutadeur (fabricesp) wrote :

Hi Andreas,

If you feel that the workaround is not enough, please reopen the bug
report: it will be definitively closed when there will be a real fix,
rather than a workaround.

Fabrice

2012/4/7 Andreas Noteng <email address hidden>:
> On 07. april 2012 20:16, Fabrice Coutadeur wrote:
>> Uploaded: thanks for your work! I deleted some unnecessary changes to
>> keep the diff as minimal as possible and run update-maintainer.
> Hello, and thanks for uploading. However, I do not think this upload
> fixes bug #78455, it's merely a workaround. The bug is that file system
> translation does not work, the workaround is to make checkinstall not
> default to file system translation, the bug still exists. I'll continue
> to work with upstream to find a real fix for this.
> Unless you disagree, I'll sett bug #78455 back to triaged.
>
> Regards
> Andreas Noteng
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975140
>
> Title:
>  Please sync latest checkinstall from Debian unstable
>
> Status in “checkinstall” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Please sync latest checkinstall revision from Debian unstable, and apply the attached debdiff.
>  The newest update in Debian fixes some minor bugs not reported in the Ubuntu BTS, the debdiff is a wokaround for bug #78455  which has been present in Ubuntu for years.
>  I've tested with an updated Precise installation, and the problem still exists.
>  With this workaround, file system translation will be disabled by default.
>
>  checkinstall (1.6.2-3ubuntu1) precise; urgency=low
>
>    * Disable file system translation by default
>
>   -- Andreas Noteng <email address hidden>  Fri, 06 Apr 2012 15:16:05
>  +0200
>
>  checkinstall (1.6.2-3) unstable; urgency=low
>
>    * Don't include empty control fields (closes: #666262)
>    * Update Standards-Version
>      - Update debian/copyright to version 1.0
>    * Don't include directories in conffiles (closes: #655453)
>
>   -- Andreas Noteng <email address hidden>  Sun, 01 Apr 2012 18:22:33
>  +0200
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/checkinstall/+bug/975140/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers