installwatch.so has moved; somebody should tell checkinstall

Bug #29536 reported by Chris Moore on 2006-01-24
22
Affects Status Importance Assigned to Milestone
checkinstall (Ubuntu)
Medium
Unassigned

Bug Description

--- checkinstall.~1~ 2005-11-17 19:47:26.000000000 +0100
+++ checkinstall 2006-01-24 14:13:47.000000000 +0100
@@ -792,7 +792,7 @@
     unset INSTALLWATCH_BACKUP_PATH
 fi

-export LD_PRELOAD=${INSTALLWATCH_PREFIX}/lib/installwatch.so
+export LD_PRELOAD=${INSTALLWATCH_PREFIX}/lib/installwatch/installwatch.so

 # Run the install command, showing the results interactively if we were asked
 # to do so in the configuration section (see the SHOW_INSTALL switch above)

Chris Moore (dooglus) wrote :

does this web interface
+join lines which
+begin with plus signs
+onto the previous lines?

Chris Moore (dooglus) wrote :

no, not in comments at least, so let's try that again:

----
--- checkinstall.~1~ 2005-11-17 19:47:26.000000000 +0100
+++ checkinstall 2006-01-24 14:13:47.000000000 +0100
@@ -792,7 +792,7 @@
     unset INSTALLWATCH_BACKUP_PATH
 fi

-export LD_PRELOAD=${INSTALLWATCH_PREFIX}/lib/installwatch.so
+export LD_PRELOAD=${INSTALLWATCH_PREFIX}/lib/installwatch/installwatch.so

 # Run the install command, showing the results interactively if we were asked
 # to do so in the configuration section (see the SHOW_INSTALL switch above)
----

That's what I pasted before. Will it be mangled again?

Chris Moore (dooglus) wrote :

Anyway, what I was trying to say was that the line in /usr/bin/checkinstall that says:

  export LD_PRELOAD=${INSTALLWATCH_PREFIX}/lib/installwatch.so

should be fixed to say:

  export LD_PRELOAD=${INSTALLWATCH_PREFIX}/lib/installwatch/installwatch.so

because that's where the checkinstall package now puts the installwatch.so file.

nszabolcs (nszabolcs) wrote :

i have the same problem
sudo checkinstall gives:
ERROR: ld.so: object '/usr/lib/installwatch.so' from LD_PRELOAD cannot be preloaded: ignored.

installwatch is under '/usr/lib/installwatch/installwatch.so'

now checkinstall is unusable. its very annoying

Changed in checkinstall:
status: Unconfirmed → Confirmed
Chris Moore (dooglus) wrote :

You can easily fix this for yourself - "sudo gedit /usr/bin/installwatch" and edit line 15 to say LIBDIR=$PREFIX/lib/installwatch.

Then you'll hopefully find and confirm the more serious bug #6567.

The attachment contains the patch already mentioned in the comments.

Steve Kowalik (stevenk) wrote :

Patch applied and uploaded.

Changed in checkinstall:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers