Ubuntu

Checkinstall shows you the options but doesn't allow you to change

Reported by Kemel Zaidan aka Legendario on 2008-04-06
6
Affects Status Importance Assigned to Milestone
checkinstall (Debian)
Fix Released
Undecided
Unassigned
checkinstall (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: checkinstall

When you create use checkinstall to create a package, it shows you during the usage, a numbered list of options of the debian package which will be created. At this time it tells you: "Enter the number to change one of the itens or press ENTER to continue".

If you press any numbers, it will ask you the same thing again and will not allow you to change any values.

My Ubuntu is Gutsy and my checkinstall package version is 1.6.1-4ubuntu1

Thanks.

doorknob60 (doorknob60) wrote :

IT happens for mee on Hardy and INtrepid too, at least for some of the numbers...I've always wondered why. I think it might have happened to me in Debian Lenny as well.

Daniel T Chen (crimsun) on 2008-12-09
Changed in checkinstall:
status: New → Confirmed
Daniel Hahler (blueyed) wrote :

Please provide more information and a test case to reproduce it: please specify the source you are using and where it can be obtained (if it only happens with some packages),
Which numbers fail to change which setting?

Changed in checkinstall:
status: Confirmed → Incomplete
Endolith (endolith) wrote :

number 10 (dependencies) always fails

Changed in checkinstall:
status: Incomplete → Confirmed
Wesley Schwengle (wesleys) wrote :

I wanted to create a bug report for this, but it is already created, number 10 fails indeed:

Enter a number to change any of them or press ENTER to continue: 0
Enter the maintainer's name and e-mail address:
>> <email address hidden>

This package will be built according to these values:

0 - Maintainer: [ <email address hidden> ]
1 - Summary: [ Tomcat connectors - mod_jk v1.2.27 ]
2 - Name: [ native ]
3 - Version: [ 1.2.27 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ native ]
9 - Alternate source location: [ ]
10 - Requires: [ ]

Enter a number to change any of them or press ENTER to continue: "10"

This package will be built according to these values:

0 - Maintainer: [ <email address hidden> ]
1 - Summary: [ Tomcat connectors - mod_jk v1.2.27 ]
2 - Name: [ native ]
3 - Version: [ 1.2.27 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ native ]
9 - Alternate source location: [ ]
10 - Requires: [ ]

Enter a number to change any of them or press ENTER to continue: 10

This package will be built according to these values:

0 - Maintainer: [ <email address hidden> ]
1 - Summary: [ Tomcat connectors - mod_jk v1.2.27 ]
2 - Name: [ native ]
3 - Version: [ 1.2.27 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ native ]
9 - Alternate source location: [ ]
10 - Requires: [ ]

Wesley Schwengle (wesleys) wrote :

This is why, if the architecture is redhat it will prompt you for the additional requirement, although a bit before this case statement, option 11 is rhel specfic, not option 10.

line 1368
        10)
            [ "$CK_REDHAT" ] && {
            echog "Enter the additional requirements: "
            echo -n ">> "
            read REQUIRES
            }
            ;;
        11)
            # 01-12-06 UKo: new feature
            echog "Enter the provided features: "
            echo -n ">> "
            read PROVIDES
            ;;
      esac

line 1302:
      echog "10 - Requires: [ %s ]" "$REQUIRES"
      [ "$CK_REDHAT" ] && echog "11 - Provides: [ %s ]" "$PROVIDES"

Andreas Noteng (andreas-noteng) wrote :

I cannot reproduce this bug in Lucid. Can anybody who previously experienced this bug please try again in lucid?
Thanks

Changed in checkinstall (Ubuntu):
status: Confirmed → Incomplete
Changed in checkinstall (Debian):
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Andreas Noteng (andreas-noteng) wrote :

Fix released in debian see: #469639 - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=469639

Andreas Noteng (andreas-noteng) wrote :

Changing to fix release as I cannot reproduce this bug in lucid, also this bug is fixed in debian and the fix has most likely been released in ubuntu too.

Changed in checkinstall (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.