Login failure as of 13 Dec 2007

Bug #175973 reported by Samir Nagheenanajar on 2007-12-12
46
This bug affects 2 people
Affects Status Importance Assigned to Milestone
checkgmail (Ubuntu)
Medium
Emmet Hikory

Bug Description

Binary package hint: checkgmail

Reproduce:

1. Log into gmail via a web browser. Works. Log out
2. Start checkgmail
3. Enter the same details
4. Error: 401 Unauthorised

checkgmail -v output:

I've edited (in case of private information). If you need a complete dump, I'll create a throw away account.

Initialisation complete
Logging in to Gmail ...

New login method: manually following redirect address http://www.google.com.au/accounts/SetSID?ssdc\0...m ...

Saved cookie: SID
D...Q

Saved cookie: GAUSR
mail:<email address hidden>

Saved cookie: LSID
mail|s.AU:D...w

Saved cookie: GoogleAccountsLocale_session
en_AU

Error: 401 Unauthorised

BTW, happens with an up to date Gutsy and an up to date Feisty.

Cedric Schieli (cschieli) wrote :

Same here with two up to date Hardy

Peter Cherriman (pjcherriman) wrote :

I'm getting the same problem on gutsy from this morning also.

Peter Cherriman (pjcherriman) wrote :

Partial Solution:

Running with the -no_cookies option, allow you to login, but you can't see the subjects of messages anymore, just if you have mail.

e.g. "checkgmail -no_cookies"

I guess google have tightened the security on their use of cookies on the gmail site.

Cedric Schieli (cschieli) wrote :

This patch did it for me

ChrisCauser (chy-causer) wrote :

Cedric, you are a legend.

Thank you.

Chris

dillonger (dillonger) wrote :

I have the same problem - and running the no cookies optioned work.
Sorry for the ignorance but how do you run patches like the above in Ubuntu ?

Changed in checkgmail:
importance: Undecided → Medium
status: New → Confirmed
Damien Cassou (cassou) wrote :

Hi dillonger,

the easiest thing is to download http://checkgmail.svn.sourceforge.net/viewvc/*checkout*/checkgmail/checkgmail, and replace /usr/bin/checkgmail by this file. You can do:

$ cd /tmp
$ wget http://checkgmail.svn.sourceforge.net/viewvc/*checkout*/checkgmail/checkgmail
$ sudo cp checkgmail /usr/bin

Gerard Hop (hoppies) wrote :

I have download the software and the checkgmail file is replaced. Checkgmail is starting up now correctly, i can logon, but......when I click on Shutdown, the program freezes.

Gerard Hop (hoppies) wrote :

Hello here I am again, in my comment above, I mean Shutdown of CheckGmail, not my computer.

Gerard H.

Hi, I can confirm Damiens solution gives the same results as Gerard, eg. on shutdown of Checkgmail the program freezes. This is on a up-to-date xubuntu 7.10 system.

btw Cedric's patch works perfectly for me

paumarc (paumarc) wrote :

if you look at console output it says that an error in a perl library occurs!!

the messatge is:

pau@esberro:~$ checkgmail
Warning: Gtk2::Sexy not found ...

CheckGmail uses Gtk2::Sexy for clickable URLs in mail messages
Please download and install from CPAN (http://search.cpan.org) if you want to use this feature ...

Parsing of undecoded UTF-8 will give garbage when decoding entities at /usr/share/perl5/LWP/Protocol.pm line 114.
Parsing of undecoded UTF-8 will give garbage when decoding entities at /usr/share/perl5/LWP/Protocol.pm line 114.

I don't think this technically has to do with checkgmail. Gmail has changed it's backend so that all users who login go to the URL http://mail.google.com/mail/#inbox while the feeds are now found at http://mail.google.com/mail/feed/atom. Those are the URLs it needs to be updated to. I've made the developer aware of this problem, but quickly noticed that on Dec 13, he submitted his own patch. Maybe updating to that latest version in Feisty, Gusty and Hardy are in order.

Emilio Pozuelo Monfort (pochu) wrote :

Subscribing ~ubuntu-universe-sponsors as this has a patch attached.

Emmet Hikory (persia) wrote :

I've unsubscribed ubuntu-universe-sponsors, as the patch is not in debdiff format. If someone could wrap the patch, or alternately grab a new upstream including the fix, please resubscribe ubuntu-universe-sponsors to request upload.

Cedric Schieli (cschieli) wrote :

Here is the debdiff between hardy's version and mine

Emilio Pozuelo Monfort (pochu) wrote :

Looks sane to me, except that the version string should be 1.12+svn... instead of 1.12.1+svn, as 1.12.1+svn is greater than 1.12.1, which hasn't been released yet.

Emmet Hikory (persia) wrote :

Cedric, thanks for the debdiff. Emilio, thanks for the version catch: I'll s/+/~/ when sponsoring to ensure that 1.12.1 can override this.

Changed in checkgmail:
assignee: nobody → persia
status: Confirmed → In Progress
Emilio Pozuelo Monfort (pochu) wrote :

BTW could you submit the patch upstream? I've done a quick look at the SF project and couldn't find it reported.

Emmet Hikory (persia) wrote :

Uploaded as checkgmail_1.12.1~svn20080102-0ubuntu1. Thanks.

Changed in checkgmail:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkgmail - 1.12.1~svn20080102-0ubuntu1

---------------
checkgmail (1.12.1~svn20080102-0ubuntu1) hardy; urgency=low

  * New upstream snapshot (LP: #175973)
  * debian/patches/permission-fix.dpatch: refreshed

 -- Cedric Schieli <email address hidden> Wed, 02 Jan 2008 11:50:38 +0100

Changed in checkgmail:
status: Fix Committed → Fix Released

Has this fix been released to Gusty? https://launchpad.net/ubuntu/+source/checkgmail/1.12.1~svn20080102-0ubuntu1

Gutsy is still broken unless I run this patch: https://bugs.launchpad.net/ubuntu/+source/checkgmail/+bug/175973/comments/5

Up-to-date as of 2008-01-15

bloody (bloodynuker) wrote :

no new fix released ? my checkgmail is still no working.......

My checkgmail was working some time after installing it but it hasn't been working at least last two weaks.

Changed in checkgmail (Ubuntu):
status: Fix Released → Incomplete
Aaditya Bhatia (aadityabhatia) wrote :

Vratislav: This bug was fixed in early 2008. The current problem is being tracked in a separate bug (#433497) and has been fixed apparently.

https://bugs.launchpad.net/ubuntu/+source/checkgmail/+bug/433497

Changed in checkgmail (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers