Touchpad not detected in tests (no mouse detected at all)

Bug #886129 reported by Thomas Mashos
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
High
Brendan Donegan
checkbox (Ubuntu)
High
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Running the suite of tests on my netbook, I wasn't given any option to test the pointing device (which is half broken).

[Impact]
Users whose sole pointing device reports as class TOUCH, rather than MOUSE (which can happen with certain types of touchpads and is likely to appear more often as multitouch screens and trackpads become more prevalent), will not be prompted to test these devices, which depend on a MOUSE device. In addition to not testing the device, their test submission will be unadmissible for Ubuntu Friendly, even though the touchpad may be working correctly.

[Development Fix]
Checkbox revision 1124 addresses this by having the corresponding test depend on either a MOUSE or a TOUCH device. Revision 1124 includes some string changes that can be omitted in order not to introduce changed strings in an SRU.

[Stable Fix]
This is fixed in http://bazaar.launchpad.net/~checkbox-dev/checkbox/trunk/revision/1124. Note that this also contains an updated prompt string and may not be appropriate to SRU as-is. However, the linked branch (https://code.launchpad.net/~roadmr/ubuntu/oneiric/checkbox/0.12.8.1) contains this and other fixes and merges cleanly against Ubuntu checkbox 0.12.8, and has been altered so that the test string as presented to the user is not modified.

[Test Case]
This necessitates a system whose sole pointing device is reported as TOUCH. Several models of touchpads do this, including Synaptics and Elantech. To ensure that the system has a device that will trigger the problem run /usr/share/checkbox/scripts/udev_resource and look for a device with category: TOUCH. Example:

path: /devices/platform/i8042/serio1/input/input6
bus: input
category: TOUCH
product: ETPS/2 Elantech Touchpad

Also, ensure that the output does NOT have any devices with category: MOUSE. Disconnect any external or additional pointing devices.

- Start "system testing" (checkbox-gtk version 0.12.8) on an 11.10 system with a TOUCH device.
- Press "Next" and provide password when prompted.
- Press "Deselect all" and select ONLY the "Input devices" suite, and press Next.
- Go through the tests.

Expected result:
- A test for the pointing device is presented.

Actual result:
- No pointing device tests are shown.
- The input/mouse test is shown untested in the report:
 input/mouse not required on this system Job requirements not met.

[Regression Potential]Just adding the additional check for devices of category TOUCH should not pose any regression potential. This will still test MOUSE devices as it contains an OR clause. The only possible regression is some confusion if a user has two pointing devices (for instance, a mouse *and* a touchpad, touchscreen or tablet) and will receive only one pointing device test.

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: checkbox 0.12.8
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CheckboxSubmission: c3d828e0d2c138c690c7f5d2faaf0b57
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Fri Nov 4 09:51:50 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: checkbox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Thomas Mashos (tgm4883) wrote :
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

It seems that Thomas's touchpad is being displayed as a 'TOUCH' device rather than a MOUSE device. This should be a simple one line change to add 'device.category == 'TOUCH'' as a requirement for the test.

Changed in checkbox:
status: New → Confirmed
Changed in checkbox (Ubuntu):
status: New → Confirmed
Changed in checkbox:
importance: Undecided → Medium
importance: Medium → High
Changed in checkbox (Ubuntu):
importance: Undecided → High
Changed in checkbox:
assignee: nobody → Brendan Donegan (brendan-donegan)
milestone: none → 0.12.9
Changed in checkbox:
status: Confirmed → In Progress
Changed in checkbox:
status: In Progress → Fix Committed
Changed in checkbox (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.13

---------------
checkbox (0.13) precise; urgency=low

  New upstream release (LP: #892268):

  [Marc Tardif]
  * Generate a submission.xml file that contains all device and attachment
  * Write the report before reporting the validation error.
  * Changed device.product to dmi.product for the formfactor (LP: #875312)

  [Daniel Manrique]
  * Use gettext for string (LP: #869267)
  * Move progress indicator to main checkbox dialog instead of a
    transient window (LP: #868995)
  * Ignore malformed dpkg entries in package_resource (LP: #794747)
  * Reset window title after finishing a manual test (LP: #874690)
  * Handle "@" in locale names (as in ca@valencia).

  [Jeff Lane]
  * Went through all the job files and:
    * Updated descriptions to match Unity UI structure
    * Added descriptions where necessary
    * Added further details to some descriptions
    * Moved some jobs to more appropriate files
    * Fixed job names in older job files to match new naming scheme
      (suite/testname)
    * Added jobs to local.txt to ensure all job files are now parsed
      (this allows easier addition of existing tests to whitelists)
    * Changed remaining manual job descriptions to match the new format
  * Updated CD and DVD write tests to be more clear about when to skip
    them (LP: #772794)

  [Ara Pulido]
  * Rewrote all job descriptions to match OEM QA syntax

  [Brendan Donegan]
  * Fix the code that assigns keys in checkbox-cli so that it never assigns
    keys which have other uses. (LP: #877467)
  * Show details of unmet job requirements (LP: #855852)
  * Ensure that connect_wireless chooses a wireless connection from the list
    of available connections (LP: #877752)
  * Have the bluetooth/detect tests require a device with the category
    BLUETOOTH to run, thus preventing the test from failing on systems with
    no Bluetooth device (LP: #862322)
  * Rename attachment jobs to not have a forward slash in their name
    (LP: #887964)
  * Guard against trying to write files to logical partitions on USB sticks
    (which will obviously fail) in usb_test (LP: #887049)
  * Make the OpenGL test ignore the return value of glxgears and improve
    the test description (LP: #890725)
  * Allow input/mouse test to run if a TOUCH device is present
    (LP: #886129)

  [ Javier Collado ]
  * Broken job dependencies fixed (LP: #888447)
  * Regex support when specifying blacklists and whitelists on the
    commandline (LP: #588647)
 -- Daniel Manrique <email address hidden> Thu, 18 Nov 2011 12:46:21 -0500

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
Daniel Manrique (roadmr)
Changed in checkbox:
status: Fix Committed → Fix Released
Daniel Manrique (roadmr)
description: updated
Daniel Manrique (roadmr)
description: updated
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Thomas, or anyone else affected,

Accepted checkbox into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in checkbox (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Daniel Manrique (roadmr) wrote :

Hi,

I followed the test case instructions on a Samsung QX410 with Elantech touchpad, which reports this in udev_resource:

path: /devices/platform/i8042/serio1/input/input8
bus: input
category: TOUCH
product: ETPS/2 Elantech Touchpad

Under Checkbox 0.12.8, I don't get any mouse tests.

With 0.12.9 installed from -proposed, I get a test called input/mouse that asks me "Moving the mouse should move the cursor on the screen".

Everything else seems to be working normally, checkbox didn't crash or generate errors.

roadmr@snowflake:~$ apt-cache policy checkbox
checkbox:
  Installed: 0.12.9
  Candidate: 0.12.9
  Version table:
 *** 0.12.9 0
        100 /var/lib/dpkg/status
     0.12.8 0
        500 http://ca.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

I'll mark this verification-done.

tags: added: verification-done
removed: verification-needed
Adolfo Jayme (fitojb)
Changed in checkbox (Ubuntu Oneiric):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers