checkbox hangs at submission step and keeps launching the browser

Bug #827904 reported by Jean-Baptiste Lallement
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Checkbox
Fix Released
Critical
Marc Tardif
checkbox (Ubuntu)
Critical
Marc Tardif

Bug Description

On a system freshly installed, after I went through the tests, on the submission screen, I clicked on the link "View Report" which launched firefox. I closed firefox moved the mouse over checkbox which launched firefox again (without clicking on anything)
I closed FF again and finally succeeded in clicking on +login lp link. I authenticated on LP, and closed FF.
I moved the mouse over CheckBox to proceed to the next step, I couldn't click on it. Instead it launched FF again (the LP login page)

finally, checkbox UI became grey and stopped responding (probably exhausted of launching so many FF instances)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: checkbox 0.12.4
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
Date: Wed Aug 17 11:35:20 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: checkbox
UpgradeStatus: Upgraded to oneiric on 2011-08-17 (0 days ago)

Related branches

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Ara Pulido (ara)
Changed in checkbox (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Canonical Hardware Certification (canonical-hw-cert)
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

Hi Jean-Baptiste,

Could this be something that happened randomly? My efforts to reproduce the issue haven't been successful.

Changed in checkbox (Ubuntu):
status: New → Incomplete
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

I can reproduce it and it seems to be a bad interaction with Unity.

Some additional steps:
* When on the 'View Report' step, I clicked Next, got a warning message about my email address then clicked on back.
* Starting from here the links start behaving weirdly, like launching FF when I rollover the main window.
* With FF launched I used ALT+TAB a few times to switch from FF to Checkbox and back. After switching from one app to the other 2 or 3 times, checkbox hangs (can't close with the window's close button) kill to the rescue

Changed in checkbox (Ubuntu):
status: Incomplete → Confirmed
Ara Pulido (ara)
Changed in checkbox:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Canonical Hardware Certification (canonical-hw-cert)
milestone: none → 0.12.5
Revision history for this message
Daniel Manrique (roadmr) wrote :

here's a sequence of steps to reproduce, on Oneiric installed from 20110824 image, which I'm running on a virtual machine:

1- open a terminal.
2- Launch checkbox-gtk.
3- Deselect all tests.
4- Select a few quick tests (the Disk suite for instance).
5- Go through the run, even if you just click "next" on all the tests.
6- On the view report screen, click on "View Report" which should launch a browser.
7- Close the browser, then click on "Next" on the Checkbox window.
8- When you get the "Error" dialog about Launchpad submission, close it.
9- On the "Successfully finished testing!" screen, press "previous".
10- Click on "View report" again, and close the Firefox window that pops up.
11- At this point, hovering over the Checkbox window often (but not always) launches a new Firefox instance.
12- If things start behaving correctly (heh), repeat steps 7-10 to make it misbehave again.

One observation is that, if I tail the checkbox log (~/.cache/checkbox/checkbox.log), I see no change when the stray browsers are launched. This means that it's not the checkbox core's fault, but rather the GTK interface's code, so the place to look in might be gtk_interface.py and possibly the hypertext-aware component, hyper_text_view.py.

Ara Pulido (ara)
Changed in checkbox:
milestone: 0.12.5 → 0.12.6
Marc Tardif (cr3)
Changed in checkbox (Ubuntu):
assignee: Canonical Hardware Certification (canonical-hw-cert) → Marc Tardif (cr3)
Changed in checkbox:
assignee: Canonical Hardware Certification (canonical-hw-cert) → Marc Tardif (cr3)
Revision history for this message
Marc Tardif (cr3) wrote :

Daniel, thanks for the detailed steps to reproduce the problem consistently. You were right that the problem was indeed in the GTK frontend rather than in the backend. Specifically, the problem with the the hyper text widgets is the same as for the button widgets where handlers are called as many times as they are connected. So, handlers either need to be disconnected explicitly after being used or checked so that they are only connected once. This was done for buttons but not for hyper text widgets, so the attached branch should fix that problem.

Changed in checkbox:
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.7

---------------
checkbox (0.12.7) oneiric; urgency=low

  New upstream release (LP: #850395):

  [Brendan Donegan]
  * Redirecting stderr to pipe to fix the gconf_resource script (LP: #832321)
  * Clear jobs directory when user selects No to recover question (LP: #836623)

  [Daniel Manrique]
  * checkbox/job.py: Guard against bogus timeout values (LP: #827859)
  * More explicit handling of string decoding/encoding, avoids problems with
    non-ascii characters (LP: #833747)
  * Changed architecture from all to any for checkbox base, to build
    architecture-specific binaries (LP: #833696)

  [Jeff Lane]
  * Several corrections necessary due to test name changes or typos found in
    job files

  [Marc Tardif]
  * Connecting hyper text widgets only once (LP: #827904)
  * Detecting MMC readers as OTHER instead of DISK (LP: #822948)
  * Validating the hostname in the SSL certificate (LP: #625076)
  * Validating the submission.xml (LP: #838123)
 -- Daniel Manrique <email address hidden> Fri, 14 Sep 2011 17:15:26 -0400

Changed in checkbox (Ubuntu):
status: Confirmed → Fix Released
Marc Tardif (cr3)
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers