scripts/cdimage_resource fails for releases whose media-info contains LTS (10.04.2 LTS)

Bug #814085 reported by Daniel Manrique on 2011-07-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Medium
Daniel Manrique

Bug Description

Version of Ubuntu: 10.04.2 and verified to exist up to 11.04.
Version of checkbox: 0.9.1 and verified to exits up to 0.11.3.

Steps to reproduce:

1- Install an LTS release (I used 10.04.2 for the test) - a virtual machine works fine.
2- Verify that /var/log/installer/media-info contains something like this:

Ubuntu 10.04.2 LTS "Lucid Lynx" - Release i386 (20110211.1)

3- run /usr/share/checkbox/scripts/cdimage_resource

Expected result: Something like this:
distributor: Ubuntu
official: Release
release: 10.04.2 LTS
architecture: i386
date: 20110211.1codename: Lucid Lynx

Actual result: Nothing :(

If the LTS part is removed and media-info contains something like"

Ubuntu 10.04.2 "Lucid Lynx" - Release i386 (20110211.1)

then it works as expected.

It's a matter of updating the regular expression used in cdimage_resource to accomodate the possibility of the LTS string appearing after the release number.

Related branches

Daniel Manrique (roadmr) on 2011-07-21
description: updated
Daniel Manrique (roadmr) on 2011-07-21
Changed in checkbox (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Daniel Manrique (roadmr)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.4

---------------
checkbox (0.12.4) oneiric; urgency=low

  New upstream release (LP: #824180):

  [Brendan Donegan]
  * Refactored job definition files.
  * Fixed dependencies and test naming.
  * Added Online CPU before/after suspend test.
  * Automated wireless tests.
  * Removed redundant sru_suite.txt, updated dependencies accordingly.
  * Automated bluetooth_obex tests.

  [Daniel Manrique]
  * Further improvements to make frontend/backend communication more reliable.
    Prevents stuck backends, failure to close the GUI due to lack of reply
    from the backend, and test specifying "user" not being run.
  * scripts/keyboard_test modified to account for pygi-related GTK API
    changes. (LP: #804369)
  * scripts/sleep_test: improve handling of NetworkManager DBus API
    changes. (LP: #808423)
  * scripts/cdimage_resource: properly handle releases with "LTS" in their
    name (LP: #814085)
  * Updated minimum_resolution test as per latest system requirements, leaving
    just one unified test. (LP: #767166)

  [Javier Collado]
  * Checkbox exits with EX_NOINPUT if a whitelist or blacklist file is
    specified and cannot be found.
  * Deselect a test suite automatically when none of its children is selected,
    in the GTK interface. (LP: #651878)
  * Make the "Next" button the default action when Enter is pressed, to
    streamline testing with the GTK interface.

  [Marc Tardif]
  * Fixed udevam not being found because /sbin not in PATH (LP: #597305)
  * Fixed hardware attachments for udev and dmi (LP: #822682)

  [Sylvain Pineau]
  * Expose the message store to other plugins, via firing an expose-msgstore
    event.

  [Andrew Faulkner]
  * Fix description for nautilus_file_create job (LP: #821141)

  [Kenneth Wimer]
  * New header image that follows brand guidelines (LP: #554202)
 -- Daniel Manrique <email address hidden> Wed, 10 Aug 2011 15:16:39 -0400

Changed in checkbox (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers