cpu/frequency_governors fails: cpufreq-selector: not found

Bug #811177 reported by Daniel Manrique on 2011-07-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Medium
TienFu Chen

Bug Description

On a test run for weekly testing with Oneiric image from 2011-07-15 and checkbox latest as of that date, the cpu/frequency_governors test fails with this trace:

/bin/sh: cpufreq-selector: not found /bin/sh: cpufreq-selector: not found /bin/sh: cpufreq-selector: not found /bin/sh: cpufreq-selector: not found /bin/sh: cpufreq-selector: not found /bin/sh: cpufreq-selector: not found /bin/sh: cannot create /sys/devices/system/cpu/cpu0/cpufreq/conservative/freq_step: Directory nonexistent /bin/sh: cannot create /sys/devices/system/cpu/cpu0/cpufreq/conservative/freq_step: Directory nonexistent /bin/sh: cpufreq-selector: not found

Test may need to be reworked and see why the cpufreq-selector is not available.

Related branches

cpufreq-selector is in gnome-applets apparently - not a package included in Oneiric by default.

I'm not entirely positive cpufreq-selector is required to actually change the frequency. echo'ing into various files in /sys/devices/system/cpu should do it.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in checkbox (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Changed in checkbox (Ubuntu):
importance: High → Medium
Ara Pulido (ara) wrote :

Assigning to Tim

Changed in checkbox (Ubuntu):
assignee: nobody → Tim Chen (ctf)
TienFu Chen (ctf) wrote :

CPU frequency can be changed via files under /sys/devices/system/cpu/cpu0/cpufreq/.

scaling_available_frequencies
scaling_available_governors: could be "conservative ondemand userspace powersave performance", when we want to change the frequency manually, we set it to "userspace".
scaling_cur_freq
scaling_setspeed

ex: sudo sh -c 'echo 2400000 > scaling_setspeed' # set frequency to 2400000(2.4G)
ex: cat scaling_cur_freq # check if the frequency has been changed.

TienFu Chen (ctf) wrote :

The setParameter() in cpu_scaling_test script will set the frequency via /sys files once cpufreq-selector failed.

TienFu Chen (ctf) wrote :

The cpufreq interfaces between 2.6. 38 and 3.0.0 are sightly different.
In 2.6.38(Natty), while governor is set to ondemand/conservative, there will be ondemand/conservative directory produced in "/sys/devices/system/cpu/cpu0/cpufreq".
In 3.0.0 kernel(Oneiric), the ondemand/conservative directory is produced in "/sys/devices/system/cpu/cpufreq".
checkbox in Oneiric still uses the old directory "/sys/devices/system/cpu/cpu0/cpufreq", so we got the error: /bin/sh: cannot create /sys/devices/system/cpu/cpu0/cpufreq/conservative/freq_step: Directory nonexistent.

TienFu Chen (ctf) wrote :

Tried the kernel parameter: maxcpus=1 on the Oneiric, result is same as comment #5

Daniel Manrique (roadmr) on 2011-09-26
Changed in checkbox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.8

---------------
checkbox (0.12.8) oneiric; urgency=low

  New upstream release (LP: #862579):

  [Brendan Donegan]
  * Remove test for FTP connection from network_check script (LP: #854222)
  * Update a parameter in usb_test to have it run faster.
  * Remove record_playback_after_suspend from Ubuntu Friendly whitelist (LP: #855540)
  * Fix minor typo in multi-monitor friendly resolution_test script which caused
    minimum_resolution test to fail (LP: #855599)
  * Remove storage_devices_test from Ubuntu Friendly whitelist since bonnie++ (which it uses) is not installed by default (LP: #855841)
  * Changed description and name to reflect Ubuntu Friendly branding. Now when a user searches for Ubuntu Friendly in the lens, Checkbox will appear (LP: #852036)
  * Reset the selections at the test suite prompt if No is selected at the recover prompt (LP: #861208)
  * Save the connection name(s) instead of the interface name so that they can be reconnected to properly after the wireless before/after suspend tests have completed (LP: #861502)
  * Make connect_wireless use the UUID of the connection instead of the name for greater reliability (LP: #862190)

  [Daniel Manrique]
  * Restored _recover attribute, re-enabling welcome and test selection
    screens (LP: #852204)
  * Remove memory/test from the Ubuntu Friendly whitelist (LP: #853799)
  * Use diff instead of grep, better comparing of empty files (LP: #852014)
  * Apport integration: new mandatory "tag" value in ApportOptions (LP: #852201)
  * Add warning prior to starting the tests (LP: #855328)
  * Apport integration: Fix instantiation of Gtk.RadioButton, needed due
    to PyGI related API changes (LP: #805679)
  * Remove ping -R parameter that apparently caused ICMP packets to be dropped
    by some routers (LP: #861404)

  [ Evan Broder ]
  * Replace resolution_test with an implementation which uses GdkScreen to
    be multimonitor-aware (LP: #632987)

  [Jeff Lane]
  * Fix names of optical drive tests and remove a non-existing test from the
    whitelist (LP: #854808)
  * Fix wireless_*_suspend jobs so they recreate iface file instead of append
    each time (LP: #855845)
    (LP: #852201)
  * Clarify better the intend of the is_laptop question (LP: #861844)
  * Fixed dependencies for tests that depend on suspend/suspend_advanced
    (LP: #860651)

  [Tim Chen]
  * Fix cpu_scaling_test (LP: #811177)

  [Ara Pulido]
  * Avoid connect_wireless messing with AP with similar names (LP: #861538)
  * Remove bluetooth/file-transfer from the list of tests to run, since due to
    bug 834348 it always fails.

  [Marc Tardif]
  * Added support for wildcards when verifying the transport certificate.
  * Applying depends across suites (LP: #861218)
 -- Daniel Manrique <email address hidden> Thu, 29 Sep 2011 13:12:01 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers