Checkbox bug submission: all radio buttons selected

Bug #805679 reported by Chad A. Davis on 2011-07-04
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Checkbox
High
Daniel Manrique
checkbox (Ubuntu)
High
Daniel Manrique

Bug Description

checkbox 0.12.4
Ubuntu oneiric alpha 2 (oneiric-dvd-amd64.iso from 2011-07-02)

Trying to report a bug after a certain test had failed, I was presented the 'what particular problem do you observe' screen, where every radio button is checked (screenshot attached). This prevents being able to submit a bug from within checkbox.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: checkbox-gtk 0.12.3
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic x86_64
Architecture: amd64
Date: Mon Jul 4 20:31:39 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110702)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: checkbox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :

The standard radio buttons on each test screen: 'Yes', 'No', 'Skip this test' work correctly, however.

Hi Chad,

Thanks for reporting this bug. I'll try and confirm it when I get a chance but I think this might be a problem in apport, as I don't think the report a problem function is part of checkbox.

Changed in checkbox (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2011-09-20
Changed in checkbox (Ubuntu):
importance: Undecided → Medium
Daniel Manrique (roadmr) wrote :

Bumping importance to High as bug reporting functionality is rather important on checkbox.

Changed in checkbox:
status: New → Confirmed
importance: Undecided → High
Changed in checkbox (Ubuntu):
importance: Medium → High
Daniel Manrique (roadmr) wrote :

Steps to reproduce:

- Launch checkbox
- On the test selection screen, deselect all tests and select only graphics/resolution under "Graphics"
- When the test asks whether the resolution is acceptable, respond "No" and press "Next".
- When asked if you want to report a bug, select "Yes"

Expected result:
- A list of symptoms with radio buttons from which I can select one and only one.

Actual result:
- All symptoms are checked.
- Pressing "Next" does nothing.
- Basically checkbox dies and needs to be forcibly quit.

This was tested on Oneiric and checkbox latest trunk as of today.

tags: added: testcase
Daniel Manrique (roadmr) on 2011-09-23
Changed in checkbox:
status: Confirmed → In Progress
assignee: nobody → Daniel Manrique (roadmr)
Changed in checkbox (Ubuntu):
assignee: nobody → Daniel Manrique (roadmr)
status: Confirmed → In Progress
Ara Pulido (ara) on 2011-09-26
Changed in checkbox:
milestone: none → 0.12.8
Changed in checkbox:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.8

---------------
checkbox (0.12.8) oneiric; urgency=low

  New upstream release (LP: #862579):

  [Brendan Donegan]
  * Remove test for FTP connection from network_check script (LP: #854222)
  * Update a parameter in usb_test to have it run faster.
  * Remove record_playback_after_suspend from Ubuntu Friendly whitelist (LP: #855540)
  * Fix minor typo in multi-monitor friendly resolution_test script which caused
    minimum_resolution test to fail (LP: #855599)
  * Remove storage_devices_test from Ubuntu Friendly whitelist since bonnie++ (which it uses) is not installed by default (LP: #855841)
  * Changed description and name to reflect Ubuntu Friendly branding. Now when a user searches for Ubuntu Friendly in the lens, Checkbox will appear (LP: #852036)
  * Reset the selections at the test suite prompt if No is selected at the recover prompt (LP: #861208)
  * Save the connection name(s) instead of the interface name so that they can be reconnected to properly after the wireless before/after suspend tests have completed (LP: #861502)
  * Make connect_wireless use the UUID of the connection instead of the name for greater reliability (LP: #862190)

  [Daniel Manrique]
  * Restored _recover attribute, re-enabling welcome and test selection
    screens (LP: #852204)
  * Remove memory/test from the Ubuntu Friendly whitelist (LP: #853799)
  * Use diff instead of grep, better comparing of empty files (LP: #852014)
  * Apport integration: new mandatory "tag" value in ApportOptions (LP: #852201)
  * Add warning prior to starting the tests (LP: #855328)
  * Apport integration: Fix instantiation of Gtk.RadioButton, needed due
    to PyGI related API changes (LP: #805679)
  * Remove ping -R parameter that apparently caused ICMP packets to be dropped
    by some routers (LP: #861404)

  [ Evan Broder ]
  * Replace resolution_test with an implementation which uses GdkScreen to
    be multimonitor-aware (LP: #632987)

  [Jeff Lane]
  * Fix names of optical drive tests and remove a non-existing test from the
    whitelist (LP: #854808)
  * Fix wireless_*_suspend jobs so they recreate iface file instead of append
    each time (LP: #855845)
    (LP: #852201)
  * Clarify better the intend of the is_laptop question (LP: #861844)
  * Fixed dependencies for tests that depend on suspend/suspend_advanced
    (LP: #860651)

  [Tim Chen]
  * Fix cpu_scaling_test (LP: #811177)

  [Ara Pulido]
  * Avoid connect_wireless messing with AP with similar names (LP: #861538)
  * Remove bluetooth/file-transfer from the list of tests to run, since due to
    bug 834348 it always fails.

  [Marc Tardif]
  * Added support for wildcards when verifying the transport certificate.
  * Applying depends across suites (LP: #861218)
 -- Daniel Manrique <email address hidden> Thu, 29 Sep 2011 13:12:01 -0400

Changed in checkbox (Ubuntu):
status: In Progress → Fix Released
Ara Pulido (ara) on 2011-09-30
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers