recovery asks yes/no question with a/b answers

Bug #786924 reported by Marcin Juszkiewicz on 2011-05-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Low
Robert Roth

Bug Description

Binary package hint: checkbox

root@linaro:~# checkbox-cli -l checkbox.log --log-level debug

Checkbox did not finish completely.
Do you want to recover from the previous run?

  a: yes
  b: no

Please choose (a/b): n
  a: yes
  b: no

Please choose (a/b): b
Welcome to System Testing!

Checkbox provides tests to confirm that your system is working properly. Once you are finished running the tests, you can view a summary report for your system.

Press any key to continue...

"Do you want to recover" question should accept y/n as this is intuitive for users.

Related branches

Hi Marcin,

Thanks for reporting this, I confirmed the behaviour - but since it's just a simple usability issue (the command line does make it clear that a/b are the accepted options), and only affects the CLI version of checkbox I'll be setting it to low.

Changed in checkbox (Ubuntu):
status: New → Confirmed
Ara Pulido (ara) wrote :

Accepting Brendan's proposal of Low importance

Changed in checkbox (Ubuntu):
importance: Undecided → Low
Jeff Lane (bladernr) wrote :

Just a quick look through the code that generates the CLI prompts and ...ugh...

I'm not completely sure, but I think the a and b options are just the behaviour of whatever is used to create the prompt. There may be a way to arbitrarily change a and b to 1 and 2, perhaps, but that'll take more digging than what I had time to do today.

Robert Roth (evfool) on 2011-05-24
Changed in checkbox (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Confirmed → In Progress
Marc Tardif (cr3) on 2011-05-25
Changed in checkbox (Ubuntu):
status: In Progress → Fix Committed

Confirmed this works in the latest checkbox

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers