System Test does not show "Select All" button when asking which tests to perform

Bug #776734 reported by Thibault D on 2011-05-03
16
This bug affects 4 people
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Low
Daniel Manrique

Bug Description

Binary package hint: checkbox

French version of Ubuntu 10.04
Fresh installation

Step 1 : open "System Check"
Step 1b : click "no" if it asks you to continue a previous session
Step 2 : click "Next", type your password and click "Validate"
Step 3 : System Check asks you which tests to perform and you have to select several checkboxes

If you want to select them all, you can't directly as you can't see the appropriate button to do so : you have to enlarge the window manually to see it. The length of the words in french might be the reasons why all buttons are not visible.

On the french version :
- "Select all" is "Tout sélectionner"
- "Select none" is "Tout désélectionner"

See screenshot here attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: checkbox-gtk 0.11.3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CheckboxSubmission: 9e6554c36969a101b9e0e3075c8ffbe0
CheckboxSystem: b8f3ec504801f13fc208edb5c785b099
Date: Tue May 3 23:16:02 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: checkbox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Thibault D (thibdrev) wrote :
Daniel Manrique (roadmr) wrote :

Confirmed, and it's indeed due to the Checkbox window being fixed-size, while the buttons might change sizes due to label lengths in different languages. I confirmed in spanish.

Assuming language packs are installed:

sudo apt-get install language-pack-gnome-{fr,es}

you can reproduce this without changing the systemwide language preference:

LANG="es_ES.UTF-8"; checkbox-gtk

or

LANG="fr_FR.UTF-8"; checkbox-gtk

Changed in checkbox (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) on 2011-05-24
Changed in checkbox (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Daniel Manrique (roadmr)
Changed in checkbox (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
Daniel Manrique (roadmr) on 2011-06-08
Changed in checkbox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.12.1

---------------
checkbox (0.12.1) oneiric; urgency=low

  New upstream release (LP: #796629):

  [Brendan Donegan]
  * Fix timeout in sleep_test script (LP: #665299)
  * Fix traces in hyper_text_view module (LP: #796508)
  * Added camera test (LP: #764222)

  [Daniel Manrique]
  * Fix GUI definition file so main window uses "natural request", growing
    when child widgets require so (LP: #776734)
  * Fix open/read blocking behavior and backend/frontend communications to
    avoid hangs and lingering backends. (LP: #588539)
  * Render header text dynamically over the image background, and updated pot
    file with the new string. (LP: #621880)

  [Robert Roth]
  * Improve command line key prompts (LP: #786924)
 -- Marc Tardif <email address hidden> Tue, 14 Jun 2011 08:30:52 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers