run crashed with KeyError in runner(): 'duration' System-Check Ubuntu Hardware Database crashed while Microphone check

Bug #729431 reported by Rene Titzmann on 2011-03-05
316
This bug affects 57 people
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
High
Marc Tardif

Bug Description

System-Check Ubuntu Hardware Database crashed while Microphone check

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: checkbox 0.11.1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Sat Mar 5 01:37:54 2011
ExecutablePath: /usr/share/checkbox/run
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/share/checkbox/run /usr/share/checkbox/configs/checkbox-gtk.ini
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_DE.UTF-8
 LANGUAGE=de_DE:de:en_GB:en
PythonArgs: ['/usr/share/checkbox/run', '/usr/share/checkbox/configs/checkbox-gtk.ini']
SourcePackage: checkbox
Title: run crashed with KeyError in runner(): 'duration'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Rene Titzmann (rene-titzmann) wrote :
affects: ubuntu → checkbox (Ubuntu)
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
visibility: private → public
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → High
Jeff Lane (bladernr) wrote :

I am unable to reproduce this locally on Thinkpad x201 running through all the audio tests in the System Testing suite.

Dennis Baudys (thecondordb) wrote :

Try the simple test 'natilus_create_folder'. This crashes too, look at all the duplicates – I assume it happens with some other tests, too.

Dennis Baudys (thecondordb) wrote :

Could it be possible that the crash only occurs when running Natty inside a virtual machine? Maybe some of the reporters accidently didn't mention it – like me in my previous comment to this bug.

David Henningsson (diwic) wrote :

No, this also happens outside a VM. I think you can reproduce it through doing things such as
1) press test to hear the test tone
2) select "no", then next (and "no" on the "do you wish to report a bug" question)
3) press previous
4) press test to hear the test tone
5) select "yes", then next
6) press previous
If the bug hasn't appeared by now, go back to 1)

Not in my case. I'm running a native install on a hard drive. It is
not quite consistent. I did get one of the run-tests to work once -
next time I tried, that one failed with the same error.

Marc Tardif (cr3) wrote :

Thanks for the thorough bug report, folks. The problem is that the manual plugin calls upon the shell plugin to run some tests that happen to have a command. However, this has no guarantee of setting the output nor the duration of the command in some cases. For example, when there is no command or when the command has already been run. So, I'm attaching a branch that removes this assumption which should address these exceptions from occuring.

Changed in checkbox (Ubuntu):
status: New → In Progress
Daniel Manrique (roadmr) wrote :

Here's another sequence of steps to reproduce. Verified with checkbox 0.10.3 on Maverick and 0.11.12 on Natty beta.

1- Delete .cache/checkbox if it exists (to ensure a clean run)
2- Run checkbox-gtk from a terminal (so you can see terminal output)
3- Press Next, then deselect all tests and check only Audio tests. press Next.
4- On the first test, press Next again, then Previous (brings you to the test list again), then Next (brings you to a sound test).
5- Press the "Test" button.

Expected result:
- Rerunning of the selected test, in this case I was expecting the audio tone to play again.

Actual result:
- Test doesn't run
- Trace as follows:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/checkbox_gtk/gtk_interface.py", line 479, in <lambda>
    lambda w, t=test, r=runner: self._run_test(t, r))
  File "/usr/lib/python2.7/dist-packages/checkbox_gtk/gtk_interface.py", line 450, in _run_test
    (status, data, duration) = runner(test)
  File "/usr/share/checkbox/plugins/manual_test.py", line 37, in runner
    return (temp["status"], temp["data"], temp["duration"])
KeyError: 'duration'

I'm also attaching the full checkbox.log file where this error appears (there's also another one from when I interrupted checkbox by pressing ctrl-c, please disregard).

I have noticed, like most other comments, that the triggering behavior is using the "previous" button.

Marc Tardif (cr3) on 2011-04-05
Changed in checkbox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.11.3

---------------
checkbox (0.11.3) natty; urgency=low

  New upstream release (LP: #751928)
  * Fixed sleep_test crashing with ioerror (LP: #630785)
  * Fixed keyerror when running some manual tests (LP: #729431)

  [Ara Pulido]
  * Video bugs should be reported as a display symptom (LP: #744964)
  * Added checkbox log to apport report
 -- Marc Tardif <email address hidden> Tue, 05 Apr 2011 16:19:17 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.