sleep_test crashed with IOError in SetWakeTime()

Bug #630785 reported by André Lopes on 2010-09-05
110
This bug affects 14 people
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
High
Marc Tardif

Bug Description

Binary package hint: checkbox

HIBERNATE/RESUME

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: checkbox 0.10.2
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Sun Sep 5 12:45:01 2010
ExecutablePath: /usr/share/checkbox/scripts/sleep_test
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/checkbox/scripts/sleep_test -s disk -w 120 --debug
ProcEnviron:
 LANGUAGE=pt_PT:pt:pt_BR:en
 PATH=(custom, no user)
 LANG=pt_PT.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/checkbox/scripts/sleep_test', '-s', 'disk', '-w', '120', '--debug']
SourcePackage: checkbox
Title: sleep_test crashed with IOError in SetWakeTime()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

André Lopes (zipatei) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
Martin Pitt (pitti) on 2011-04-05
visibility: private → public
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → High
Marc Tardif (cr3) wrote :

Thanks for the bug reports, the problem is that hibernate_once does not specify the test should be run as root. I'm attaching a branch that should fix this problem.

Marc Tardif (cr3) on 2011-04-05
Changed in checkbox (Ubuntu):
status: New → In Progress
Marc Tardif (cr3) on 2011-04-05
Changed in checkbox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.11.3

---------------
checkbox (0.11.3) natty; urgency=low

  New upstream release (LP: #751928)
  * Fixed sleep_test crashing with ioerror (LP: #630785)
  * Fixed keyerror when running some manual tests (LP: #729431)

  [Ara Pulido]
  * Video bugs should be reported as a display symptom (LP: #744964)
  * Added checkbox log to apport report
 -- Marc Tardif <email address hidden> Tue, 05 Apr 2011 16:19:17 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers