udev_resource crashed with KeyError in product()

Bug #537435 reported by Ken Weill P. Lumacad on 2010-03-11
180
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Checkbox
High
Marc Tardif
checkbox (Ubuntu)
High
Marc Tardif

Bug Description

Binary package hint: checkbox

I tried to run System Testing from System - Administration, then it crashed.

ProblemType: Crash
Architecture: i386
Date: Thu Mar 11 23:34:56 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/checkbox/scripts/udev_resource
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
InterpreterPath: /usr/bin/python2.6
Package: checkbox 0.9
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/checkbox/scripts/udev_resource
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_PH.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
PythonArgs: ['/usr/share/checkbox/scripts/udev_resource']
SourcePackage: checkbox
Title: udev_resource crashed with KeyError in product()
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

tags: removed: need-duplicate-check
Steve Beattie (sbeattie) on 2010-03-17
visibility: private → public
tags: added: iso-testing
Steve Beattie (sbeattie) on 2010-03-17
Changed in checkbox (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Fiona Conn (roseyeagle) wrote :

Running Lucid from within Virtual Box on Ubuntu 9.10.

Calysto (clairedesbois) wrote :

I test Lucid with Virtual Box on Fedora 12

Marc Tardif (cr3) wrote :

Please provide the listing of the directory /sys/devices/virtual/dmi/id

Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
Changed in checkbox (Ubuntu):
status: Confirmed → Incomplete
Marc Tardif (cr3) wrote :

bios_date
bios_vendor
bios_version
modalias
power
product_name
product_serial
product_uuid
product_version
subsystem
sys_vendor
uevent

Marc Tardif (cr3) wrote :

So, the challenge seems to be that vbox does not expose any chassis nor any board information. This is strange because both VMware and KVM at least expose some virtual representation of that information.

Changed in checkbox:
importance: Undecided → High
status: New → Fix Committed
Changed in checkbox (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.1

---------------
checkbox (0.9.1) lucid; urgency=low

  New upstream release (LP: #548800):
  * Added cpu_scaling_test script.
  * Fixed hard drive detection (LP: #549714)
  * Fixed backend to handle empty messages (LP: #536645)
  * Fixed parsing of package resource (LP: #539691)
  * Fixed malformed xml report (LP: #485445)
  * Fixed running root manual tests as normal user (LP: #383559)
  * Fixed writing apport files only after submitting (LP: #530380)
  * Fixed audio test instructions (LP: #529205)
  * Fixed gathering chassis information (LP: #537435)
  * Fixed detection of disks in kvm (LP: #552998)
  * Fixed udev_resource script to be more resilient (LP: #552999)
  * Fixed filter_packages script to use new resources.
 -- Marc Tardif <email address hidden> Sun, 07 Mar 2010 15:05:44 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
Marc Tardif (cr3) on 2010-04-02
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers