backend crashed with ValueError in loads()

Bug #536645 reported by Haggai Eran on 2010-03-10
This bug affects 501 people
Affects Status Importance Assigned to Milestone
Checkbox
Undecided
Marc Tardif
checkbox (Ubuntu)
Medium
Marc Tardif
Lucid
Medium
Marc Tardif

Bug Description

Binary package hint: checkbox

Checkbox skips all tests except the moniter tests, and I get this crash report.

ProblemType: Crash
Architecture: i386
Date: Wed Mar 10 13:29:26 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/checkbox/backend
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100310)
Package: checkbox 0.9
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/checkbox/backend /tmp/checkboxWg38Oj/input /tmp/checkboxWg38Oj/output
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=he_IL.utf8
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
PythonArgs: ['/usr/share/checkbox/backend', '/tmp/checkboxWg38Oj/input', '/tmp/checkboxWg38Oj/output']
SourcePackage: checkbox
Title: backend crashed with ValueError in loads()
Uname: Linux 2.6.32-16-generic i686
UserGroups:

Related branches

Haggai Eran (haggai-eran) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
visibility: private → public
Changed in checkbox (Ubuntu):
importance: Undecided → High
Changed in checkbox (Ubuntu):
status: New → Triaged
tags: added: bugpattern-written
removed: bugpattern-needed

Lucid w/updates as of 16 Mar 2010 in VBox 3.1.4 r57640 on Ubuntu 8.04.4. Dell Latitude D800 1.4 Ghz notebook.

"System Testing" (checkbox) runs my requested tests, but will not submit to Launchpad. Reports backend crash.

tags: added: bugpattern-needed
tags: added: iso-testing
Krasimir Chonov (kchonov) wrote :

It`s affecting me too. I`m using Ubuntu 10.04 i386 from 2010-03-18. ISO-testing.

Changed in checkbox (Ubuntu):
assignee: nobody → Rotilio Salvatore (salvy)
Nigel Babu (nigelbabu) wrote :

Please do not assign bugs to yourself unless you intent to fix it.

Changed in checkbox (Ubuntu):
assignee: Rotilio Salvatore (salvy) → nobody
Changed in checkbox:
assignee: nobody → Rotilio Salvatore (salvy)
Changed in checkbox (Ubuntu):
assignee: nobody → Rotilio Salvatore (salvy)
Changed in checkbox:
assignee: Rotilio Salvatore (salvy) → nobody
Changed in checkbox (Ubuntu):
assignee: Rotilio Salvatore (salvy) → nobody
Rotilio Salvatore (salvy) wrote :

sorry i'm mistake,
 this bug affecting me, i'm new user in this wiki sorry for this error

Salvatore.

murmelhunter (dirk-drehlich) wrote :

I just got the same error while running the system test for uploading the info

murmelhunter (dirk-drehlich) wrote :

the rest seems to be quite stable so far

mst1970 (stegmueller) wrote :

affect me after BUG: #542695

W Hamilton (hexuan) wrote :

No recollection of this crash. There was a system hang on first run after reboot command on initial installation via USB key which resulted in a failure to shut down, then running normally after first full startup sequence. That might have been it.

was trying to install vbox while firefox open. think i ran out of memory only 512mb in this machine

Linards Ticmanis (ticmanis) wrote :

I was only closing checkbox without running any tests. Then this one came up.

Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
M Henri Day (mhenriday) wrote :

Same thing here on a 64-bit system....

Henri

kwalo (kwalo) wrote :

I was also getting notification about kernel crashes, when running checkbox. I didn't find anything interesting in dmesg, except for few deprecation warnings from sysfs:

[ 250.029201] thinkpad_acpi: WARNING: sysfs attribute hotkey_enable is deprecated and will be removed. Hotkey reporting is always enabled
[ 250.029301] thinkpad_acpi: deprecated sysfs attribute: access by process with PID 2161
[ 250.029303] thinkpad_acpi: WARNING: sysfs attribute hotkey_bios_mask is deprecated and will be removed. This attribute is useless.
[ 250.032227] thinkpad_acpi: deprecated sysfs attribute: access by process with PID 2161
[ 250.032230] thinkpad_acpi: WARNING: sysfs attribute bluetooth_enable is deprecated and will be removed. Please switch to generic rfkill before year 2010

Dave H (dave-hills-2009) wrote :

Put my netbook into standby while I had my tea. Crash report indicted when returning from standby, Had Firefox open, nothing else. No noticeable crash.

Still valid for me: Lucid beta 1 in VBox 3.1.6 r59338 w/Guest Additions on Ubuntu 8.04.4. Hardware: Dell Latitude D800 notebook 1.4 Ghz.

Brian Murray (brian-murray) wrote :

This seems to happen if you close checkbox with the red "X" which really is the only way to exit it other than proceeding through everything.

Changed in checkbox (Ubuntu Lucid):
importance: High → Medium
Stephen Cradock (s-cradock) wrote :

I tried to run checkbox (amd64, not virtualized) and got messages that no hard drive was found. Closing checkbox using red X button generated this crash. Needless to say I do have a hard-drive; this is not a netbook, running lucid beta fully-updated as of March 26th 2010 10 am PDT.

Same thing happened to me as described by Stephen.

Attached the saved checkbox output as html file.

Zeb (zebcarnell) wrote :

Same issue for me when closing an error on amd64

TommyBoy (thomaslloyd) wrote :

This occurs on my Dell inspirion 1525 after a hibernate.

Wouter Moeken (w-moeken) wrote :

Occured on my Dell Studio 1749 after a hibernate

Marc Tardif (cr3) on 2010-03-28
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
status: New → Fix Committed
Changed in checkbox (Ubuntu Lucid):
status: Triaged → Fix Committed
John Yaldwyn (jy-4hf) wrote :

I didn't actually run any test just opened System Testing, clicked Next, then closed the window. Lucid 10.04.

Changed in checkbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
G4JC (gaming4jc2) wrote :

Just got this bug on March 31st amd64 daily build of lucid.

Roy Jamison (xteejx) wrote :

All updates 1st April amd64, checkbox gives same problem as above, but checkbox didn't skip any tests itself, I skipped quite a few though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.1

---------------
checkbox (0.9.1) lucid; urgency=low

  New upstream release (LP: #548800):
  * Added cpu_scaling_test script.
  * Fixed hard drive detection (LP: #549714)
  * Fixed backend to handle empty messages (LP: #536645)
  * Fixed parsing of package resource (LP: #539691)
  * Fixed malformed xml report (LP: #485445)
  * Fixed running root manual tests as normal user (LP: #383559)
  * Fixed writing apport files only after submitting (LP: #530380)
  * Fixed audio test instructions (LP: #529205)
  * Fixed gathering chassis information (LP: #537435)
  * Fixed detection of disks in kvm (LP: #552998)
  * Fixed udev_resource script to be more resilient (LP: #552999)
  * Fixed filter_packages script to use new resources.
 -- Marc Tardif <email address hidden> Sun, 07 Mar 2010 15:05:44 -0400

Changed in checkbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
Marc Tardif (cr3) on 2010-04-02
Changed in checkbox:
status: Fix Committed → Fix Released
duckwhistle (nicoll-mg) wrote :

Using 64 bit system, crash report detected following close of System Testing app, no unusual behavior whilst in use.

MoLE (moleonthehill) wrote :

checkbox 0.9 still in the beta 1 ISO, so hopefully will be included in the next beta ISO.

Roy Jamison (xteejx) wrote :

The current version is 0.9.1 in Lucid, so it should be available later today/tomorrow when Beta 2 is released.

dpursehouse (david-pursehouse) wrote :

This bug still appears to be in 'System Testing' in the final release. downloaded new release 30/04, run from Live USB, run System Testing and run through teh mionitor tests - do not supply email address, just view the report, then "finish", and as soon as user clicks finish, "backend" process takes one core to 100% usage. Using top, user can see Backend process running as root, and is able to kill it to restore cpu to normal usage.

Claudio Bastos (claudiobastos) wrote :

This bug still occur.

I upgraded my 9.10 to 10.04LTS in 2010-05-08.

I try 'System Testing' and it crashes in 'Video Tests', skipping to "delivery report" screen.

To post a comment you must log in.