(checkbox) "System Testing" application will not submit to Launchpad

Bug #531010 reported by Glenn Brumfield on 2010-03-02
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Checkbox
Undecided
Marc Tardif
checkbox (Ubuntu)
Critical
Marc Tardif

Bug Description

Binary package hint: checkbox

XML Parsing Error: not well-formed
Location: file:///home/glenn/.cache/checkbox/submission.xml
Line Number 4001, Column 53: Checking for texture_from_pixmap... [SKIP]
----------------------------------------------------^

Error: Required fields not contained in POST data: submission_key, system

I am able to log into Launchpad account, but not from "System Testing" application to report to the Launchpad hardware database at https://launchpad.net/+login. When I enter my email address, I get the above error message.

checkbox 0.8.6

fresh installation of Lucid Lynx alpha 3 & updates in VBox 3.1.4 r57640 w/Guest Additions on Ubuntu 8.04.4; Dell Latitude D800

ProblemType: Bug
ApportLog:
 apport (pid 1539) Tue Mar 2 14:32:08 2010: called for pid 1519, signal 11
 apport (pid 1539) Tue Mar 2 14:32:08 2010: executable: /usr/lib/openoffice/program/soffice.bin (command line "/usr/lib/openoffice/program/soffice.bin -writer -splash-pipe=5")
 apport (pid 1539) Tue Mar 2 14:32:35 2010: wrote report /var/crash/_usr_lib_openoffice_program_soffice.bin.1000.crash
Architecture: i386
CrashReports: 600:1000:1000:7194181:2010-03-02 14:32:34.638514000 -0600:2010-03-02 14:42:35.813076181 -0600:/var/crash/_usr_lib_openoffice_program_soffice.bin.1000.crash
Date: Tue Mar 2 16:02:47 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: apport 1.12.1-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: apport
Uname: Linux 2.6.32-15-generic i686

Related branches

I forgot to mention that Lucid Lynx was installed with the "encrypted file system" option enabled.

After updating Lucid on 11 MAR 2010 to include latest checkbox, I received the following error:

Failed to process form: Value of 'field.system' key of dict {'field.architecture': 'i386', 'field.distribution': 'Ubuntu', 'field.date_created': '2010-03-11T21:47:09', 'field.emailaddress': '<email address hidden>', 'field.contactable': 'False', 'field.distroseries': '10.04', 'field.actions.upload': 'Upload', 'field.private': 'False', 'field.format': 'VERSION_1', 'field.live_cd': 'False'} could not be converted: None isn't acceptable as a value

Hi. Using Lucid Lynx without efs-option (as I think). This error appeared:

Failed to process form: 'field.submission_data' is not a valid key as per {'field.architecture': <functools.partial object at 0x103d050>, 'field.distribution': <functools.partial object at 0x103d730>, 'field.system': <functools.partial object at 0x103d788>, 'field.actions.upload': <functools.partial object at 0x103d7e0>, 'field.private': <functools.partial object at 0x103d838>, 'field.format': <functools.partial object at 0x103d890>, 'field.contactable': <functools.partial object at 0x103d8e8>, 'field.date_created': <functools.partial object at 0x103d940>, 'field.emailaddress': <functools.partial object at 0x103d998>, 'field.submission_key': <functools.partial object at 0x103d9f0>, 'field.distroseries': <functools.partial object at 0x103da48>, 'field.live_cd': <functools.partial object at 0x103daa0>}

Still valid for Lucid beta 1 as of 23 March.

Robert Roth (evfool) wrote :

I cannot submit report neither in Lucis beta 1 from 23 march all updates installed, first time I try I get something like 'cannot submit to server, please try again later', and if i click submit again, i get the message from comment #4.

yoda42 (yoda42) wrote :

Attaching submission.xml file created by my system which also exhibits this condition. Repeated send attempts result in the "failed to process form error described above," for which my variant is included below.

Can one submit submission.xml manually to launchpad?

Failed to process form: 'field.submission_data' is not a valid key as per {'field.architecture': <functools.partial object at 0x9c8b43c>, 'field.distribution': <functools.partial object at 0x9cfe6bc>, 'field.system': <functools.partial object at 0x9cfe6e4>, 'field.actions.upload': <functools.partial object at 0x9cfe70c>, 'field.private': <functools.partial object at 0x9cfe734>, 'field.format': <functools.partial object at 0x9cfe75c>, 'field.contactable': <functools.partial object at 0x9cfe784>, 'field.date_created': <functools.partial object at 0x9cfe7ac>, 'field.emailaddress': <functools.partial object at 0x9cfe7d4>, 'field.submission_key': <functools.partial object at 0x9cfe7fc>, 'field.distroseries': <functools.partial object at 0x9cfe824>, 'field.live_cd': <functools.partial object at 0x9cfe84c>}

Anxious Nut (anxiousnut) wrote :

using lucid beta, fs not encrypted, i got this

Failed to process form: 'field.submission_data' is not a valid key as per {'field.architecture': <functools.partial object at 0xb768f84c>, 'field.distribution': <functools.partial object at 0xb768f874>, 'field.system': <functools.partial object at 0xb768f89c>, 'field.actions.upload': <functools.partial object at 0xb768f8c4>, 'field.private': <functools.partial object at 0xb768f8ec>, 'field.format': <functools.partial object at 0xb768f914>, 'field.contactable': <functools.partial object at 0xb768f93c>, 'field.date_created': <functools.partial object at 0xb768f964>, 'field.emailaddress': <functools.partial object at 0xb768f98c>, 'field.submission_key': <functools.partial object at 0xb768f9b4>, 'field.distroseries': <functools.partial object at 0xb768f9dc>, 'field.live_cd': <functools.partial object at 0xb768fa04>}

the submission.xml in firefox says
XML Parsing Error: not well-formed
Location: file:///home/mohammed/.cache/checkbox/submission.xml
Line Number 8340, Column 53: Checking for texture_from_pixmap... [SKIP]
----------------------------------------------------^(arrow was directing at the symbol [001B])

Still valid for me in Lucid beta 1 (encrypted fs).

Jorge Castro (jorge) on 2010-03-27
Changed in checkbox (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Josh Anders (cybiko123) wrote :

Same issue as Glenn on Lucid Beta 1.

My submission.xml is attached.

Marc Tardif (cr3) on 2010-03-29
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
GaryW (gnubyexample) wrote :

Running Lucid beta1

Getting the "None isn't acceptable as a value" error as mentioned by Glenn in comment #3

A quick look at the output from ps had me thinking that maybe there should be a systemid or similar passed between these programs calls?

: #root@amd754n(~) ;ps axuwwwwf | grep checkbox
1000 1831 0.0 0.0 4204 244 ? S 13:12 0:00 /bin/bash /usr/bin/checkbox-gtk
1000 1833 0.5 2.4 89220 12256 ? S 13:12 0:58 \_ python /usr/share/checkbox/run /usr/share/checkbox/configs/checkbox-gtk.ini
1000 1835 0.0 0.4 36184 2512 ? S 13:12 0:00 \_ gksu -k -- /usr/share/checkbox/backend /tmp/checkboxvVAp43/input /tmp/checkboxvVAp43/output
root 1840 0.0 0.1 8184 804 ? Ss 13:12 0:00 \_ /usr/bin/python /usr/share/checkbox/backend /tmp/checkboxvVAp43/input /tmp/checkboxvVAp43/output

Screenshot (redacted) attached.

Marc Tardif (cr3) wrote :

There are several problems reported in this bug which may indeed result in not submitting to Launchpad.

Glenn, the "XML Parsing Error: not well-formed" error you reported was already reported in bug #485445. This will be fixed in version 9.1 of Checkbox.

Gary, the problem about the system id being set to None might be related to bug #537435. If you were running Lucid in virtualbox, then this will be fixed in version 9.1 of Checkbox. Otherwise, please report a separate bug.

As for other reports, I have been informed that there was also a problem on the Launchpad side. I will follow up about that problem on this bug report.

Fixed for me with Checkbox version 9.1. Thank you! :)

dangyogi (dangyogi) wrote :

Running System Test from Live CD boot, it refuses to send info to launchpad, saying that I had not entered my email address. I had already logged into launchpad to report a different error, and was still logged in. Hitting the login link, it says I'm already logged in. Trying to log out and then hit the link again, it still says I'm logged in and hitting Next on the System Testing screen still says I have not entered my email address...

dangyogi (dangyogi) wrote :

Sorry, forgot to say ubuntu 10.04 beta 1 desktop i386 32-bit Live CD.

Marc Tardif (cr3) wrote :

dangyogi, the problem you reported affected Checkbox or Launchpad as detailed in bug #550973 which is actually assigned to both projects. Launchpad released a fix on the 14th, a few days after you reported your bug, and Checkbox only committed a fix which should be released with version 0.9.2 of the application.

This bug is not quite a duplicate of bug #550973 but I will nonetheless mark it as fix committed because the problem should be fixed in the long term with version 0.9.2 once it is released.

Changed in checkbox:
status: New → Fix Committed
Changed in checkbox (Ubuntu):
status: Confirmed → Fix Committed
Marc Tardif (cr3) on 2010-09-16
Changed in checkbox:
status: Fix Committed → Fix Released
Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
I Craft Crafts (icraftcrafts) wrote :

similar bug trying to upload report with fresh ubuntu 10.10 desktop. 2 days old and this must be the best ubuntu ever! it seriously rocks

I Craft Crafts (icraftcrafts) wrote :

during the first try it just couldnt log me into the server. this happens afterwards though. no proxy server etc. direct connection to adsl router and internet

Failed to process form: 'field.submission_data' is not a valid key as per {'field.architecture': <functools.partial object at 0x925525c>, 'field.distribution': <functools.partial object at 0x92559dc>, 'field.system': <functools.partial object at 0x9255a04>, 'field.actions.upload': <functools.partial object at 0x9255a2c>, 'field.private': <functools.partial object at 0x9255a54>, 'field.format': <functools.partial object at 0x9255a7c>, 'field.contactable': <functools.partial object at 0x9255aa4>, 'field.date_created': <functools.partial object at 0x9255acc>, 'field.emailaddress': <functools.partial object at 0x9255af4>, 'field.submission_key': <functools.partial object at 0x9255b1c>, 'field.distroseries': <functools.partial object at 0x9255b44>, 'field.live_cd': <functools.partial object at 0x9255b6c>}

This bug is back.

Changed in checkbox:
status: Fix Released → Confirmed
Changed in checkbox (Ubuntu):
status: Fix Released → Confirmed

Test data to reproduce using my ~/.cache/checkbox folder.

Marc Tardif (cr3) wrote :

This problem occurs when submitting a second time, after which the form dictionary contains the field.submission_data key. However, this key is not included in the FORM Map property defined in the launchpad_exchange plugin. Furthermore, this key is a file type which is not even available in the current set of properties.

To fix this bug, I created the new FileVariable class, the File property using that variable class and added the field.submission_data key to the FORM table. This should make it for Natty, thanks for the bug report.

Changed in checkbox (Ubuntu):
status: Confirmed → Fix Committed
Changed in checkbox:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.11.2

---------------
checkbox (0.11.2) natty; urgency=low

  New upstream release (LP: #736919):
  * Added version to dpkg dependency
  * Added multiarch support to install script (LP: #727411)
  * Fixed submitting data twice (LP: #531010)
  * Fixed job descriptions for checkbox-cli (LP: #221400)

  [Daniel Manrique]
  * Fixed strings in audio tests and updated pot file (LP: #691241)

  [Jochen Kemnade]
  * Fixed grammar in user-apps tests (LP: #642001)

  [Jeff Lane]
  * Added reboot instructions to suspend/hibernate tests (LP: #420493)
  * Made the firewire instructions make more sense (LP: #693068)

  [Michael Terry]
  * Fixed several strings appear in English although translated (LP: #514401)
    - jobs/fingerprint.txt.in
    - jobs/media.txt.in
    - jobs/monitor.txt.in
    - jobs/sleep.txt.in
    - jobs/firewire.txt.in
    - po/checkbox.pot
  * Fixed grammar (LP: #525454)
    + jobs/fingerprint.txt.in
 -- Marc Tardif <email address hidden> Thu, 17 Mar 2011 11:15:12 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers