checkbox writes to .cache/checkbox/submission before submission completes

Bug #530380 reported by Brian Murray on 2010-03-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Marc Tardif
checkbox (Ubuntu)
High
Marc Tardif
Lucid
High
Marc Tardif

Bug Description

Binary package hint: checkbox

When running checkbox a new submission id is generated for use by the hardware database and the system id stays the same. However, if one exits checkbox before the information is submitted to Launchpad the submission id, found in .cache/checkbox/submission, is still changed.

This becomes a problem when later someone reports a bug using apport and the HWD-Submission information in Launchpad (used by linkHWSubmission) is populated by this submission id. The bug will either be linked to a non-existent (or wrong) hwdb submission or be linked to nothing at all. Neither of these is the intended behavior.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: fee5e196cb921cbd36888f428b38b488
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Mon Mar 1 15:03:33 2010
DistroRelease: Ubuntu 10.04
Package: checkbox 0.8.6
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SourcePackage: checkbox
Uname: Linux 2.6.32-13-generic x86_64

Related branches

Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :

For example if you were to search the database for the CheckboxSubmission in this bug report you would not, or should not, find it.

Brian Murray (brian-murray) wrote :

Abel - what will happen in the case that an invalid or non-existent HWDB-Submission is used when reporting a bug in Launchpad?

Changed in checkbox (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in checkbox (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 02.03.2010 00:17, Brian Murray wrote:
> Abel - what will happen in the case that an invalid or non-existent
> HWDB-Submission is used when reporting a bug in Launchpad?
>

unfortunately, nothing... The line
"CheckboxSubmission: fee5e196cb921cbd36888f428b38b488" is at present
simply not processed...

I filed bug 530556 about it.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFLjNbOekBPhm8NrtARAm+xAJ4mulliIMVnG/tx5LQdHsEidMiiWQCgnzzJ
EIB3K8QqoJhSctU1wzxPzYI=
=EV4U
-----END PGP SIGNATURE-----

Abel Deuring (adeuring) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 02.03.2010 10:14, Abel Deuring wrote:
> On 02.03.2010 00:17, Brian Murray wrote:
>> Abel - what will happen in the case that an invalid or non-existent
>> HWDB-Submission is used when reporting a bug in Launchpad?
>
>
> unfortunately, nothing... The line
> "CheckboxSubmission: fee5e196cb921cbd36888f428b38b488" is at present
> simply not processed...
>
> I filed bug 530556 about it.

...and this is complete nonsense -- I was too stupid to find the code
when I wrote the answer.
lp.bug.browser.bugtarget.FileBugViewBase.submit_bug_action does indeed
create links between bugs and HWDB submissions:

         for submission_key in extra_data.hwdb_submission_keys:
             submission = submission_set.getBySubmissionKey(
                 submission_key, self.user)
             if submission is not None:
                 bug.linkHWSubmission(submission)

(line 648).

So: A link between a bug and a HWDB submission is created, if the the
HWDB submission exists. If doesn't for whichever reason (mostly likely
because checkbox did create a submission ID but nothing was uploaded or
an error like a timeout occurred during the upload), the invalid /
non-extistent submission key is silently ignored.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD4DBQFLjjryekBPhm8NrtARAsmwAJY6m31N9lwmSYMi8HaOrEVDxEQcAJ98rq0r
bp0H3NEemAkQnnZHIbqNSg==
=gXiC
-----END PGP SIGNATURE-----

Marc Tardif (cr3) on 2010-03-05
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
Changed in checkbox (Ubuntu Lucid):
assignee: nobody → Marc Tardif (cr3)
Marc Tardif (cr3) on 2010-03-08
Changed in checkbox:
status: New → Fix Committed
importance: Undecided → Medium
Steve Langasek (vorlon) wrote :

If the fix was committed 10 days ago, what's preventing the bug from being fixed in the archive? This has now missed beta-1.

Changed in checkbox (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Marc Tardif (cr3) wrote :

The reason is the review process for inclusion in the main archive was longer than expected. The merge request has been finally approved yesterday, see bug #548800 for more details.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.1

---------------
checkbox (0.9.1) lucid; urgency=low

  New upstream release (LP: #548800):
  * Added cpu_scaling_test script.
  * Fixed hard drive detection (LP: #549714)
  * Fixed backend to handle empty messages (LP: #536645)
  * Fixed parsing of package resource (LP: #539691)
  * Fixed malformed xml report (LP: #485445)
  * Fixed running root manual tests as normal user (LP: #383559)
  * Fixed writing apport files only after submitting (LP: #530380)
  * Fixed audio test instructions (LP: #529205)
  * Fixed gathering chassis information (LP: #537435)
  * Fixed detection of disks in kvm (LP: #552998)
  * Fixed udev_resource script to be more resilient (LP: #552999)
  * Fixed filter_packages script to use new resources.
 -- Marc Tardif <email address hidden> Sun, 07 Mar 2010 15:05:44 -0400

Changed in checkbox (Ubuntu Lucid):
status: Triaged → Fix Released
Marc Tardif (cr3) on 2010-04-02
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers