Several scripts fail due to lack of execute permissions

Bug #459606 reported by David Henningsson on 2009-10-24
128
This bug affects 31 people
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Critical
Marc Tardif

Bug Description

Binary package hint: checkbox

A lot of the files in the scripts directory lack execute permissions. As a result several tests fail, e g alsa_record_playback and run_compiz_check.

For example, when testing audio, pressing the "test" button will just cause a window to open and immediately close again, and button name change to "test again".

Changed in checkbox (Ubuntu):
importance: Undecided → High
description: updated
gyromaxx (gyromaxx) wrote :

I confirm the same problem here with this pre-installed Gnome application System > Administration > System Testing on Ubuntu 9.10RC, e.g. with tests on audio, video modes, kernel modesetting, disk...
For instance:
<code>
Disk benchmark:

/bin/sh: /usr/share/checkbox/scripts/disk_bench_test: Permission denied

Is this ok?
</code>

I guess all the shell/python scripts for package "checkbox" (Checkbox System Testing) should have at least their execute permission set (or be called via their corresponding interpreter?):
<code>
-rw-r--r-- 1 root root 239 2009-10-14 17:23 /usr/share/checkbox/scripts/alsa_record_playback
-rw-r--r-- 1 root root 1061 2009-10-14 17:23 /usr/share/checkbox/scripts/audio_detect_silence
-rw-r--r-- 1 root root 28457 2009-10-14 17:23 /usr/share/checkbox/scripts/compiz-check
-rw-r--r-- 1 root root 323 2009-10-14 17:23 /usr/share/checkbox/scripts/cycle_vts
-rw-r--r-- 1 root root 431 2009-10-14 17:23 /usr/share/checkbox/scripts/disk_bench_test
-rw-r--r-- 1 root root 2943 2009-10-14 17:23 /usr/share/checkbox/scripts/filter_templates
-rwxr-xr-x 1 root root 761 2009-10-14 17:23 /usr/share/checkbox/scripts/gst_pipeline_test
-rwxr-xr-x 1 root root 3928 2009-10-14 17:23 /usr/share/checkbox/scripts/internet_test
-rwxr-xr-x 1 root root 1829 2009-10-14 17:23 /usr/share/checkbox/scripts/keyboard_test
-rw-r--r-- 1 root root 1173 2009-10-14 17:23 /usr/share/checkbox/scripts/network_check
-rwxr-xr-x 1 root root 451 2009-10-14 17:23 /usr/share/checkbox/scripts/network_test
-rwxr-xr-x 1 root root 1291 2009-10-14 17:23 /usr/share/checkbox/scripts/resolution_test
-rw-r--r-- 1 root root 655 2009-10-14 17:23 /usr/share/checkbox/scripts/run_compiz_check
-rwxr-xr-x 1 root root 14497 2009-10-14 17:23 /usr/share/checkbox/scripts/suspend_test
-rw-r--r-- 1 root root 3190 2009-10-14 17:23 /usr/share/checkbox/scripts/xrandr_cycle
</code>

All tests looked to be running OK after just setting the execute bit on these files, e.g. via:
<code>
sudo chmod a+x /usr/share/checkbox/scripts/*
</code>

So I guess this would be just a simple file execute permission fix in this package "checkbox"?

David Henningsson (diwic) wrote :

@gyromaxx: exactly, and I even made a branch + merge proposal with that particular fix to make it as simple as possible for an ubuntu-core-dev to pick it up.

An interesting thing to notice is that the error is not upstream but only in the karmic branch. This could be the reason why this bug could have escaped detection for so long.

Marc Tardif (cr3) on 2009-10-25
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
importance: High → Critical
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.8.5

---------------
checkbox (0.8.5) karmic; urgency=low

  * Fixed translation of suites and tests files (LP: #456115)
  * Fixed checking the status of command registries (LP: #457502)
  * Fixed selecting suites in the command line (LP: #457559)
  * Fixed reporting of bugs to contain test description (LP: #427932)
  * Fixed execute permissions on scripts (LP: #459606)
  * Renamed processors_info plugin to singular because processor
    information is reported as a single structure with a count attribute
  * Updated translation files.

 -- Marc Tardif <email address hidden> Mon, 26 Oct 2009 12:17:30 -0400

Changed in checkbox (Ubuntu):
status: Confirmed → Fix Released
Kenyon Karl (kenyon-karl) wrote :

Test_disk_bench (I reported as Bug 447614) hung one time in Ubuntu 9.10 Final when running in Live mode on my Asus A2H (A2500H) laptop. Could it have been related to having to fetch code from the CD ROM? Or is it somehow related to the previous test? After rebooting, and returning to this test after skipping the Audio Tests, Systems test did what appear to be a nice test of my hard drive!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers