Missing manual page for checkbox-gtk

Bug #426641 reported by Alex Lourie on 2009-09-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Low
Marc Tardif

Bug Description

In Karmic Alpha 5, manual is missing for checkbox-gtk:

alex@alex-karmic-alpha:~/Projects/ubuntu-docs/manpages$ man checkbox-gtk
No manual entry for checkbox-gtk
See 'man 7 undocumented' for help when manual pages are not available.

Related branches

Alex Lourie (alourie) wrote :

I've written the man page.

Phil Bull (philbull) on 2009-09-09
affects: ubuntu-docs (Ubuntu) → checkbox (Ubuntu)
Twig (pfirth) wrote :

Hi, the man page is available for me with Karmic + the latest updates. Could you update and check if this is still an issue?

Thanks,
Twig.

Changed in checkbox (Ubuntu):
status: New → Incomplete

Indeed.

Verified that in latest delivery the man page exist.

It can be checked with 'man checkbox'

On Wed, Sep 9, 2009 at 5:02 PM, Twig <email address hidden> wrote:

> Hi, the man page is available for me with Karmic + the latest updates.
> Could you update and check if this is still an issue?
>
> Thanks,
> Twig.
>
> ** Changed in: checkbox (Ubuntu)
> Status: New => Incomplete
>
> --
> Missing manual page for checkbox-gtk
> https://bugs.launchpad.net/bugs/426641
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “checkbox” package in Ubuntu: Incomplete
>
> Bug description:
> In Karmic Alpha 5, manual is missing for checkbox-gtk:
>
> alex@alex-karmic-alpha:~/Projects/ubuntu-docs/manpages$ man checkbox-gtk
> No manual entry for checkbox-gtk
> See 'man 7 undocumented' for help when manual pages are not available.
>

Changed in checkbox (Ubuntu):
status: Incomplete → Confirmed
Twig (pfirth) wrote :

Marking as fixed as per your report.

Thanks,
Twig.

Changed in checkbox (Ubuntu):
status: Confirmed → Fix Released
Phil Bull (philbull) wrote :

A manpage is not displayed when the "man checkbox-gtk" command is issued. This should be fixed, at least.

Changed in checkbox (Ubuntu):
status: Fix Released → New
Brian Murray (brian-murray) wrote :

It'd be helpful to know a package version that anybody is recreating this bug report with. When using checkbox version 0.8.1 on Karmic I am unable to recreate this bug report and 'man checkbox-gtk' displays the manual for checkbox.

Changed in checkbox (Ubuntu):
status: New → Incomplete
Twig (pfirth) wrote :

Hi. I closed this as it worked correctly for me and the submitter after updating. Unless I've misunderstood something, this is resolved. Alex, please could you confirm the manpage now appears on your system?

Phil Bull (philbull) wrote :

I'm running karmic with latest updates applied.

phil@jaguar:~$ apt-cache show checkbox-gtk | grep Version
Version: 0.8.1-0ubuntu1
Python-Version: current

phil@jaguar:~$ man checkbox-gtk
No manual entry for checkbox-gtk
See 'man 7 undocumented' for help when manual pages are not available.

Alex Lourie (alourie) wrote :

Sorry, I previously misunderstood the situation.

Here's what I got:

1.
alex@alex-karmic-testing:~$ checkbox-gtk --version
0.7.2

2.
alex@alex-karmic-testing:~$ sudo apt-get install checkbox
Reading package lists... Done
Building dependency tree
Reading state information... Done
checkbox is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 525 not upgraded.

So, does it mean I have the latest version? No:

3.
alex@alex-karmic-testing:~$ sudo apt-get install checkbox-gtk
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  checkbox-gtk
......
Setting up checkbox-gtk (0.8.1-0ubuntu1) ...

4. And now:
alex@alex-karmic-testing:~$ man checkbox-gtk
No manual entry for checkbox-gtk
See 'man 7 undocumented' for help when manual pages are not available.
alex@alex-karmic-testing:~$ apt-cache show checkbox | grep Version
Version: 0.8.1-0ubuntu1
Python-Version: current

So I guess there are the following issues:

1. man checkbox-gtk still doesn't work in latest version.
2. you can install "checkbox", "checkbox-cli" and "checkbox-gtk" separately, which is confusing in this specific case
3. and if we're already there, "man checkbox-cli" doesn't work either:

alex@alex-karmic-testing:~$ man checkbox-cli
No manual entry for checkbox-cli
See 'man 7 undocumented' for help when manual pages are not available.

alex@alex-karmic-testing:~$ checkbox-cli --version
0.7.2

I still can update checkbox-cli separately, but I will leave it like this for a moment, until the issue resolved.

Twig (pfirth) wrote :

Sorry for the confusion. I should have double-checked before marking the bug as fixed. I'm running the same version:

0.8.1-0ubuntu1

and the man page displays correctly. This applies for man checkbox-gtk, man checkbox-cli and man checkbox.

If I then do:

apt-get purge checkbox checkbox-gtk

followed by:

apt-get install checkbox checkbox-gtk

I do get the exact issue.

Alex Lourie (alourie) wrote :

So I guess this can be marked as Confirmed.

Phil Bull (philbull) on 2009-09-10
Changed in checkbox (Ubuntu):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

The command 'apt-cache show checkbox-gtk | grep Version' isn't a good way to check what version of a package you have installed as this only shows the version available on the archive. A better way to check what version of a package you have installed is either 'apt-cache policy checkbox-gtk' or 'dpkg-query -l checkbox-gtk'.

Regardless, the manual for checkbox, checkbox-cli and checkbox-gtk are provided by the file '/usr/share/man/man1/checkbox1.gz' which is included in the package checkbox. I'm not quite sure why man checkbox would work and the others would fail.

Phil Bull (philbull) wrote :

I was under the impression that you needed a separate manpage for each command, and you just redirect to the main checkbox manpage using a macro, e.g. checkbox-gtk.1.gz contains a file of one line, ".so man1/checkbox.1".

$ apt-cache policy checkbox-gtk
checkbox-gtk:
  Installed: 0.8.1-0ubuntu1
  Candidate: 0.8.1-0ubuntu1
  Version table:
 *** 0.8.1-0ubuntu1 0
        500 http://gb.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Brian Murray (brian-murray) wrote :

Actually, in the checkbox man file we can see the following:

.SH NAME

checkbox, checkbox\-cli, checkbox\-gtk \- Application for system testing

As I understand it there is man database that contains a mapping of applications to man files so that database should open up the file '/usr/share/man/man1/checkbox.1.gz'. It'd be interesting to update the mandb using 'mandb -c' and see if 'man checkbox-gtk' works after that.

Alex Lourie (alourie) wrote :

-----BEGIN PGP MESSAGE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Use GnuPG with Firefox : http://getfiregpg.org (Version: 0.7.8)

owGNkT1LA0EQhi+JilmQmE6spoikyYdNchAsgoUQCxsbq8De7ZgsuduNe3v5KGwl
haKWghixi/4EEVSIjVhYWFjpf0gv3gUiXOcWU8z7zM47M2dLCSOeTiYOapeHxfvY
6+OzZWzfvn1uKk5FjpBatoPQRrUvlYsMXCqYBXkb7CbarRxYvgaugXEmshqa6LQr
hFAHe9Uw5FtUudzOa/Q0F41KsSldLIZKBjyfyb/vSCF4xDTDRKBYjCu0tVQcPbCl
0JSLoLnALqoQ8akDbdpAr0BKZrkcSUHAIFDGkBXIOnha0T7YVEeFf1kMzUzntGQv
39AtsiNnrVBo1YdgKVFgFxGyYZkJvmDS9t0ARJadkuF2oNtEEfVLA1dCaqAdyh1q
OVgYbM0Z6bixMB8PL2GQ5PLsPqtD4/r86yNzMvBKp8On1PvkYryW6h0ZVxujldHx
3viuvpiJPbz8VL9vJvVf
=k94c
-----END PGP MESSAGE-----

On Sat, Sep 12, 2009 at 12:35 AM, Brian Murray <email address hidden> wrote:

> Actually, in the checkbox man file we can see the following:
>
> .SH NAME
>
> checkbox, checkbox\-cli, checkbox\-gtk \- Application for system testing
>
> As I understand it there is man database that contains a mapping of
> applications to man files so that database should open up the file
> '/usr/share/man/man1/checkbox.1.gz'. It'd be interesting to update the
> mandb using 'mandb -c' and see if 'man checkbox-gtk' works after that.
>
> --
> Missing manual page for checkbox-gtk
> https://bugs.launchpad.net/bugs/426641
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “checkbox” package in Ubuntu: Confirmed
>
> Bug description:
> In Karmic Alpha 5, manual is missing for checkbox-gtk:
>
> alex@alex-karmic-alpha:~/Projects/ubuntu-docs/manpages$ man checkbox-gtk
> No manual entry for checkbox-gtk
> See 'man 7 undocumented' for help when manual pages are not available.
>

Phil Bull (philbull) wrote :

Aha! Yes, it works now:

$ sudo mandb -c
Processing manual pages under /usr/share/man...
(Lines of output)

$ man checkbox-gtk
(Manpage appears)

So, why isn't the mandb being updated properly when the package is installed?

Alex Lourie (alourie) wrote :

Sorry, for some reason my email interface didn't work.

Unfortunately, for me the mandb -c didn't work:

alex@alex-karmic-testing:/home/alex$ sudo mandb -c
....
77 man subdirectories contained newer manual pages.
5766 manual pages were added.
0 stray cats were added.
alex@alex-karmic-testing:/home/alex$ man checkbox-gtk
No manual entry for checkbox-gtk
See 'man 7 undocumented' for help when manual pages are not available.

Marc Tardif (cr3) wrote :

The problem is that Checkbox did not provide a symlink for the checkbox-gtk and checkbox-cli manpages. I have added the necessary files to the packaging of checkbox so that the proper symlinks are provided.

Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
importance: Undecided → Low
milestone: none → karmic-alpha-6
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.8.4

---------------
checkbox (0.8.4) karmic; urgency=low

  * Fixed failing dependencies when not available (LP: #430051)
  * Fixed supporting udevadm not providing DEVPATH variable (LP: #430084)
  * Fixed supporting audio devices without a /proc/asound entry (LP: #430086)
  * Fixed running when python-apport package is not installed (LP: #430103)
  * Fixed X error when exiting after reporting a bug (LP: #430776)
  * Fixed prompting to report a bug according to GNOME HIG (LP: #429701)
  * Fixed prompting for answer in checkbox-cli (LP: #429764)
  * Fixed resolution_test message for fglrx driver (LP: #346816)
  * Fixed adding of manpage symlinks for gtk and cli (LP: #426641)
  * Fixed recovering from connecting to the backend (LP: #446693)
  * Fixed backend to use dbus instead of policykit (LP: #435714)
  * Fixed interpolation of output variable in cli (LP: #450673)
  * Fixed selection of suites in cli (LP: #450713)
  * Fixed parsing of virtio-pci devices (LP: #450774)

 -- Marc Tardif <email address hidden> Wed, 14 Oct 2009 11:22:06 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers