checkbox-backend 0.7 doesn't run

Bug #352740 reported by Steve Guio on 2009-03-31
10
Affects Status Importance Assigned to Milestone
Checkbox
Medium
Marc Tardif
checkbox (Ubuntu)
Medium
Marc Tardif
Lucid
Undecided
Unassigned

Bug Description

The impact of this bug is that when the checkbox-backend process doesn't run, this prevents some tests from running. This fix simply extends the debian/control file to suggest installing checkbox-cli or checkbox-gtk when upgrading from the old hwtest package.

Binary package hint: checkbox

$ checkbox-backend
Traceback (most recent call last):
  File "/usr/share/checkbox/run", line 40, in <module>
    main()
  File "/usr/share/checkbox/run", line 35, in main
    application = manager.create_application(sys.argv)
  File "/usr/lib/python2.6/dist-packages/checkbox/application.py", line 117, in create_application
    log_handlers.append(FileHandler(log_filename))
  File "/usr/lib/python2.6/logging/__init__.py", line 801, in __init__
    StreamHandler.__init__(self, self._open())
  File "/usr/lib/python2.6/logging/__init__.py", line 820, in _open
    stream = open(self.baseFilename, self.mode)
IOError: [Errno 13] Permission denied: '/var/log/checkbox.log'

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: checkbox 0.7
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: checkbox
Uname: Linux 2.6.28-11-generic i686

Related branches

I've only installed checkbox.

$ sudo apt-get install checkbox

I don't have checkbox-cli or checkbox-gtk installed. Why checkbox package didn't Recommends or Suggests them?

Because not everyone wants GTK interface, I think checkbox-backend should at least recommends checkbox-cli.

David Murphy (schwuk) wrote :

checkbox-backend is not intended to be run by users directly, and requires being run as root. Your comments about Recommends are valid, and we should also improve the package descriptions and error messages.

Changed in checkbox (Ubuntu):
assignee: nobody → schwuk
importance: Undecided → Medium
milestone: none → later
status: New → Confirmed
Changed in checkbox:
assignee: nobody → schwuk
importance: Undecided → Medium
milestone: none → 0.8
status: New → Confirmed
David Murphy (schwuk) on 2009-07-14
Changed in checkbox:
milestone: 0.8-alpha2 → 0.8-alpha3
Marc Tardif (cr3) wrote :

Steve, the checkbox-backend script has been replaced with a backend script under /usr/share, so it should no longer appear in your PATH environment variable. This fixes part of the problem you reported.

You also proposed adding checkbox-gtk or checkbox-cli to the base checkbox package suggests line. This would be similar to the apport project which also has a base package and separate interface packages. I have committed that change which should appear in version 0.9.2 of Checkbox. Thanks!

Changed in checkbox (Ubuntu):
assignee: David Murphy (schwuk) → Marc Tardif (cr3)
Changed in checkbox:
assignee: David Murphy (schwuk) → Marc Tardif (cr3)
status: Confirmed → Fix Committed
Changed in checkbox (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.10

---------------
checkbox (0.10) maverick; urgency=low

  New upstream release (LP: #585132):
  * Added media tests (LP: #397944)
  * Added support for comments in templates.
  * Added referer when sending submissions to Launchpad (LP: #550973)
  * Added suggests to checkbox package in debian/control file (LP: #352740)
  * Fixed udev_resource script to be more resilient (LP: #556824)
  * Fixed cdimage_resource script to read casper.log (LP: #558728)
  * Fixed reporting all resources found for a job (LP: #560948)
  * Fixed stalling when using kdesudo to start backend (LP: #557443)
  * Fixed starting the appropriate default browser on UNR (LP: #563050)
  * Fixed ansi_parser script when outputting to stdout (LP: #560952)
  * Fixed opening the report with the gconf preferred browser (LP: #562580)
  * Fixed suspend_test to use relative time for wakealarm (LP: #349768)
  * Fixed backend not getting terminated upon closing (LP: #553328)
 -- Marc Tardif <email address hidden> Tue, 06 Apr 2010 14:17:46 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
Marc Tardif (cr3) on 2010-06-10
Changed in checkbox:
status: Fix Committed → Fix Released
Changed in checkbox (Ubuntu Lucid):
milestone: none → lucid-updates
status: New → In Progress
Marc Tardif (cr3) on 2010-06-10
description: updated
Daniel Manrique (roadmr) wrote :

Hello, the following information should complete this bug as a valid SRU report, to hopefully upload this fix to Lucid.

Solution:

Checkbox revision 794 adds a Suggests: for checkbox-cli or checkbox-gtk to ensure they are present when checkbox is installed.

Also, ubuntu-desktop (source from ubuntu-meta revision 171) (dated 2009-01-31) adds a dependency on checkbox-gtk to ensure it's always installed. Still it's possible to remove ubuntu-desktop and checkbox-gtk to reproduce the problem.

TEST CASE:

I was unable to replicate the behavior described in the original report when installing Ubuntu 8.04 (with hwtest) and trying to upgrade that to 10.04. The test case is thus slightly artificial and a bit convoluted but illustrates the problem, which apparently happened while upgrading from 8.04 to a non-LTS release (either 8.10 or 9.04):

1- Do a fresh install of Ubuntu 10.04
2- apt-get remove checkbox-gtk (this removes also checkbox and ubuntu-desktop).
3- apt-get install checkbox

In this case checkbox gets installed, but there is no interface, so there isn't even a way to invoke it (the report talks about checkbox-backend but that has been phased out, however the dependency problem still remained).

Of note, in 10.04 ubuntu-desktop depends on checkbox-gtk, so a situation where checkbox-gtk is not present means the user forced (or agreed to) removal of ubuntu-desktop.

Regression potential:

for Lucid there's practically none, as the only possible side effect from this change is that, upon installing checkbox, either checkbox-cli or checkbox-gtk will be suggested. Since the checkbox package is basically unusable without either interface, a case where a user is affected by this suggestion is very unlikely.

Ara Pulido (ara) wrote :

This bug is awaiting verification that the checkbox version in lucid-proposed solves the problem. Please test checkbox and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

ubuntu-sru approved and reviewed. Please accept into lucid-proposed.

Hello Steve, or anyone else affected,

Accepted checkbox into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in checkbox (Ubuntu Lucid):
status: In Progress → Fix Committed
Chad A. Davis (chadadavis) wrote :

Either I do not follow the test care, or the verification fails.
I removed checkbox and checkbox-gtk and checkbox-cli
Enabling proposed and installing checkbox 0.9.2 only installs checkbox, because it only 'suggests' checkbox-cli and checkbox-gtk.
Should checkbox rather 'recommends' checkbox-cli and checkbox-gtk if they are to be installed by default?

Daniel Manrique (roadmr) wrote :

Hi Chad,

Thanks so much for helping verify this report. This is a tricky one because I was unable to replicate the exact, bad reported behavior.

Are you trying to install checkbox using apt-get? this doesn't install either recommends or suggests automatically. My suggestion to test a normal end-user behavior would be to use the package manager to install checkbox and verify that checkbox-gtk got installed as well.

The faulty behavior (i.e. without the -proposed repository enabled) would be that checkbox-gtk doesn't get installed, even if using the package manager.

 Thanks again!

Chad A. Davis (chadadavis) wrote :

I also started from Ubuntu 10.04.2 (checkbox 0.9.1), so I don't have checkbox-backend.

I verified that without -proposed, installing checkbox 0.9.1 does not install checkbox-gtk (nor -cli)

With -proposed, installing checkbox 0.9.2 also does not install checkbox-gtk nor checkbox-cli (neither with apt-get, nor with software-center).

However, apt-get does install 'Recommends' by default. I tested on aislerot, which is recommended by ubuntu-desktop:

sudo apt-get remove ubuntu-desktop aisleriot
sudo apt-get install ubuntu-desktop
apt-cache show ubuntu-desktop | grep -o 'Recommends: .* aisleriot,'

Perhaps the behavior of software center has changed in new releases, but this was a fresh install of 10.04.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.2

---------------
checkbox (0.9.2) lucid-proposed; urgency=low

  New upstream release (LP: #567568):
  * Added referer when sending submissions to Launchpad (LP: #550973)
  * Added suggests to checkbox package in debian/control file (LP: #352740)
  * Fixed udev_resource script to be more resilient (LP: #556824)
  * Fixed cdimage_resource script to read casper.log (LP: #558728)
  * Fixed reporting all resources found for a job (LP: #560948)
  * Fixed stalling when using kdesudo to start backend (LP: #557443)
  * Fixed starting the appropriate default browser on UNR (LP: #563050)
  * Fixed opening the report with the gconf preferred browser (LP: #562580)
  * Fixed suspend_test to use relative time for wakealarm (LP: #349768)
  * Fixed backend not getting terminated upon closing (LP: #553328)
 -- Daniel Manrique <email address hidden> Wed, 22 Jun 2011 14:18:08 -0400

Changed in checkbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers