Ubuntu

Wakeup timer doesn't work on HP Compaq

Reported by petski on 2009-03-27
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Checkbox (Legacy)
Low
Marc Tardif
checkbox (Ubuntu)
Low
Marc Tardif
Lucid
Undecided
Unassigned

Bug Description

The impact of this bug is that the suspend_test script might return false positives on some systems because of the way wakealarm might be supported. This fix provides a clean way to support wakealarm in all situations, assuming wakealarm is supported at all.

As requested on ubuntu-devel-announce [1] I've performed the "suspend_test --full" test. Unfortunately, the first test fails. In this test, the laptop is suspended and a wakeup-timer is set up. The wakeup-timer doesn't do what it's supposed to do and my laptop will only come back alive when I press the power button.

* My laptop is a HP Compaq 6710b
* In #307090 it's suggested to boot with "hpet=disable", which makes no difference in my case.
* It looks like http://bugzilla.kernel.org/show_bug.cgi?id=12013#c33 is related.
* See https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting/Feedback "| grep 6710b" as well.

pet@workmate:~$ uname -a
Linux workmate 2.6.28-9-generic #31-Ubuntu SMP Wed Mar 11 15:43:49 UTC 2009 x86_64 GNU/Linux

pet@workmate:~$ sudo sh -c 'echo 0 > /sys/class/rtc/rtc0/wakealarm'
pet@workmate:~$ sudo sh -c 'echo `date "+%s" -d "+ 5 minutes"` > /sys/class/rtc/rtc0/wakealarm'
pet@workmate:~$ cat /proc/driver/rtc
rtc_time : 18:12:16
rtc_date : 2009-03-27
alrm_time : 18:17:06
alrm_date : ****-**-27
alarm_IRQ : no
alrm_pending : no
24hr : yes
periodic_IRQ : no
update_IRQ : no
HPET_emulated : no
DST_enable : no
periodic_freq : 1024
batt_status : okay

[1] https://lists.ubuntu.com/archives/ubuntu-devel-announce/2009-March/000556.html

Same here with a HP Compaq 6530b

Everything worked, except the wakeup

foxynet (foxynet) wrote :

Same here with a HP Compaq 2510p

Everything worked, except the wakeup.

hpet=disable made no difference

petski (petski) on 2009-03-29
description: updated
Matej Kenda (matejken) wrote :

I'm attaching the results of the suspend_test script, ran on HP Compaq 6710b. The results are very bad.

$ uname -a
Linux pc-matejk 2.6.28-11-generic #39-Ubuntu SMP Thu Apr 2 04:39:54 UTC 2009 x86_64 GNU/Linux

$ cat /var/lib/acpi-support/*-*
68DDU Ver. F.15
Hewlett-Packard
HP Compaq 6710b (GB893EA#AKN)
F.15

Not only that the laptop didn't wake up several times, it also didn't suspend a couple of times.

Matej Kenda (matejken) wrote :

The reported system load while running the script was also very high (between 15 an 35).

squigglepops (brendanright) wrote :

Worked fine for me, except that my initial suspend returned with a terminal error message. When I became impatient and tried ctrl-alt-F7 it came back to life (not sure if that was a coincidence or not), and it worked fine from then on.

My laptop is an HP Compaq 6710b:

Linux hp-6710b-public 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

petski (petski) wrote :

At upstream, it's suggested [1] to set the wakeup timer in a relative way. I've made a small patch for the suspend_test script (find it attached), so the wakeup timer is set that way. I reran the suspend_test script and got positive results for at least test one and two.

Help wanted: This bugid still doesn't have a source package. What should this be? acpi*, linux* or even checkbox?

[1] http://bugzilla.kernel.org/show_bug.cgi?id=12013#c36

affects: ubuntu → checkbox (Ubuntu)
David Murphy (schwuk) on 2009-06-18
Changed in checkbox:
importance: Undecided → Low
status: New → Confirmed
Marc Tardif (cr3) on 2010-04-17
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
Changed in checkbox:
assignee: nobody → Marc Tardif (cr3)
status: Confirmed → In Progress
Changed in checkbox (Ubuntu):
status: Confirmed → In Progress
Marc Tardif (cr3) on 2010-04-17
Changed in checkbox (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.10

---------------
checkbox (0.10) maverick; urgency=low

  New upstream release (LP: #585132):
  * Added media tests (LP: #397944)
  * Added support for comments in templates.
  * Added referer when sending submissions to Launchpad (LP: #550973)
  * Added suggests to checkbox package in debian/control file (LP: #352740)
  * Fixed udev_resource script to be more resilient (LP: #556824)
  * Fixed cdimage_resource script to read casper.log (LP: #558728)
  * Fixed reporting all resources found for a job (LP: #560948)
  * Fixed stalling when using kdesudo to start backend (LP: #557443)
  * Fixed starting the appropriate default browser on UNR (LP: #563050)
  * Fixed ansi_parser script when outputting to stdout (LP: #560952)
  * Fixed opening the report with the gconf preferred browser (LP: #562580)
  * Fixed suspend_test to use relative time for wakealarm (LP: #349768)
  * Fixed backend not getting terminated upon closing (LP: #553328)
 -- Marc Tardif <email address hidden> Tue, 06 Apr 2010 14:17:46 -0400

Changed in checkbox (Ubuntu):
status: In Progress → Fix Released
Marc Tardif (cr3) on 2010-06-10
Changed in checkbox:
status: In Progress → Fix Released
Marc Tardif (cr3) on 2010-06-10
Changed in checkbox (Ubuntu Lucid):
status: New → In Progress
milestone: none → lucid-updates
Marc Tardif (cr3) on 2010-06-10
description: updated
Daniel Manrique (roadmr) wrote :

Hello, the following information should complete this bug as a valid SRU report, to hopefully upload this fix to Lucid.

Solution:

Checkbox revision 795 uses relative time for the rtcwakealarm, which seems to be more stable than absolute time, as documented in this bug's discussion and all the referred material. So instead of an absolute seconds after epoch value for the wakeup, this now specifies an increment from the current time with the "+seconds" syntax.

TEST CASE:

This is hardware-dependent so results may vary.

1- on a Lucid installation on an HP Compaq system, run:
   sudo /usr/share/checkbox/scripts/suspend_test --full

On an affected system, the old version of the script will fail to wake the system up automatically. The new version should wake the system up correctly.

Regression potential:
Both formats for the rtc wakealarm are essentially equivalent and both are supported with the Lucid kernel. Short of a system using local instead of UTC time for the RTC (where the old code wouldn't work as expected), or a kernel downgrade that removes support for rtc wakealarm (in which case even the old code would fail) this change should be completely harmless.

Ara Pulido (apulido) wrote :

This bug is awaiting verification that the checkbox version in lucid-proposed solves the problem. Please test checkbox and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

ubuntu-sru approved and reviewed. Please accept into lucid-proposed.

Hello petski, or anyone else affected,

Accepted checkbox into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in checkbox (Ubuntu Lucid):
status: In Progress → Fix Committed
petski (petski) wrote :

I'm currently running karmic (I know, I know). Hopefully someone else is able to test this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.9.2

---------------
checkbox (0.9.2) lucid-proposed; urgency=low

  New upstream release (LP: #567568):
  * Added referer when sending submissions to Launchpad (LP: #550973)
  * Added suggests to checkbox package in debian/control file (LP: #352740)
  * Fixed udev_resource script to be more resilient (LP: #556824)
  * Fixed cdimage_resource script to read casper.log (LP: #558728)
  * Fixed reporting all resources found for a job (LP: #560948)
  * Fixed stalling when using kdesudo to start backend (LP: #557443)
  * Fixed starting the appropriate default browser on UNR (LP: #563050)
  * Fixed opening the report with the gconf preferred browser (LP: #562580)
  * Fixed suspend_test to use relative time for wakealarm (LP: #349768)
  * Fixed backend not getting terminated upon closing (LP: #553328)
 -- Daniel Manrique <email address hidden> Wed, 22 Jun 2011 14:18:08 -0400

Changed in checkbox (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.