missing .so in check

Bug #125781 reported by Stefan Sauer on 2007-07-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
check
Fix Released
Unknown
check (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: check

The package check-0.9.4-3 misses the .so file it only distributes static libraries:
/usr/lib/libcheck_pic.a
/usr/lib/libcheck.a

The /usr/lib/libcheck_pic.a is hacky workaround for that.
It breaks selfbuilt software that uses pkg-config to link against check, as it wont see it (pkg-config --libs check answers -lcheck).

The bug as initially reported there, but the fix is incomplete.
https://bugs.launchpad.net/ubuntu/+source/check/+bug/5840

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in check (Ubuntu):
status: New → Incomplete
Stefan Sauer (ensonic) wrote :

Teej, this is easy to verify and yes its still broken

# apt-cache show check | grep Version
Version: 0.9.5-4

# dpkg -L check | grep libcheck
/usr/lib/libcheck_pic.a
/usr/lib/libcheck.a

# pkg-config --libs check
-lcheck

I am also seeing the same as above. Marking as Confirmed and setting importance to Low - not a core application.

Changed in check (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: check 0.9.5-4
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Still seeing this behaviour in version 0.9.8-1ubuntu1. The problem is there has been no update on the projects Sourceforge page for over a year and a half, is it orphaned? I shall report this bug to Debian nonetheless and link it in.

Changed in check (Ubuntu):
status: Confirmed → Incomplete
Changed in check:
status: Unknown → New
Stefan Sauer (ensonic) wrote :

Teej, I am following the upstream project and it is indeed not doing a lot of releases. The mailing list is active though and things works quite fine for everyone. Also the packages are fine on other distros. Would be nice if the ubuntu pckage could be fixed.

Changed in check:
status: New → Fix Committed
Changed in check:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.