Upgrading Ceph from 14.2.11-0ubuntu0.19.10.1~cloud4 to 15.2.8-0ubuntu0.20.04.1~cloud0 fails when ceph-mds is installed

Bug #1919261 reported by Fabio Augusto Miranda Martins
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Invalid
Undecided
Unassigned
Ussuri
Fix Released
Medium
Unassigned
ceph (Ubuntu)
Invalid
Medium
Unassigned
Focal
Fix Released
Medium
James Page

Bug Description

[Impact]
Package upgrades will fail due to a move of a file between packages

[Test Case]
Install ceph-mds 14.2.11-0ubuntu0.19.10.1~cloud4 (from UCA) on bionic
do-release-upgrade to focal
package upgrade will fail.

[Where problems could occur]
Version declarations might not be correct; upgrade might still break with the same conflict.

[Original Bug Report]
In a host where ceph-mds is installed, upgrading from 14.2.11-0ubuntu0.19.10.1~cloud4 to 15.2.8-0ubuntu0.20.04.1~cloud0 fails with:

dpkg: error processing archive /tmp/apt-dpkg-install-Zen6uw/9-ceph-common_15.2.8-0ubuntu0.20.04.1~cloud0_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/cephfs-data-scan', which is also in package ceph-mds 14.2.11-0ubuntu0.19.10.1~cloud4
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /tmp/apt-dpkg-install-Zen6uw/9-ceph-common_15.2.8-0ubuntu0.20.04.1~cloud0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The problem happens because /usr/bin/cephfs-data-scan is provided by ceph-mds in 14.2.11-0ubuntu0.19.10.1~cloud4:

# dpkg -S /usr/bin/cephfs-data-scan
ceph-mds: /usr/bin/cephfs-data-scan

However in 15.2.8-0ubuntu0.20.04.1~cloud0 it is provided by ceph-common:

# dpkg -S /usr/bin/cephfs-data-scan
ceph-common: /usr/bin/cephfs-data-scan

A quick workaround is to temporarily remove ceph-mds before the upgrade (dpkg -r ceph-mds) and then perform the upgrade process using apt install. It will upgrade all packages and reinstall ceph-mds.

Dan Hill (hillpd)
tags: added: sts
Revision history for this message
James Page (james-page) wrote :

Breaks:
 ceph-mds (<< 14.2.5-3~),
Replaces:
 ceph-mds (<< 14.2.5-3~),

looks like the versioning check in the focal package is not correct.

Changed in ceph (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
status: Triaged → Invalid
Changed in ceph (Ubuntu Focal):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
James Page (james-page) wrote :

This is due to some historic issues in sync between Debian and Ubuntu versioning.

Revision history for this message
James Page (james-page) wrote :

I've pushed a fix to the next focal update which should resolve this issue.

Changed in ceph (Ubuntu Focal):
status: Triaged → In Progress
assignee: nobody → James Page (james-page)
James Page (james-page)
description: updated
Changed in cloud-archive:
status: New → Invalid
Revision history for this message
Brian Murray (brian-murray) wrote : Proposed package upload rejected

An upload of ceph to focal-proposed has been rejected from the upload queue for the following reason: "The patch d/p/bug1955345.patch doesn't actually appear in the debdiff or d/p/series file.".

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Fabio, or anyone else affected,

Accepted ceph into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ceph/15.2.16-0ubuntu0.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ceph (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Chris MacNaughton (chris.macnaughton) wrote :

Hello Fabio, or anyone else affected,

Accepted ceph into ussuri-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ussuri-needed to verification-ussuri-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ussuri-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ussuri-needed
Revision history for this message
Tyler Stachecki (tstachecki) wrote :

Hello,

I tried to verify this SRU, but halfway through the process... realized I was pulling from -updates (current) and not -proposed... and even so, I could not replicate the bug:

So I guess it's fixed?
Tyler

---

# Boot a clean cloud-init'd 18.04 image:
ubuntu@dev-10-34-138-116:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.6 LTS
Release: 18.04
Codename: bionic

# Configure apt to internal mirror of Train UCA on this LP's file date (2021-03-15)
...

# Install ceph-mds, verify the intended version was installed:
ubuntu@dev-10-34-138-116:~$ sudo DEBIAN_PRIORITY=critical DEBIAN_FRONTEND=noninteractive apt-get install -y ceph-mds
...
ubuntu@dev-10-34-138-116:~$ dpkg-query -W ceph-mds
ceph-mds 14.2.11-0ubuntu0.19.10.1~cloud4

# Remove train UCA and do-release-upgrade
...
ubuntu@dev-10-34-138-116:~$ sudo apt-get update
ubuntu@dev-10-34-138-116:~$ sudo apt -yu full-upgrade
ubuntu@dev-10-34-138-116:~$ sudo apt -y install ubuntu-release-upgrader-core
ubuntu@dev-10-34-138-116:~$ sudo do-release-upgrade -f DistUpgradeViewNonInteractive
...

# Ceph upgraded without failure:
ubuntu@dev-10-34-138-116:~$ dpkg-query -W ceph-mds
ceph-mds 15.2.14-0ubuntu0.20.04.2

Revision history for this message
Chris MacNaughton (chris.macnaughton) wrote :

I see the same thing as Tyler with the latest package in the Train UCA as well. In addition, I can confirm that an upgrade from the UCA Train version of ceph-mds to bionic-ussuri (proposed, verified with: 15.2.16-0ubuntu0.20.04.1~cloud0) or to focal (proposed, verified with: 15.2.16-0ubuntu0.20.04.1) works as expected, and the upgrade progresses correctly.

tags: added: verification-done verification-done-focal verification-ussuri-done
removed: verification-needed verification-needed-focal verification-ussuri-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceph - 15.2.16-0ubuntu0.20.04.1

---------------
ceph (15.2.16-0ubuntu0.20.04.1) focal; urgency=medium

  [ James Page ]
  * d/control: Correct Breaks/Replaces versioning between -common and -mds
    to resolve issues with upgrades (LP: #1919261).

  [ Chris MacNaughton ]
  * New upstream release (LP: #1964802).
  * Dropped patches in latest relese:
    - d/p/rgw_clear_buckets_before_calling_list_buckets.patch
    - d/p/bug1955345.patch
  * d/p/misc-32-bit-fixes.patch: Refreshed.
  * d/rules, d/ceph-osd.install: Update ceph-osd-smartctl to ceph-smartctl.

 -- James Page <email address hidden> Wed, 30 Mar 2022 13:42:23 +0100

Changed in ceph (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Update Released

The verification of the Stable Release Update for ceph has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Chris MacNaughton (chris.macnaughton) wrote :

The verification of the Stable Release Update for ceph has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Chris MacNaughton (chris.macnaughton) wrote :

This bug was fixed in the package ceph - 15.2.16-0ubuntu0.20.04.1~cloud0
---------------

 ceph (15.2.16-0ubuntu0.20.04.1~cloud0) bionic-ussuri; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 ceph (15.2.16-0ubuntu0.20.04.1) focal; urgency=medium
 .
   [ James Page ]
   * d/control: Correct Breaks/Replaces versioning between -common and -mds
     to resolve issues with upgrades (LP: #1919261).
 .
   [ Chris MacNaughton ]
   * New upstream release (LP: #1964802).
   * Dropped patches in latest relese:
     - d/p/rgw_clear_buckets_before_calling_list_buckets.patch
     - d/p/bug1955345.patch
   * d/p/misc-32-bit-fixes.patch: Refreshed.
   * d/rules, d/ceph-osd.install: Update ceph-osd-smartctl to ceph-smartctl.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers