Can't uninstall ceph-mon package

Bug #1754585 reported by getaceres on 2018-03-09
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ceph (Ubuntu)
Medium
James Page
Artful
Medium
James Page
Bionic
Medium
James Page

Bug Description

[Impact]
Unable to uninstall ceph* packages

[Test Case]
sudo apt install ceph-osd
sudo apt purge ceph-osd

[Regression Potential]
Minimal - we're dropping postrm maintainer scripts which only stop obsolete/removed init.d sysv scripts.

[Original Bug Report]
In Ubuntu Artful, when I'm trying to uninstall the ceph package, I get the following error:

sudo apt remove ceph-mon
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
  ceph ceph-mon
0 actualizados, 0 nuevos se instalarán, 2 para eliminar y 0 no actualizados.
Se liberarán 13,8 MB después de esta operación.
¿Desea continuar? [S/n]
(Leyendo la base de datos ... 290537 ficheros o directorios instalados actualmente.)
Desinstalando ceph (12.2.2-0ubuntu0.17.10.1) ...
Desinstalando ceph-mon (12.2.2-0ubuntu0.17.10.1) ...
Failed to stop ceph.service: Unit ceph.service not loaded.
invoke-rc.d: initscript ceph, action "stop" failed.
dpkg: error al procesar el paquete ceph-mon (--remove):
 el subproceso instalado el script pre-removal devolvió el código de salida de error 5
Se encontraron errores al procesar:
 ceph-mon
E: Sub-process /usr/bin/dpkg returned an error code (1)

It's similar to https://bugs.launchpad.net/ubuntu/+source/ceph/+bug/1546112 but instead of ceph, that I can uninstall, the problem now is ceph-mon.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ceph (Ubuntu):
status: New → Confirmed
Joel Van Boxtel (jeol13) wrote :

also affects Ubuntu 18.04 still

James Page (james-page) wrote :

The ceph*.prerm scripts have snippets for stopping ceph daemons managed via the init.d scripts, which are no longer shipped by the Ubuntu packages.

The radosgw package does continue to ship an init.d script, so this will need to be retained for this package only.

Changed in ceph (Ubuntu Bionic):
status: Confirmed → Triaged
Changed in ceph (Ubuntu Artful):
status: New → Triaged
importance: Undecided → Medium
Changed in ceph (Ubuntu Bionic):
importance: Undecided → Medium
milestone: none → ubuntu-18.03
Changed in ceph (Ubuntu Artful):
milestone: none → artful-updates
assignee: nobody → James Page (james-page)
Changed in ceph (Ubuntu Bionic):
assignee: nobody → James Page (james-page)
James Page (james-page) wrote :

Committed to ubuntu/bionic branch; will be included with my 12.2.4 upload.

Changed in ceph (Ubuntu Bionic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceph - 12.2.4-0ubuntu1

---------------
ceph (12.2.4-0ubuntu1) bionic; urgency=medium

  [ James Page ]
  * New upstream point release (LP: #1750826, #1731819, #1718134).
  * d/ceph-osd.install: Add ceph-volume tools (LP: #1750376).
  * d/*: wrap-and-sort -bast.
  * d/control,compat: Bump debhelper compat level to 10.
  * d/control: Switch to using python3-sphinx.
  * d/rules: Switch to using WITH_BOOST_CONTEXT for rgw beast frontend
    enablement.
  * d/rules,control: Switch to using vendored boost as 1.66 is required.
  * d/control: Add python-jinja2 to Depends of ceph-mgr (LP: #1752308).

  [ Tiago Stürmer Daitx ]
  * Update java source and target flags from 1.5 to 1.8. Allows it to run
    using OpenJDK 8 or earlier and to be build with OpenJDK 9, 10, and 11
    (LP: #1756854).

  [ James Page ]
  * d/ceph*.prerm: Drop, no longer needed as only use for removed upstart
    and init.d methods of managing ceph daemons (LP: #1754585).

 -- James Page <email address hidden> Tue, 20 Mar 2018 09:28:22 +0000

Changed in ceph (Ubuntu Bionic):
status: Fix Committed → Fix Released
Joel Van Boxtel (jeol13) wrote :

uninstallation of ceph worked.
however, upgrading was difficult it required:

sudo aptitude -enter the package selector
Mark all upgradeable
then mark ceph for reinstallation due to it being held back - dependency problem)

result: it forces the system to use only latest packages and install them overwriting existing files
then after reboot.

then:
sudo apt remove ceph*

Joel Van Boxtel (jeol13) wrote :

sorry about the typos.

James Page (james-page) on 2018-03-27
description: updated

Hello getaceres, or anyone else affected,

Accepted ceph into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ceph/12.2.4-0ubuntu0.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ceph (Ubuntu Artful):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-artful
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions