[SRU] Drop Build-Depends on python-sphinxcontrib.issuetracker

Bug #1177855 reported by Andres Rodriguez on 2013-05-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
celery (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]
Dropping this build-dependency allows us to MIR celery in precise for the upcoming MAAS SRU. This Build-Dep does not impact the functionality of celery, and in reality, it is not required for it to build and function. This build-dep is used for the doc generation, however, dropping it doesn't affect the doc generation either, nor provides any changes to the docs. The docs remain the same.

[Test Case]
1. Install python-celery-doc
2. Check all docs are present.

[Regression Potential]
Minimal. This only affects the docs generation, which do not get affected by dropping the dependency.

Changed in celery (Ubuntu):
status: New → Fix Released
Changed in celery (Ubuntu Precise):
importance: Undecided → Critical
importance: Critical → High
importance: High → Undecided
Dave Walker (davewalker) wrote :

Andres, I understood that this is a no-op change for the produced binaries.

The Dep allows issue tracking to remote bug trackers for more information, for the sphinx produced documentation. However, the builds being done in a network isolated chroot means that the produced binary debs are identical. Is this correct?

Please can you prove that the binaries are identical by doing a diff between the debs.

Thanks.

Andres Rodriguez (andreserl) wrote :

Daviey,

Just to clarify, issuetracker is being disabled by default and makes no sense to have it as a build-dep. See docs/conf.py:

if False: #not os.environ.get("SKIP_ISSUES"):
    # Issue tracker is not working, just hangs
    issuetracker = "github"
    issuetracker_project = "ask/celery"
    issuetracker_issue_pattern = r'[Ii]ssue #(\d+)'

If this were change to True, it would actually require to access the network in order to be able to build. However, since it is being disabled by default we do not require the build-dependency.

Cheers.

Andres Rodriguez (andreserl) wrote :
Andres Rodriguez (andreserl) wrote :

Note that the change does not affect the documentation at all and this file is only needed when issuetracker is enabled on the docs, but it is not:

if False: #not os.environ.get("SKIP_ISSUES"):
    # Issue tracker is not working, just hangs
    issuetracker = "github"
    issuetracker_project = "ask/celery"
    issuetracker_issue_pattern = r'[Ii]ssue #(\d+)'

Since this is not enabled, then the file being dropped by removing the build-dep is not required at all and won't affect nor change the docs at *all*

Hello Andres, or anyone else affected,

Accepted celery into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/celery/2.4.6-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in celery (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

I've tested this and works as expected.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

copied to precise-updates.

Changed in celery (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers