[SRU] newton stable releases

Bug #1664306 reported by Chuck Short on 2017-02-13
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Newton
Undecided
Unassigned
ceilometer (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
cinder (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
heat (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
horizon (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
keystone (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
neutron (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
nova (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
nova-lxd (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned
swift (Ubuntu)
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

Stable release updates for the following packages to support OpenStack Newton:

ceilometer 7.0.2
cinder 9.1.2
heat 7.0.2
keystone 10.0.1
neutron 9.2.0
nova 14.0.4
swift 2.10.1

Upstream QA process for stable releases is documented here:

https://docs.openstack.org/project-team-guide/stable-branches.html

Test plan:

For all stable point releases, we perform regression testing by juju deploying two openstack clouds, one against -proposed and one against -updates, and we then run tempest integration smoke tests[1] to verify those deployed clouds, and evaluate any differences in results.

[1] https://github.com/openstack/tempest/blob/master/README.rst

Dr. Jens Harbott (j-harbott) wrote :

Nova released 14.0.4

Chuck Short (zulcss) on 2017-03-01
description: updated
no longer affects: ironic (Ubuntu)
Brian Murray (brian-murray) wrote :

Please follow the rules for new upstream microreleases from https://wiki.ubuntu.com/StableReleaseUpdates#New_upstream_microreleases specifically:

"The upstream QA process must be documented/demonstrated and linked from the SRU tracking bug."

Thanks!

Changed in ceilometer (Ubuntu Yakkety):
status: New → Incomplete
Changed in cinder (Ubuntu Yakkety):
status: New → Incomplete
Chuck Short (zulcss) on 2017-03-08
description: updated
Chuck Short (zulcss) on 2017-03-08
description: updated

Hello Chuck, or anyone else affected,

Accepted nova-lxd into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova-lxd/14.2.0-0ubuntu0.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova-lxd (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Changed in nova (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Chuck, or anyone else affected,

Accepted nova into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:14.0.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Chuck, or anyone else affected,

Accepted heat into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/heat/1:7.0.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in heat (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Chuck, or anyone else affected,

Accepted cinder into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinder/2:9.1.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cinder (Ubuntu Yakkety):
status: Incomplete → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Chuck, or anyone else affected,

Accepted ceilometer into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ceilometer/1:7.0.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ceilometer (Ubuntu Yakkety):
status: Incomplete → Fix Committed
Changed in swift (Ubuntu Yakkety):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Chuck, or anyone else affected,

Accepted horizon into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:10.0.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Yakkety):
status: New → Fix Committed
James Page (james-page) on 2017-03-17
summary: - newton stable SRU releases
+ [SRU] newton stable releases
James Page (james-page) wrote :

For some reason keystone did not get marked as 'Fix Committed' but it is in the proposed pocket for yakkety.

Changed in keystone (Ubuntu):
status: New → Fix Committed
Changed in keystone (Ubuntu Yakkety):
status: New → Fix Committed
Changed in keystone (Ubuntu):
status: Fix Committed → Invalid
Brian Murray (brian-murray) wrote :

Hello Chuck, or anyone else affected,

Accepted neutron into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:9.2.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron (Ubuntu Yakkety):
status: New → Fix Committed
James Page (james-page) wrote :

Yakkety Newton verification tests:

11:13:13 ======
11:13:13 Totals
11:13:13 ======
11:13:13 Ran: 105 tests in 1017.0000 sec.
11:13:13 - Passed: 95
11:13:13 - Skipped: 6
11:13:13 - Expected Fail: 0
11:13:13 - Unexpected Success: 0
11:13:13 - Failed: 4
11:13:13 Sum of execute time for each test: 484.7182 sec.

4 test failures are related to boot from volume test failures due to bug 1672367, covered under separate SRU and pending acceptance into proposed.

tags: added: verification-done
removed: verification-needed
Changed in cloud-archive:
status: New → Invalid
Changed in ceilometer (Ubuntu):
status: New → Invalid
Changed in cinder (Ubuntu):
status: New → Invalid
Changed in heat (Ubuntu):
status: New → Invalid
Changed in horizon (Ubuntu):
status: New → Invalid
no longer affects: ironic (Ubuntu Yakkety)
Changed in neutron (Ubuntu):
status: New → Invalid
Changed in nova (Ubuntu):
status: New → Invalid
Changed in nova-lxd (Ubuntu):
status: New → Invalid
Changed in swift (Ubuntu):
status: New → Invalid
James Page (james-page) wrote :

Holding this bug until bug 1665698 is resolved; the tempest test cases don't specifically cover any drivers that use 'tap' device types so the bug won't show up as part of normal testing.

James Page (james-page) on 2017-03-20
tags: added: verification-needed
removed: verification-done
James Page (james-page) wrote :

Xenial Newton tests:

13:17:35 ======
13:17:35 Totals
13:17:35 ======
13:17:35 Ran: 103 tests in 1270.0000 sec.
13:17:35 - Passed: 97
13:17:35 - Skipped: 6
13:17:35 - Expected Fail: 0
13:17:35 - Unexpected Success: 0
13:17:35 - Failed: 0
13:17:35 Sum of execute time for each test: 690.1797 sec.

(but may need re-validating with any subsequent fixes).

Andy Whitcroft (apw) wrote :

Hello Chuck, or anyone else affected,

Accepted nova into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:14.0.4-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Andy Whitcroft (apw) wrote :

Hello Chuck, or anyone else affected,

Accepted nova into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:14.0.4-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

James Page (james-page) wrote :

Yakkety newton verification testing:

09:23:00 ======
09:23:00 Totals
09:23:00 ======
09:23:00 Ran: 103 tests in 1556.0000 sec.
09:23:00 - Passed: 96
09:23:00 - Skipped: 6
09:23:00 - Expected Fail: 0
09:23:00 - Unexpected Success: 0
09:23:00 - Failed: 1
09:23:00 Sum of execute time for each test: 937.5234 sec.

Looking into the single failure.

James Page (james-page) wrote :

Xenial newton verification testing:

10:00:49 ======
10:00:49 Totals
10:00:49 ======
10:00:49 Ran: 103 tests in 1427.0000 sec.
10:00:49 - Passed: 97
10:00:49 - Skipped: 6
10:00:49 - Expected Fail: 0
10:00:49 - Unexpected Success: 0
10:00:49 - Failed: 0
10:00:49 Sum of execute time for each test: 738.4477 sec.

James Page (james-page) wrote :

yakkety-newton test failure was the:

 tempest.scenario.test_volume_boot_pattern.TestVolumeBootPattern.test_volume_boot_pattern

tests; I've re-run this independently and it passes OK:

======
Totals
======
Ran: 1 tests in 178.5077 sec.
 - Passed: 1
 - Skipped: 0
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 144.9156 sec.

tags: added: verification-done
removed: verification-needed
Felipe Reyes (freyes) on 2017-03-28
tags: added: sts
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova-lxd - 14.2.0-0ubuntu0.16.10.1

---------------
nova-lxd (14.2.0-0ubuntu0.16.10.1) yakkety; urgency=medium

  * New upstream version for Openstack Newton. (LP: #1664306)

 -- Chuck Short <email address hidden> Fri, 03 Mar 2017 09:56:57 -0500

Changed in nova-lxd (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nova-lxd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 1:7.0.2-0ubuntu1

---------------
heat (1:7.0.2-0ubuntu1) yakkety; urgency=medium

  * New upstream stable release for OpenStack Newton (LP: #1664306).

 -- Chuck Short <email address hidden> Wed, 01 Mar 2017 14:05:03 -0500

Changed in heat (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 2:9.1.2-0ubuntu1

---------------
cinder (2:9.1.2-0ubuntu1) yakkety; urgency=medium

  [ Corey Bryant ]
  * d/control: Add keystoneauth1 dependency to (Build-)Depends (LP: #1641148).

  [ Chuck Short ]
  * New upstream stable release for OpenStack Newton (LP: #1664306).

 -- Chuck Short <email address hidden> Wed, 01 Mar 2017 14:02:56 -0500

Changed in cinder (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2:10.0.1-0ubuntu1

---------------
keystone (2:10.0.1-0ubuntu1) yakkety; urgency=medium

  * New upstream stable release for OpenStack Newton. (LP: #1664306)

 -- Chuck Short <email address hidden> Wed, 01 Mar 2017 14:07:05 -0500

Changed in keystone (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 1:7.0.2-0ubuntu1

---------------
ceilometer (1:7.0.2-0ubuntu1) yakkety; urgency=medium

  * New usptream stable release for OpenStack Newton. (LP: #1664306)

 -- Chuck Short <email address hidden> Wed, 01 Mar 2017 13:59:59 -0500

Changed in ceilometer (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:10.0.2-0ubuntu1

---------------
horizon (3:10.0.2-0ubuntu1) yakkety; urgency=medium

  * New upstream stable release for OpenStack Newton. (LP: #1664306)

 -- Chuck Short <email address hidden> Wed, 01 Mar 2017 14:23:02 -0500

Changed in horizon (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:9.2.0-0ubuntu1

---------------
neutron (2:9.2.0-0ubuntu1) yakkety; urgency=medium

  [ Chuck Short ]
  * d/p/tests-db.patch: Specify a db path for tests.
  * New upstream point release for Openstack Newton (LP: #1664306).
  * d/control: Bump python-pecan version. (LP: #1668578)

  [ Corey Bryant ]
  * d/tests/control: Use needs-recommends to ensure neutron-plugin-ml2 is
    installed.

 -- Corey Bryant <email address hidden> Mon, 06 Mar 2017 10:02:38 -0500

Changed in neutron (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package swift - 2.10.1-0ubuntu1

---------------
swift (2.10.1-0ubuntu1) yakkety; urgency=medium

  * d/p/avoid-infinite-loop-while-placing-parts.patch: Dropped
    no longer needed.
  * New upstream stable release for OpenStack Newton. (LP: #1664306)

 -- Chuck Short <email address hidden> Wed, 01 Mar 2017 14:19:25 -0500

Changed in swift (Ubuntu Yakkety):
status: Fix Committed → Fix Released
James Page (james-page) wrote :

The verification of the Stable Release Update for ceilometer has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package ceilometer - 1:7.0.2-0ubuntu1~cloud0
---------------

 ceilometer (1:7.0.2-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 ceilometer (1:7.0.2-0ubuntu1) yakkety; urgency=medium
 .
   * New usptream stable release for OpenStack Newton. (LP: #1664306)

James Page (james-page) wrote :

The verification of the Stable Release Update for cinder has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package cinder - 2:9.1.2-0ubuntu1~cloud0
---------------

 cinder (2:9.1.2-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 cinder (2:9.1.2-0ubuntu1) yakkety; urgency=medium
 .
   [ Corey Bryant ]
   * d/control: Add keystoneauth1 dependency to (Build-)Depends (LP: #1641148).
 .
   [ Chuck Short ]
   * New upstream stable release for OpenStack Newton (LP: #1664306).

James Page (james-page) wrote :

The verification of the Stable Release Update for heat has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package heat - 1:7.0.2-0ubuntu1~cloud0
---------------

 heat (1:7.0.2-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 heat (1:7.0.2-0ubuntu1) yakkety; urgency=medium
 .
   * New upstream stable release for OpenStack Newton (LP: #1664306).

James Page (james-page) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package horizon - 3:10.0.2-0ubuntu1~cloud0
---------------

 horizon (3:10.0.2-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 horizon (3:10.0.2-0ubuntu1) yakkety; urgency=medium
 .
   * New upstream stable release for OpenStack Newton. (LP: #1664306)

James Page (james-page) wrote :

The verification of the Stable Release Update for keystone has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package keystone - 2:10.0.1-0ubuntu1~cloud0
---------------

 keystone (2:10.0.1-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 keystone (2:10.0.1-0ubuntu1) yakkety; urgency=medium
 .
   * New upstream stable release for OpenStack Newton. (LP: #1664306)

James Page (james-page) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package neutron - 2:9.2.0-0ubuntu1~cloud0
---------------

 neutron (2:9.2.0-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 neutron (2:9.2.0-0ubuntu1) yakkety; urgency=medium
 .
   [ Chuck Short ]
   * d/p/tests-db.patch: Specify a db path for tests.
   * New upstream point release for Openstack Newton (LP: #1664306).
   * d/control: Bump python-pecan version. (LP: #1668578)
 .
   [ Corey Bryant ]
   * d/tests/control: Use needs-recommends to ensure neutron-plugin-ml2 is
     installed.

James Page (james-page) wrote :

The verification of the Stable Release Update for nova-lxd has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package nova-lxd - 14.2.0-0ubuntu0.16.10.1~cloud0
---------------

 nova-lxd (14.2.0-0ubuntu0.16.10.1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 nova-lxd (14.2.0-0ubuntu0.16.10.1) yakkety; urgency=medium
 .
   * New upstream version for Openstack Newton. (LP: #1664306)

James Page (james-page) wrote :

The verification of the Stable Release Update for swift has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package swift - 2.10.1-0ubuntu1~cloud0
---------------

 swift (2.10.1-0ubuntu1~cloud0) xenial-newton; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 swift (2.10.1-0ubuntu1) yakkety; urgency=medium
 .
   * d/p/avoid-infinite-loop-while-placing-parts.patch: Dropped
     no longer needed.
   * New upstream stable release for OpenStack Newton. (LP: #1664306)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:14.0.4-0ubuntu1.2

---------------
nova (2:14.0.4-0ubuntu1.2) yakkety; urgency=medium

  * d/p/libvirt-set-vlan-tag-for-macvtap.patch: Pick dependent patch
    for fix for libvirt 1.3.1 compatibility (LP: #1665698).

nova (2:14.0.4-0ubuntu1.1) yakkety; urgency=medium

  * d/patches/libvirt-set-script-path.patch: Conditionally set
    the script path for ethernet vif types (LP: #1665698).

nova (2:14.0.4-0ubuntu1) yakkety; urgency=medium

  * New upstream point release for OpenStack Newton (LP: #1664306).
  * d/control: Bump python-rfc3986 version.

 -- James Page <email address hidden> Wed, 22 Mar 2017 15:46:21 +0000

Changed in nova (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers