[SRU] ceilometer-common mongodb-autoreconnect.patch breaks ceilometer-dbsync

Bug #1421663 reported by Corey Bryant on 2015-02-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ceilometer (Ubuntu)
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Impact]
apt-get install ceilometer-common on utopic-proposed results in:

2015-02-13 13:16:02.003 14731 CRITICAL ceilometer [-] AttributeError: 'NoneType' object has no attribute 'find'
2015-02-13 13:16:02.003 14731 TRACE ceilometer Traceback (most recent call last):
2015-02-13 13:16:02.003 14731 TRACE ceilometer File "/usr/bin/ceilometer-dbsync", line 10, in <module>
2015-02-13 13:16:02.003 14731 TRACE ceilometer sys.exit(dbsync())
2015-02-13 13:16:02.003 14731 TRACE ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/cmd/storage.py", line 32, in dbsync
2015-02-13 13:16:02.003 14731 TRACE ceilometer storage.get_connection_from_config(cfg.CONF, 'metering').upgrade()
2015-02-13 13:16:02.003 14731 TRACE ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/storage/__init__.py", line 86, in get_connection_from_config
2015-02-13 13:16:02.003 14731 TRACE ceilometer return get_connection(url, namespace)
2015-02-13 13:16:02.003 14731 TRACE ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/storage/__init__.py", line 91, in get_connection
2015-02-13 13:16:02.003 14731 TRACE ceilometer connection_scheme = urlparse.urlparse(url).scheme
2015-02-13 13:16:02.003 14731 TRACE ceilometer File "/usr/lib/python2.7/urlparse.py", line 143, in urlparse
2015-02-13 13:16:02.003 14731 TRACE ceilometer tuple = urlsplit(url, scheme, allow_fragments)
2015-02-13 13:16:02.003 14731 TRACE ceilometer File "/usr/lib/python2.7/urlparse.py", line 182, in urlsplit
2015-02-13 13:16:02.003 14731 TRACE ceilometer i = url.find(':')
2015-02-13 13:16:02.003 14731 TRACE ceilometer AttributeError: 'NoneType' object has no attribute 'find'
2015-02-13 13:16:02.003 14731 TRACE ceilometer

This is due to a cherry picked patch mongodb-autoreconnect.patch.

[Test Case]
apt-get install ceilometer-common on utopic-proposed

[Regression Potential]
The patch was not yet upstream so I don't see any regression potential from removing this patch.

Related branches

Changed in nova (Ubuntu):
status: New → Incomplete
status: Incomplete → Invalid
Changed in ceilometer (Ubuntu):
status: New → Invalid
no longer affects: nova (Ubuntu)

Hello Corey, or anyone else affected,

Accepted ceilometer into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ceilometer/2014.2.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ceilometer (Ubuntu Utopic):
status: New → Fix Committed
tags: added: verification-needed
Billy Olsen (billy-olsen) wrote :

FWIW, the patch that was reverted introduced a new config option - which then causes the patch in debian/patches/default-config.patch to insert the connection parameter under the wrong config section.

Corey Bryant (corey.bryant) wrote :

Sorry Billy, sounds like bad luck on the patch applies. I'm guessing the fuzz level on the patch applies was high enough to put the option in the wrong section.

tags: added: verification-done
Corey Bryant (corey.bryant) wrote :

Testing has successfully completed on ceilometer (2014.2.2-0ubuntu2).

tags: added: utopic
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2014.2.2-0ubuntu2

---------------
ceilometer (2014.2.2-0ubuntu2) utopic; urgency=medium

  [ Corey Bryant ]
  * /d/p/mongodb-autoreconnect.patch: Dropped as it is breaking
    ceilometer-dbsync (LP: #1421663).
 -- Chuck Short <email address hidden> Fri, 13 Feb 2015 15:28:25 -0500

Changed in ceilometer (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ceilometer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers