It can not with the last Ubuntu-Trusty, probléme with dépendance.

Bug #1261101 reported by Moula BADJI on 2013-12-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ceilometer (Ubuntu)
Critical
Unassigned

Bug Description

hi,
i try to install ceilometor with Ubuntu Trusty. I can not, problem dependance, this is the message :

Paramétrage de ceilometer-common (2014.1~b1-0ubuntu1) ...
2013-12-15 07:38:27.469 2922 ERROR stevedore.extension [-] Could not load 'sqlite': (WebOb 1.3 (/usr/lib/python2.7/dist-packages), Requirement.parse('WebOb>=1.2.3,<1.3'))
2013-12-15 07:38:27.469 2922 ERROR stevedore.extension [-] (WebOb 1.3 (/usr/lib/python2.7/dist-packages), Requirement.parse('WebOb>=1.2.3,<1.3'))
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension Traceback (most recent call last):
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/stevedore/extension.py", line 134, in _load_plugins
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension invoke_kwds,
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/stevedore/named.py", line 95, in _load_one_plugin
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension ep, invoke_on_load, invoke_args, invoke_kwds,
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/stevedore/extension.py", line 146, in _load_one_plugin
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension plugin = ep.load()
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2107, in load
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension if require: self.require(env, installer)
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2120, in require
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension working_set.resolve(self.dist.requires(self.extras),env,installer)))
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 580, in resolve
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension raise VersionConflict(dist,req) # XXX put more info here
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension VersionConflict: (WebOb 1.3 (/usr/lib/python2.7/dist-packages), Requirement.parse('WebOb>=1.2.3,<1.3'))
2013-12-15 07:38:27.469 2922 TRACE stevedore.extension
2013-12-15 07:38:27.470 2922 CRITICAL ceilometer [-] No 'ceilometer.storage' driver found, looking for 'sqlite'
Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                  Aucun rapport « apport » n'a été créé car le message d'erreur indique une erreur consécutive à un échec précédent.
                                                                    Aucun rapport « apport » écrit car MaxReports a déjà été atteint
                                                    dpkg: erreur de traitement de ceilometer-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de ceilometer-agent-central :
 ceilometer-agent-central dépend de ceilometer-common (= 2014.1~b1-0ubuntu1) ; cependant :
 Le paquet ceilometer-common n'est pas encore configuré.

dpkg: erreur de traitement de ceilometer-agent-central (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de ceilometer-api :
 ceilometer-api dépend de ceilometer-common (= 2014.1~b1-0ubuntu1) ; cependant :
 Le paquet ceilometer-common n'est pas encore configuré.

dpkg: erreur de traitement de ceilometer-api (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de ceilometer-collector :
 ceilometer-collector dépend de ceilometer-common (= 2014.1~b1-0ubuntu1) ; cependant :
 Le paquet ceilometer-common n'est pas encore configuré.

dpkg: erreur de traitement de ceilometer-collector (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 ceilometer-common
 ceilometer-agent-central
 ceilometer-api
 ceilometer-collector
E: Sub-process /usr/bin/dpkg returned an error code (1)

thank's.

Related branches

Julien Danjou (jdanjou) on 2013-12-16
affects: ceilometer → ceilometer (Ubuntu)
Changed in ceilometer (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Chuck Short (zulcss) on 2014-01-09
Changed in ceilometer (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2014.1~b2-0ubuntu1

---------------
ceilometer (2014.1~b2-0ubuntu1) trusty; urgency=medium

  [ James Page ]
  * d/control: Add python-jsonpath-rw to BD's.
  * d/p/fix-setup-requirements.patch: Bump WebOb to support < 1.4.
   (LP: #1261101)

  [ Chuck Short ]
  * New upstream version.
  * debian/control, debian/ceilometer-common.install: Split out
    ceilometer-alarm-evaluator and ceilometer-alarm-notifier into their
    own packages. (LP: #1250002)
  * debian/ceilometer-agent-central.logrotate,
    debian/ceilometer-agent-compute.logrotate,
    debian/ceilometer-api.logrotate,
    debian/ceilometer-collector.logrotate: Add logrotate files,
    thanks to Ahmed Rahal. (LP: #1224223)
  * Fix typos in upstart files.
 -- Chuck Short <email address hidden> Thu, 23 Jan 2014 15:08:11 -0500

Changed in ceilometer (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers