[SRU] update openstack packages to 2013.2 release tarballs

Bug #1236462 reported by Scott Moser on 2013-10-07
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned
ceilometer (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
cinder (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
glance (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
heat (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
horizon (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
keystone (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
nova (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
quantum (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned
swift (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned

Bug Description

Openstack 2013.2 will release on October 17, 2013.
Ubuntu 13.10 will release on October 17, 2013.

That means that we're basically guaranteed to not have "2013.2" official release tarballs in Ubuntu.
This bug is a place holder for all the openstack packages that will need updating to the official release tarballs.

Related branches

Scott Moser (smoser) on 2013-10-07
summary: - [SRU] update openstack packages to released versions
+ [SRU] update openstack packages to 2013.2 release tarballs
affects: ubuntu → ceilometer (Ubuntu)
Scott Moser (smoser) on 2013-10-07
Changed in ceilometer (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in cinder (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in glance (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in horizon (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in keystone (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in nova (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in oslo-config (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in python-django-openstack-auth (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in quantum (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in swift (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Chuck Short (zulcss) wrote :

We dont have a MRE for ceilometer or heat.

no longer affects: oslo-config (Ubuntu)
no longer affects: python-django-openstack-auth (Ubuntu)
Changed in heat (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

Hello Scott, or anyone else affected,

Accepted nova into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nova/1:2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted neutron into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/neutron/1:2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted swift into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/swift/1.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted keystone into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/keystone/1:2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glance (Ubuntu Saucy):
status: Confirmed → Fix Committed
Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted glance into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glance/1:2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cinder (Ubuntu Saucy):
status: Confirmed → Fix Committed
Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted cinder into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/cinder/1:2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Saucy):
status: Confirmed → Fix Committed
Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted horizon into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/horizon/1:2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ceilometer (Ubuntu Saucy):
status: Confirmed → Fix Committed
Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted ceilometer into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ceilometer/2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in heat (Ubuntu Saucy):
status: Confirmed → Fix Committed
Dave Walker (davewalker) wrote :

Hello Scott, or anyone else affected,

Accepted heat into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/heat/2013.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in swift (Ubuntu Saucy):
status: Confirmed → Fix Committed
Changed in keystone (Ubuntu Saucy):
status: Confirmed → Fix Committed
Changed in nova (Ubuntu Saucy):
status: Confirmed → Fix Committed
Changed in quantum (Ubuntu Saucy):
status: Confirmed → Fix Committed
Miklos Juhasz (mjuhasz) on 2013-10-27
description: updated
James Page (james-page) wrote :

I've executed the standard three test topologies in the OpenStack QA Lab:

1) Nova Network, Cinder iSCSI
2) Nova Network, Cinder Ceph
3) Neutron Network, Cinder Ceph

Aside from three test failures due to issues in the Tempest test suite that we use from OpenStack upstream, all deployments and tests completed successfully.

tags: added: verification-done
removed: verification-needed
James Page (james-page) on 2013-10-29
Changed in cloud-archive:
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 1:2013.2-0ubuntu1

---------------
nova (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 11:27:05 -0400

Changed in nova (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 1:2013.2-0ubuntu1

---------------
glance (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:11:10 -0400

Changed in glance (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 1:2013.2-0ubuntu1

---------------
keystone (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:22:54 -0400

Changed in keystone (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package swift - 1.10.0-0ubuntu1

---------------
swift (1.10.0-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:26:18 -0400

Changed in swift (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2013.2-0ubuntu1

---------------
horizon (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 09:43:46 -0400

Changed in horizon (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2013.2-0ubuntu1

---------------
ceilometer (2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 09:38:31 -0400

Changed in ceilometer (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 1:2013.2-0ubuntu1

---------------
cinder (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:00:43 -0400

Changed in cinder (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 2013.2-0ubuntu1

---------------
heat (2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 09:30:24 -0400

Changed in heat (Ubuntu Saucy):
status: Fix Committed → Fix Released
Dave Walker (davewalker) on 2013-10-29
Changed in ceilometer (Ubuntu):
status: Fix Committed → Invalid
Changed in cinder (Ubuntu):
status: Fix Committed → Invalid
Changed in glance (Ubuntu):
status: Fix Committed → Invalid
Changed in horizon (Ubuntu):
status: Fix Committed → Invalid
Changed in heat (Ubuntu):
status: Fix Committed → Invalid
Changed in keystone (Ubuntu):
status: Fix Committed → Invalid
Changed in nova (Ubuntu):
status: Fix Committed → Invalid
Changed in swift (Ubuntu):
status: Fix Committed → Invalid
Changed in quantum (Ubuntu Saucy):
status: Fix Committed → Invalid
Changed in quantum (Ubuntu):
status: Fix Committed → Invalid
James Page (james-page) wrote :

Copied all updates through to the -updates pocket after successful verification

Changed in cloud-archive:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2013.2-0ubuntu1

---------------
ceilometer (2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 09:38:31 -0400

Changed in ceilometer (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2013.2-0ubuntu1

---------------
horizon (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 09:43:46 -0400

Changed in horizon (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 1:2013.2-0ubuntu1

---------------
cinder (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:00:43 -0400

Changed in cinder (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 1:2013.2-0ubuntu1

---------------
nova (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 11:27:05 -0400

Changed in nova (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 1:2013.2-0ubuntu1

---------------
glance (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:11:10 -0400

Changed in glance (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 2013.2-0ubuntu1

---------------
heat (2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 09:30:24 -0400

Changed in heat (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 1:2013.2-0ubuntu1

---------------
keystone (1:2013.2-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:22:54 -0400

Changed in keystone (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package swift - 1.10.0-0ubuntu1

---------------
swift (1.10.0-0ubuntu1) saucy; urgency=low

  * New upstream release (LP: #1236462).
 -- Chuck Short <email address hidden> Thu, 17 Oct 2013 10:26:18 -0400

Changed in swift (Ubuntu):
status: Invalid → Fix Released
James Page (james-page) on 2016-05-16
Changed in cloud-archive:
status: Fix Released → Fix Committed
James Page (james-page) wrote :
Download full text (16.9 KiB)

This bug was fixed in the package heat - 1:6.0.0-0ubuntu2~cloud0
---------------

 heat (1:6.0.0-0ubuntu2~cloud0) xenial-newton; urgency=medium
 .
   * New package for the Ubuntu Cloud Archive.
 .
 heat (1:6.0.0-0ubuntu2) yakkety; urgency=medium
 .
   * d/p/engine-shutdown.patch: Cherry pick fix to ensure that heat-engine
     worker processes are shutdown correctly when SIGINT is received early
     in the process lifecycle (LP: #1562042).
 .
 heat (1:6.0.0-0ubuntu1) xenial; urgency=medium
 .
   * New upstream release for OpenStack Mitaka.
 .
 heat (1:6.0.0~rc1-0ubuntu1) xenial; urgency=medium
 .
   * New upstream release candidate for OpenStack Mitaka.
   * d/control: Align (build-)depends with upstream.
 .
 heat (1:6.0.0~b3-0ubuntu1) xenial; urgency=medium
 .
   * New upstream milestone for OpenStack Mitaka.
   * d/p/use-oslo-config-fixture-for-tests.patch: Removed. Fixed upstream.
   * d/control: Align (build-)depends with upstream.
 .
 heat (1:6.0.0~b2-0ubuntu2) xenial; urgency=medium
 .
   * d/p/use-oslo-config-fixture-for-tests.patch: Cherry-picked from upstream
     master branch to fix test failures with new oslo.config versions.
 .
 heat (1:6.0.0~b2-0ubuntu1) xenial; urgency=medium
 .
   * New upstream milestone for OpenStack Mitaka.
   * d/control: Align (build-)depends with upstream.
 .
 heat (1:6.0.0~b1-0ubuntu1) xenial; urgency=medium
 .
   * New upstream milestone for OpenStack Mitaka.
   * d/control: Align (build-)depends with upstream.
   * d/p/fixup-assert-regex.patch: Rebased.
 .
 heat (1:5.0.0-0ubuntu1) wily; urgency=medium
 .
   * New upstream release for OpenStack Liberty.
 .
 heat (1:5.0.0~rc2-0ubuntu1) wily; urgency=medium
 .
   * New upstream release candidate for OpenStack Liberty.
   * Don't clean heat.egg-info ensuring that non-py resources actually
     get installed (LP: #1505444).
 .
 heat (1:5.0.0~rc1-0ubuntu1) wily; urgency=medium
 .
   * New upstream release candidate for OpenStack Liberty.
   * d/control: Align (build-)depends with upstream.
   * d/watch: Update to cope with upstream rc versioning.
   * d/rules: Drop removal of .eggs directory in override_dh_auto_clean.
   * d/control: Bump minimum pbr version to 1.8.
 .
 heat (1:5.0.0~b3-0ubuntu1) wily; urgency=medium
 .
   * New upstream milestone for OpenStack Liberty.
   * d/control: Align (build-)depends with upstream.
   * d/p/fix-dummy-resource-missing.patch: Dropped. Fixed in milestone.
   * d/p/move-extensions.patch: Dropped. Fixed in milestone.
 .
 heat (1:5.0.0~b2-0ubuntu2) wily; urgency=medium
 .
   * d/control: Add python-pymysql to (build-)depends.
   * d/p/fix-dummy-resource-missing.patch: Cherry-picked from master to fix
     failing tests.
   * d/p/move-extensions: Cherry-picked from master to fix failing tests.
 .
 heat (1:5.0.0~b2-0ubuntu1) wily; urgency=medium
 .
   * New upstream milestone for OpenStack Liberty.
   * d/control: Align (build-)depends with upstream.
   * d/p/fix-requirements.patch: Dropped. No longer needed.
   * d/p/fixup-assert-regex.patch: Rebased.
   * d/rules: Remove .eggs directory in override_dh_auto_clean.
 .
 heat (1:5.0.0~b1-0ubuntu4) wily; urgency=medium
 .
   * d/heat-common.install: Include missing templates ...

Changed in cloud-archive:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers