Missing logrotate configuration files

Bug #1224223 reported by Mathieu Gagné on 2013-09-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ceilometer (Ubuntu)
Low
Unassigned

Bug Description

Logrotate configuration files are missing for all ceilometer services:
- ceilometer-agent-central
- ceilometer-agent-compute
- ceilometer-api
- ceilometer-collector

I expect logrotate configuration files to be provided by the package.

Related branches

Changed in ceilometer (Ubuntu):
importance: Undecided → Low
Ahmed Rahal (arahal) wrote :

This is a basic logrotate configuration file with rotation on 7 days

Ahmed Rahal (arahal) wrote :

This is a basic logrotate configuration file with rotation on 7 days

Ahmed Rahal (arahal) wrote :

This is a basic logrotate configuration file with rotation on 7 days

Ahmed Rahal (arahal) wrote :

This is a basic logrotate configuration file with rotation on 7 days

Chuck Short (zulcss) on 2014-01-09
Changed in ceilometer (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2014.1~b2-0ubuntu1

---------------
ceilometer (2014.1~b2-0ubuntu1) trusty; urgency=medium

  [ James Page ]
  * d/control: Add python-jsonpath-rw to BD's.
  * d/p/fix-setup-requirements.patch: Bump WebOb to support < 1.4.
   (LP: #1261101)

  [ Chuck Short ]
  * New upstream version.
  * debian/control, debian/ceilometer-common.install: Split out
    ceilometer-alarm-evaluator and ceilometer-alarm-notifier into their
    own packages. (LP: #1250002)
  * debian/ceilometer-agent-central.logrotate,
    debian/ceilometer-agent-compute.logrotate,
    debian/ceilometer-api.logrotate,
    debian/ceilometer-collector.logrotate: Add logrotate files,
    thanks to Ahmed Rahal. (LP: #1224223)
  * Fix typos in upstart files.
 -- Chuck Short <email address hidden> Thu, 23 Jan 2014 15:08:11 -0500

Changed in ceilometer (Ubuntu):
status: Confirmed → Fix Released

In the current packages present in trusty, these files are missing again.

Shayne Civitarese (civerooni) wrote :

Also noticing these files are missing from latest build.

If you look at the revision listed in this bug:
http://bazaar.launchpad.net/~ubuntu-server-dev/ceilometer/icehouse/revision/82#debian/changelog
It looks like those files were noted in the changelog as being added, but I can't actually see the files in the revision.

Seems someone forgot to add to the repository before committing...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers