ceilometer-dbsync abuse

Bug #1182964 reported by Swann Croiset on 2013-05-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned
ceilometer (Ubuntu)
High
James Page
Trusty
High
James Page

Bug Description

When installing the compute-agent on a hypervisor generaly we didn't need to sync db from it.
DB is usually installed on an anther server

furthermore, for each installation of compute-agent (on compute nodes), dbsync is fired which is too much and useless.
and if there are no db accessible the installation failed.

the ceilometer-dbsync come with ceilometer-common which is a dependance of ceilometer-agent-compute.

A better place to do the dbsync would be with the installation of the collector IMHO

----
> lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring

> aptitude show ceilometer-agent-compute
Package: ceilometer-agent-compute
State: not installed
Version: 2013.1-0ubuntu1
Priority: optional
Section: universe/python
Maintainer: Chuck Short <email address hidden>
Architecture: all
Uncompressed Size: 48.1 k
Depends: ceilometer-common (= 2013.1-0ubuntu1), upstart-job, python
Description: ceilometer compute agent

Related branches

Swann Croiset (swann-w) on 2013-05-22
description: updated
Swann Croiset (swann-w) on 2013-05-22
description: updated
Changed in ceilometer (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
James Page (james-page) on 2014-03-06
Changed in ceilometer (Ubuntu Trusty):
status: Confirmed → Triaged
James Page (james-page) wrote :

After some further discussion on irc downgrading this to wishlist; yes its inefficient but does not cause direct issues.

Changed in ceilometer (Ubuntu Trusty):
importance: Medium → Wishlist
James Page (james-page) on 2014-03-14
Changed in cloud-archive:
status: New → Triaged
importance: Undecided → Wishlist
James Page (james-page) wrote :

Hmm - reconsidering as this just broken upgrades of alot of compute nodes - which don't have a connection set:

ubuntu@juju-jamespage-machine-13:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  quantum-plugin-openvswitch python-testtools python-daemon python-quantumclient python-nose python-gflags python-quantum python-extras python-carrot
  python-fixtures python-glance python-utidylib python-stompy python-oslo-config quantum-common python-lockfile python-feedparser python-dateutil
  libtidy-0.99-0 python-libxml2 python-xattr python-dingus qemu-common
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up ceilometer-common (2013.2.2-0ubuntu1~cloud0) ...
+ [ configure = configure ]
+ getent group ceilometer
+ getent passwd ceilometer
+ chown -R ceilometer:adm /var/log/ceilometer
+ chmod 0750 /var/log/ceilometer
+ chown -R ceilometer:ceilometer /var/lib/ceilometer /etc/ceilometer
+ su -s /bin/sh -c /usr/bin/ceilometer-dbsync ceilometer
2014-04-01 16:13:18.679 8736 CRITICAL ceilometer [-] (OperationalError) unable to open database file None None
dpkg: error processing ceilometer-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ceilometer-agent-compute:
 ceilometer-agent-compute depends on ceilometer-common (= 2013.2.2-0ubuntu1~cloud0); however:
  Package ceilometer-common is not configured yet.
dpkg: error processing ceilometer-agent-compute (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 ceilometer-common
 ceilometer-agent-compute
E: Sub-process /usr/bin/dpkg returned an error code (1)

James Page (james-page) on 2014-04-01
Changed in ceilometer (Ubuntu Trusty):
importance: Wishlist → High
Changed in cloud-archive:
importance: Wishlist → High
Changed in ceilometer (Ubuntu Trusty):
assignee: nobody → James Page (james-page)
status: Triaged → In Progress
James Page (james-page) on 2014-04-01
Changed in ceilometer (Ubuntu Trusty):
status: In Progress → Fix Committed
Chuck Short (zulcss) on 2014-04-02
Changed in cloud-archive:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 2014.1~rc2-0ubuntu1

---------------
ceilometer (2014.1~rc2-0ubuntu1) trusty; urgency=medium

  [ James Page ]
  * d/ceilometer-common.postinst: Only run db sync process if default sqlite
    connection is configured in /etc/ceilometer/ceilometer.conf (LP: #1182964).

  [ Chuck Short ]
  * New upstream release (LP: #1299055).
 -- Chuck Short <email address hidden> Tue, 08 Apr 2014 15:41:50 -0400

Changed in ceilometer (Ubuntu Trusty):
status: Fix Committed → Fix Released
James Page (james-page) on 2015-03-24
Changed in cloud-archive:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers