Can't burn CDs

Bug #26718 reported by Julien Olivier
Affects Status Importance Assigned to Milestone
cdrtools (Ubuntu)
Scott James Remnant (Canonical)

Bug Description

I tried to burn a CD-R today and discovered that it didn't work anymore. I tend
to think that it's due to udev but it could also be a bug in cdrecord.

If I try to burn using nautilus-cd-burn, rhythmbox or serpentine, I always get
the same behaviour: the CD writer is detected correctly, the image is created,
and finally the burning fails but no data is written on the CD. Thus, the CD can
be re-used.

If I try to burn using graveman, the CD writer is detected too, but when I
launch the actual burning, it refuses to go on, saying that there is no CD in
the writer.

Finally, I tried to perform a cdrecord -scanbus, and here is what I got:

root@lifebook ~ # cdrecord -scanbus
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Joerg
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to
<email address hidden>.
      The original author should not be bothered with problems of this version.

cdrecord: Warning: Running on Linux-2.6.15-7-386
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord: For more information, install the cdrtools-doc
cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .

Any idea ?

PS: it used to work last time I tried, on the same PC (a few months ago). I also
tried on a Windows PC with the same CDs, and it worked.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Definitely not a udev bug, if udev is loading the right driver and the device
node is being created, then its job is done. It has no further involvement than
that. Unless you know that the device node is wrong (for example, are the
permissions correct?) then I don't see how this is a udev bug.

Revision history for this message
Julien Olivier (julo) wrote :

There are two things that made me think it was related to udev:
 - until today I had a bug with udev not creating the /dev/hdc device node.
 - this line: "cdrecord: No such file or directory. Cannot open '/dev/pg*'.
Cannot open SCSI
driver." made me think that maybe udev failed to create /dev/pg* nodes. Indeed,
they don't exist, but I don't know if they should.

For your information:
julien@lifebook ~ $ ls -l /dev/hdc
brw-r----- 1 root floppy 22, 0 2005-12-08 11:13 /dev/hdc

Is it correct ? Should I check anything else ?

Revision history for this message
Julien Olivier (julo) wrote :

I fixed the problem by doing the following:

chmod g+w /dev/hdc
ln -s /dev/hdc /dev/pg0

Revision history for this message
Philip Falkner (philafel) wrote :

I think this is a udev permission problem.

1) IDE DVD-RW drive hdc is showing up root:floppy. Shouldn't that be
root:cdrom? In /etc/udev/rules.d/40-permissions.rules, it looks like a typo
on line 18, with an extra 0 before the comma.

KERNEL=="hd[a-z]|pcd[0-9]*"0, \
        IMPORT{program}="cdrom_id --export $tempnode"

 Shouldn't it be
KERNEL=="hd[a-z]|pcd[0-9]*", \
        IMPORT{program}="cdrom_id --export $tempnode"

 This change makes my hdc root:cdrom.

2) hdc is also 0640, so only root can burn discs. Is that a deliberate
change? 0660 would let members of cdrom burn.

Revision history for this message
Julien Olivier (julo) wrote :

And what about the /dev/pg0 file ? Isn't it needed ? cdrecord -scanbus refuses
to detect my cd writer unless I link /dev/hdc to /dev/pg0.

Revision history for this message
Matt Zimmerman (mdz) wrote :

cdrecord -scanbus is working here, and looks for /dev/sg* rather than /dev/pg*. I'm not sure under what circumstances it looks for /dev/pg*. Are you still experiencing this problem with current Dapper?

Changed in cdrtools:
assignee: nobody → keybuk
status: Unconfirmed → Needs Info
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

/dev/pg are the interfaces for IDE devices connected on a parallel port; nobody seems to have driver-core'd these yet, but then they're almost certainly not what you're looking for.

Please try the current dapper, but I don't think that'll fix anything because there's been no cdrecord update since you filed the bug (until today, which isn't relevant).

Note that linking /dev/pg0 to /dev/hdc shouldn't fix it, because they are different devices.

Revision history for this message
Julien Olivier (julo) wrote :

I still see the same error message when running cdrecord -scanbus on Dapper. But, now, it seems to not affect nautilus-cd-burn, which works without needing to create the simlink.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Yeah, the symlink is bogus -- /dev/pg0 and /dev/hdc would be totally different interfaces anyway.

This means cdrecord -scanbus is busted for you I guess.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

As you note, nautilus-cd-burn works correctly; and if you give the right arguments to cdrecord it also works correct.y -scanbus not behaving is not unusual according to upstream

Changed in cdrtools:
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.