Ubuntu

D-I prompts for CD-ROM drivers when preseeding from USB drive

Reported by Tom Ellis on 2010-05-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cdrom-detect (Ubuntu)
Medium
Colin Watson
Karmic
Medium
Colin Watson
Lucid
Medium
Colin Watson

Bug Description

Binary package hint: debian-installer

TEST CASE: When installing Ubuntu 10.04 LTS from a USB drive (alternate CD install created with usb-creator-gtk) with the Language and Keyboard values preseeded and a preseed/file also on the disk the installation gets to a point where it tries to mount the CD and fails.
D-I prompts for additional drivers after not detecting the CD drive, but if you run detect again it correctly mounts the drive and the automated installation continues as expected.

This seems like a race condition, as the USB drive has not settled when D-I tries to mount it.

The expected behavior is that the installation continues as normal waiting for the drive to settle before mounting it.

This bug is affecting an important customer, hence the request for a stable update. It has been addressed in the development branch in cdrom-detect 1.32ubuntu5. Patch: http://bazaar.launchpad.net/~ubuntu-core-dev/cdrom-detect/ubuntu/revision/461.

This change really just tries harder, so I see little potential for regression aside from increased delays on failures.

Tom Ellis (tellis) wrote :

My boot options added to text.cfg:

cdrom-detect/try-usb=true persistent file=/cdrom/test/test.seed debian-installer/locale=en_US.UTF-8 console-setup/layoutcode=us initrd=/install/initrd.gz DEBCONF_DEBUG=developer quiet --

Uploading more debug info shortly.

Tom Ellis (tellis) wrote :
Tom Ellis (tellis) wrote :

Removed commented line in /bin/hw-detect for debugging:

# set -x

Reran install, syslog attached for logs up to the failure.

Tom Ellis (tellis) wrote :

as per Bug #424437
I added a sleep to /var/lib/dpkg/info/cdrom-detect.postinst to check to see if it was the USB drive not settling and installation continued as expected.

Changed in debian-installer (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

The requested information was provided, setting this to Triaged, Thanks Tom.

Colin Watson (cjwatson) wrote :

Tom, could you please try this diff?

  http://bazaar.launchpad.net/~ubuntu-core-dev/cdrom-detect/ubuntu/revision/461

If that works, then I can apply it to Maverick and backport it. Thanks in advance.

affects: debian-installer (Ubuntu) → cdrom-detect (Ubuntu)
Tom Ellis (tellis) wrote :

Colin,
Thanks for the patch.
Applied and tested, it fixed the issue for me.

is there a chance for a 9.10 backport too?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cdrom-detect - 1.32ubuntu5

---------------
cdrom-detect (1.32ubuntu5) maverick; urgency=low

  * usb-storage sometimes seems to take a while to settle to the point of
    actually exposing block devices, despite the 'udevadm settle' in
    hw-detect. I don't see an easy way to solve this, so, with
    reservations, retry the detection loop three times with a 'sleep 3' in
    between in the event that no devices are found, in the hope that that
    improves matters (LP: #586036).
 -- Colin Watson <email address hidden> Fri, 04 Jun 2010 18:23:26 +0100

Changed in cdrom-detect (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) on 2010-06-04
description: updated
Changed in cdrom-detect (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → Medium
Changed in cdrom-detect (Ubuntu):
importance: Low → Medium
Changed in cdrom-detect (Ubuntu Karmic):
assignee: nobody → Colin Watson (cjwatson)
Changed in cdrom-detect (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in cdrom-detect (Ubuntu Lucid):
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
status: New → In Progress

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in cdrom-detect (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in cdrom-detect (Ubuntu Lucid):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Colin Watson (cjwatson) wrote :

Could you please use this image to test this?

  http://cdimage.ubuntu.com/lucid/daily/current/

Tom Ellis (tellis) wrote :

Tested todays lucid daily, doesn't seem to work for me.

The patch isn't in the initrd.gz as far as I can see?

Colin Watson (cjwatson) wrote :

Could you try again? I've checked that it's in the initrd of the current daily build.

Alex Chiang (achiang) wrote :

Colin,

I tested your change in an OEM project based on Lucid.

Without your change, I would get prompted about the cdrom 100% of the time.

With your change, I've now successfully done 3 fully automatic installs without being prompted at all; your patch is working great.

Thanks!

Martin Pitt (pitti) on 2010-07-14
tags: added: verification-done
Tom Ellis (tellis) wrote :

This is also now working for me in the latest Lucid daily builds.

Thanks for all your help Colin!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cdrom-detect - 1.32ubuntu3.10.04

---------------
cdrom-detect (1.32ubuntu3.10.04) lucid-proposed; urgency=low

  * usb-storage sometimes seems to take a while to settle to the point of
    actually exposing block devices, despite the 'udevadm settle' in
    hw-detect. I don't see an easy way to solve this, so, with
    reservations, retry the detection loop three times with a 'sleep 3' in
    between in the event that no devices are found, in the hope that that
    improves matters (LP: #586036).
 -- Colin Watson <email address hidden> Fri, 04 Jun 2010 18:33:56 +0100

Changed in cdrom-detect (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Removing v-done again since karmic test is still outstanding.

tags: removed: verification-done
Martin Pitt (pitti) wrote :

Can anyone please test this on karmic? Or should we remove the proposed update, since it is unlikely to be useful (since we won't respin karmic CDs)?

Tom Ellis (tellis) wrote :

Since we don't respin the karmic CD, it's pretty useless for me, I can however use the fix with my own respins. Thanks.

Martin Pitt (pitti) wrote :

Right,I agree.

Changed in cdrom-detect (Ubuntu Karmic):
status: Fix Committed → Won't Fix
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers