Ubuntu

10.04 64 bit server installation unable to mount CD on blade

Reported by xcross on 2010-05-03
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cdrom-detect (Ubuntu)
Undecided
Unassigned

Bug Description

I'm attempting to install 10.04 LTS Server 64 bit on an IBM blade server. After booting the CD and responding to the initial screens the installation fails, reporting that it can't mount the cd. The blade server is in a chassis with a shared "media tray" where the CD drive resides. The CD is a usb drive.

I've installed 9.10 desktop but never server on this machine so I don't know if this is new problem with 10.04 server CD.

xcross (xcross59) wrote :
xcross (xcross59) wrote :

I just tried 9.10 server and it successfully got past the step of mounting/scanning the installation medium. The screen shot is where I killed the install.

xcross (xcross59) on 2010-05-09
Changed in ubuntu:
status: New → Incomplete
status: Incomplete → New
xcross (xcross59) on 2010-05-09
affects: ubuntu → live-installer (Ubuntu)
xcross (xcross59) wrote :

I'm willing to work on a fix if someone can point me to directions for building the Lucid server live cd.

I also face the same situation and same problem. It happen when I try to install Lucid and Karmic server edition. There is no problem when I try to install Desktop version 32 bit and 64 bit.

affects: live-installer (Ubuntu) → cdrom-detect (Ubuntu)
Christopher Tozzi (cjt34) wrote :

I have the same problem and same hardware. After a lot of struggling, I found a workaround that allowed me to install Ubuntu 10.04 LTS on my blade. Here's what I did.

You will need an Ubuntu Server 10.04 CD and a USB stick formatted as ext2 (or possibly other file systems, but I couldn't get a fat32 stick to mount, so I reformatted it to ext2 and it worked) with the Ubuntu Server iso image on it.

With those materials in hand, this is what I did:
1. boot your blade to the Ubuntu Server CD. Make sure the USB stick is plugged in as well.
2. when the installer gets to the point where it fails to detect the CD, go back to the main menu and select "Execute Shell."
3. in the shell, mount the USB stick with commands like:
  mkdir /mnt/sdb1
  mount /dev/sdb1 /mnt/sdb1
4. next, mount the Ubuntu Server ISO image as a loopback device at the mountpoint /cdrom:
  mount -o loop -t iso9660 /mnt/sdb1/ubuntu-10.04-server-amd64.iso /cdrom
5. type "exit" to exit the shell and go back to the main menu. From there, select the option to detect the CD ROM. It should now work and you can proceed with the installation.

This is a complicated workaround and it would be great to have the bug itself fixed. I'm happy to provide any information towards that end.

Christopher Tozzi (cjt34) wrote :

Addenda:

1. it turns out that the steps in my previous message won't actually allow you to complete installation of Ubuntu Server 10.04, due to an issue that arises as a result of manually mounting the CD image as a loopback device. However, that too can be worked around. I've created a full set of the instructions that allowed me to complete installation successfully at http://ubuntuforums.org/showthread.php?p=9338967#post9338967.

2. for the purposes of tracking down the source of this bug, it may be useful to note that when I boot to the Ubuntu 10.04 Server installation CD and drop down to a shell, I can't find anything in /dev that corresponds to my CD device. Normally (in Ubuntu 8.04 running on this same blade) this should be /dev/sr0, but it doesn't exist.

3. I will attach dmesg, lspci and syslog from the installer session in case they're useful. Please note that in addition to the CD device, there was a USB stick (/dev/sdb) attached to the blade during this session.

If I can provide any other information, please let me know.

Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Changed in cdrom-detect (Ubuntu):
status: New → Confirmed

I read all the hard steps needed to install Ubuntu server from USB stick but the fix is actually very simple:

Just copy the file "fs-secondary-modules-2.6.32-21-generic-di_2.6.32-21.32_amd64.ude" in the same directory that is located but with the name "fs-secondary-modules-2.6.32-21-generic-di_2.6.32-21.32_amd64.udeb". This step is done on your USB stick after it has been prepared with Unetbootin or other similar tool. The directory that the file is located is "pool/main/l/linux".

The version number of the file and the amd64 part depends on the version of Ubuntu that you had downloaded.

The credits for this fix go to Uniqueone user from the Ubuntu forums. Here is his post:
http://ubuntuforums.org/showpost.php?p=9637343&postcount=4
which I used to create this step. My one is a bit different with coping the file instead of renaming it, because if you rename it permanently in the ISO, you will not be able to install from CD.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers