Intrepid installer doesn't detect SATA DVD-ROM

Bug #267838 reported by Michael Hipp
4
Affects Status Importance Assigned to Milestone
cdrom-detect (Ubuntu)
Fix Released
Undecided
Unassigned
Nominated for Intrepid by Wouter Stomp

Bug Description

Binary package hint: debian-installer

(I hope I attached this to the correct package.)

I'm attempting to install Intrepid i386 server alpha5 downloaded from here:

  http://cdimage.ubuntu.com/releases/intrepid/alpha-5/intrepid-server-i386.iso

Early in the installer it fails to detect the CD-ROM and gives error message: "No common CD-ROM drive was detected". There appears to be no way to move forward with the installation at this point.

Hardware: Motherboard is Gigabyte GA-M51GM-S2G
  http://www.gigabyte.com.tw/Support/Motherboard/Manual_Model.aspx?ProductID=2281
Uses a NVIDIA Geforce 6100 + nForce 430 chipset

The DVD-ROM drive is a Lite-On SHC-52S7K

This could be related to this bug:
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/249299

I have confirmed that 6.06.1 LTS server and 8.04.1 LTS server do not have this problem.

Revision history for this message
Michael Hipp (michael-hipp) wrote :

I switched the system to a PATA DVD-ROM drive and it seems to work fine.

Revision history for this message
Colin Watson (cjwatson) wrote :

With the SATA drive, does the corresponding desktop CD detect the CD drive?

Changed in debian-installer:
status: New → Incomplete
Revision history for this message
Michael Hipp (michael-hipp) wrote :

I tried the daily live desktop 386 CD dated 9/15. It seems to work fine.

Changed in cdrom-detect:
status: Incomplete → New
Revision history for this message
Steve Beattie (sbeattie) wrote :

This bug was found in the Intrepid development cycle; removing regression-potential and marking as regression-release.

Revision history for this message
Colin Watson (cjwatson) wrote :

OK, sorry for my delay in following up. Could you please post the output of 'sudo lspci -vvnn' from a running 8.10 desktop CD, so that I can see which driver is involved? I'm guessing that the problem is that the relevant kernel module isn't shipped in the right udebs so that the installer initrd can load it.

Changed in cdrom-detect:
status: New → Incomplete
Revision history for this message
Michael Hipp (michael-hipp) wrote :

Thanks. But now it seems this system will not run the desktop live CD. (I know I tried it once before per my comments above.) It dies to BusyBox with no error message. Any ideas?

This system currently runs 8.04 desktop and W2k. I could post the output from 8.04 if that would help.

Revision history for this message
Colin Watson (cjwatson) wrote :

Yes please, the output from 8.04 would be helpful - just as long as it's from a working Ubuntu instance.

Revision history for this message
Jon Ringer (jonringer117) wrote :
Download full text (61.2 KiB)

I have a similar problem with my DVD-ROM.

The drive is plugged into the second Sata slot on the motherboard, it goes through the Sata interface and uses a Sata power cable.
Info:
Lite-on it corp.
CD-RW/DVD-ROM DRIVE
MODEL SHC-52S7K

Extra Info:

dmesg:
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.27-9-generic (buildd@rothera) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Thu Nov 20 21:57:00 UTC 2008 (Ubuntu 2.6.27-9.19-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[ 0.000000] BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003fef0000 (usable)
[ 0.000000] BIOS-e820: 000000003fef0000 - 000000003fef3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000003fef3000 - 000000003ff00000 (ACPI data)
[ 0.000000] BIOS-e820: 00000000f0000000 - 00000000f2000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
[ 0.000000] last_pfn = 0x3fef0 max_arch_pfn = 0x100000
[ 0.000000] kernel direct mapping tables up to 38000000 @ 7000-c000
[ 0.000000] RAMDISK: 3781d000 - 37fefe95
[ 0.000000] DMI 2.4 present.
[ 0.000000] ACPI: RSDP 000F7630, 0024 (r2 Nvidia)
[ 0.000000] ACPI: XSDT 3FEF30C0, 0044 (r1 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: FACP 3FEF9700, 00F4 (r3 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: DSDT 3FEF3240, 6472 (r1 NVIDIA ASUSACPI 1000 MSFT 3000000)
[ 0.000000] ACPI: FACS 3FEF0000, 0040
[ 0.000000] ACPI: HPET 3FEF9940, 0038 (r1 Nvidia ASUSACPI 42302E31 AWRD 98)
[ 0.000000] ACPI: MCFG 3FEF99C0, 003C (r1 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: APIC 3FEF9840, 0098 (r1 Nvidia ASUSACPI 42302E31 AWRD 0)
[ 0.000000] 126MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] mapped low ram: 0 - 38000000
[ 0.000000] low ram: 00000000 - 38000000
[ 0.000000] bootmap 00008000 - 0000f000
[ 0.000000] (9 early reservations) ==> bootmem [0000000000 - 0038000000]
[ 0.000000] #0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]
[ 0.000000] #1 [0000001000 - 0000002000] EX TRAMPOLINE ==> [0000001000 - 0000002000]
[ 0.000000] #2 [0000006000 - 0000007000] TRAMPOLINE ==> [0000006000 - 0000007000]
[ 0.000000] #3 [0000100000 - 00005c0a20] TEXT DATA BSS ==> [0000100000 - 00005c0a20]
[ 0.000000] #4 [003781d000 - 0037fefe95] RAMDISK ==> [003781d000 - 0037fefe95]
[ 0.000000] #5 [00005c1000 - 00005c4000] INIT_PG_TABLE ==> [00005c1000 - 00005c4000]
[ 0.000000] #6 [000009f000 - 0000100000] BIOS reserved ==> [000009f000 - 0000100000]
[ 0.000000] #7 [0000007000 - 0000008000] PGTABLE ==> [0000007000 - 0000008000]
[ 0.000000] #8 [0000008000 - 000000f000] BOOTMAP ==> [0000008000 - 000000f000]
[ 0.000000] found SMP MP-table at [c00f5bb0] 000f5bb0
[ 0.000000] Zone PFN ranges:
[ 0.000000]...

Revision history for this message
Jon Ringer (jonringer117) wrote :

Sry for the double post, forgot to run commands under sudo, and say that the drive is recognized while running windows XP.

The drive is plugged into the second Sata slot on the motherboard, it goes through the Sata interface and uses a Sata power cable.
Info:
Lite-on it corp.
CD-RW/DVD-ROM DRIVE
MODEL SHC-52S7K

The command logs will be in the form of attachments this time.

Revision history for this message
Colin Watson (cjwatson) wrote :

Thanks for the feedback (although Jon, in future note that in general it is very hard to tell whether your hardware detection bug is the same as somebody else's, and it is usually in your own best interest to file a *separate* bug rather than to attach information to an existing bug).

I think that the odds are that this is fixed in Jaunty, now that pata_amd is built into the kernel, thereby eliminating most possibilities of divergence between the installer and the live CD. Michael Hipp, if you are still experiencing this problem with a current build of Jaunty, please do reopen this bug and provide the details I asked for in comments 5 and 7.

If you are not Michael Hipp and you're experiencing a bug that looks like this, please resist the temptation to comment on or reopen this bug. Instead, you will be better off filing a new bug with details (i.e. does the live CD work, and lspci -vvnn).

Changed in cdrom-detect:
status: Incomplete → Fix Released
Revision history for this message
Michael Hipp (michael-hipp) wrote :
Download full text (16.6 KiB)

Colin, your note reminded me that I hadn't replied to this. I apologize.

The machine is running Hardy desktop. Here's the output of 'sudo lspci -vvnn'. Let me know if you need more or need me to test something.

00:00.0 RAM memory [0500]: nVidia Corporation C51 Host Bridge [10de:02f1] (rev a2)
 Subsystem: Giga-byte Technology GA-M55plus-S3G [1458:5000]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Capabilities: [44] HyperTransport: Slave or Primary Interface
  Command: BaseUnitID=0 UnitCnt=15 MastHost- DefDir- DUL-
  Link Control 0: CFlE+ CST- CFE- <LkFail- Init+ EOC- TXO- <CRCErr=0 IsocEn- LSEn- ExtCTL- 64b-
  Link Config 0: MLWI=16bit DwFcIn- MLWO=16bit DwFcOut- LWI=16bit DwFcInEn- LWO=16bit DwFcOutEn-
  Link Control 1: CFlE+ CST- CFE- <LkFail- Init+ EOC- TXO- <CRCErr=0 IsocEn- LSEn+ ExtCTL- 64b-
  Link Config 1: MLWI=16bit DwFcIn- MLWO=16bit DwFcOut- LWI=8bit DwFcInEn- LWO=8bit DwFcOutEn-
  Revision ID: 1.03
  Link Frequency 0: 1.0GHz
  Link Error 0: <Prot- <Ovfl- <EOC- CTLTm-
  Link Frequency Capability 0: 200MHz+ 300MHz+ 400MHz+ 500MHz+ 600MHz+ 800MHz+ 1.0GHz+ 1.2GHz- 1.4GHz- 1.6GHz- Vend-
  Feature Capability: IsocFC+ LDTSTOP+ CRCTM- ECTLT- 64bA- UIDRD-
  Link Frequency 1: 800MHz
  Link Error 1: <Prot- <Ovfl- <EOC- CTLTm-
  Link Frequency Capability 1: 200MHz+ 300MHz+ 400MHz+ 500MHz+ 600MHz+ 800MHz+ 1.0GHz+ 1.2GHz- 1.4GHz- 1.6GHz- Vend-
  Error Handling: PFlE+ OFlE+ PFE- OFE- EOCFE- RFE- CRCFE- SERRFE- CF- RE- PNFE- ONFE- EOCNFE- RNFE- CRCNFE- SERRNFE-
  Prefetchable memory behind bridge Upper: 00-00
  Bus Number: 00
 Capabilities: [e0] HyperTransport: MSI Mapping

00:00.1 RAM memory [0500]: nVidia Corporation C51 Memory Controller 0 [10de:02fa] (rev a2)
 Subsystem: Giga-byte Technology GA-M55plus-S3G [1458:5000]
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR+ <PERR-

00:00.2 RAM memory [0500]: nVidia Corporation C51 Memory Controller 1 [10de:02fe] (rev a2)
 Subsystem: Giga-byte Technology GA-M55plus-S3G [1458:5000]
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-

00:00.3 RAM memory [0500]: nVidia Corporation C51 Memory Controller 5 [10de:02f8] (rev a2)
 Subsystem: Giga-byte Technology GA-M55plus-S3G [1458:5000]
 Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-

00:00.4 RAM memory [0500]: nVidia Corporation C51 Memory Controller 4 [10de:02f9] (rev a2)
 Subsystem: Giga-byte Technology GA-M55plus-S3G [1458:5000]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0

00:00.5 RAM memory [0500]: nVidia Corporation C51 Host Bridge [...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments